Announcement

Collapse
No announcement yet.

Physical Material with landscapes

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Physical Material with landscapes

    I assigned physical materials to all my landscape layers and my blueprint always return "Default" surface type. Other materials (no landscapes) work fine and return correct surface type.

    My blueprint looks like this:
    Click image for larger version

Name:	footsteps.jpg
Views:	1
Size:	51.7 KB
ID:	1134465

    What's wrong?

    #2
    I don't know what happened but after restart Unreal Editor it works fine! ... Bug?

    Comment


      #3
      Hello Kodmistrz,
      what is this physical materials? Is this like a wind? I did not know what do you exactly mean with this Physical materials?
      Kind regards,
      Andreas

      Comment


        #4
        https://docs.unrealengine.com/latest...ide/index.html

        With physic materials you can add different e.g impact effects for different surfaces. Just as an example -> when you hit a wood surface the impact should be red and when you hit stone, it should be blue (both different materials should have a physic material assigned to them)

        Comment


          #5
          Originally posted by kodmistrz View Post
          I don't know what happened but after restart Unreal Editor it works fine! ... Bug?

          i can confirm this! Had the same problem, same node, same effect and solution.

          Comment


            #6
            Me too! Any solutions would be welcome.

            Ta,

            Comment


              #7
              I had same problem Checking "Generate Overlap Events" solved it.

              Click image for larger version

Name:	enable1.jpg
Views:	1
Size:	75.6 KB
ID:	1115597
              Advanced 3d Footprints | Videos | Open Source Mine Sweeper

              Comment


                #8
                Originally posted by NanoVoxel View Post
                I had same problem Checking "Generate Overlap Events" solved it.

                [ATTACH=CONFIG]110681[/ATTACH]
                Thanks a bunch! This fix worked for me, though I cannot understand why it possibly would have anything to do with returning the correct physical material.

                Comment


                  #9
                  Originally posted by Nightmask3 View Post
                  Thanks a bunch! This fix worked for me, though I cannot understand why it possibly would have anything to do with returning the correct physical material.
                  It must be tied in with "can receive hit"
                  Advanced 3d Footprints | Videos | Open Source Mine Sweeper

                  Comment


                    #10
                    Originally posted by NanoVoxel View Post
                    It must be tied in with "can receive hit"
                    That sounds plausible, but the hit actor was always correctly returned as the heightfield collision component for the landscape, even without checking the 'can receive hit' option. The only issue was that the physical material was always returning incorrectly. I'm under the impression that this may be a bug.

                    Comment


                      #11
                      pulling up an old thread here - but a little more info:
                      sculpting a segment updates the physics material for that section
                      Checking and unchecking "generate overlap events" results in the new physics material working

                      From this, it seems that either action causes the collision to be updated, making this a bug, as the collision should be updated when changing physics material
                      See my PortalsBP on the marketplace
                      Currently working on Wheelz2 and Zario

                      Comment

                      Working...
                      X