Announcement

Collapse
No announcement yet.

Blender 2.73a and 2.74 working export to UE4 settings for various types

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Blender 2.73a and 2.74 working export to UE4 settings for various types

    Ok so I spent a few hours really working through the Blender to UE4 pipeline and had a pretty frustrating time of it. That said, I have now got a set of 'rules' that work really well.

    1. This has only been tested on Blender 2.73a and 2.74 (2nd Test Build) on OS X
    2. This assumes you are using Blender standard -Y as your 'Forward'

    In terms of UE4, there are 3 types of assets that I have tested, Static Meshes (no joints/skinning etc.), Skeletal Meshes (using Armatures, no animations, for example a character in T-Pose), Skeletal Animation (Animation assets - basically just the Armature(s) exported to play on the Skeletal Mesh previously exported).

    Unfortunately there seems to be a new 180˚ flip on one of these assets in Blender 2.74 so the import settings into UE4 are slightly different.

    Blender Scene Setup
    Click image for larger version

Name:	Blender Scene Setup.png
Views:	1
Size:	52.1 KB
ID:	1146101

    So set the scene up as most people have already agreed as Metric and the scale at 0.01 this means we are working in cm's.

    Example of the test mesh and its size
    Click image for larger version

Name:	Blender Units.png
Views:	1
Size:	77.7 KB
ID:	1146102

    You can see that Blender will show you the units in meters so something that is 250cm will be shown as 2.5m


    2.73a and 2.74 (Test Build 2) Export Settings

    Static Meshes
    Click image for larger version

Name:	Blender Export Static Mesh Settings.png
Views:	1
Size:	37.6 KB
ID:	1146103

    Skeletal Meshes
    Click image for larger version

Name:	Blender Export Skeletal Mesh Settings.png
Views:	1
Size:	37.9 KB
ID:	1146104

    Skeletal Animations
    Click image for larger version

Name:	Blender Export Skeletal Animation Settings.png
Views:	1
Size:	37.9 KB
ID:	1146105

    Note Selected Objects tick box, you need to select the Armature(s)

    Importing into UE4 from Blender 2.73a

    Static Meshes
    Click image for larger version

Name:	Import Static Mesh Settings2.73a.png
Views:	1
Size:	84.0 KB
ID:	1146106
    Note Yaw is +90˚, Scale is 0.01

    Skeletal Meshes
    Click image for larger version

Name:	Import Skeletal Mesh Settings2.73a.png
Views:	1
Size:	88.8 KB
ID:	1146107
    Note Yaw is +90˚, Scale is 0.01

    Skeletal Animations
    Click image for larger version

Name:	Import Skel Animation Settings2.73a.png
Views:	1
Size:	63.4 KB
ID:	1146108
    Note Yaw is -90˚, Scale is 1

    Importing into UE4 from Blender 2.74 (Test Build 2)

    Static Meshes
    Click image for larger version

Name:	Import Static Mesh Settings2.74.png
Views:	1
Size:	83.8 KB
ID:	1146109
    Note Yaw is -90˚, Scale is 1

    Skeletal Meshes
    Click image for larger version

Name:	Import Skeletal Mesh Settings2.74.png
Views:	1
Size:	88.4 KB
ID:	1146110
    Note Yaw is -90˚, Scale is 0.01

    Skeletal Animations
    Click image for larger version

Name:	Import Skel Animation Settings2.73a.png
Views:	1
Size:	63.4 KB
ID:	1146108
    Note Yaw is -90˚, Scale is 1

    So the good news is in 2.74 the rotations are now unified. The Scale still is not that is why you cannot export/import a skeletal mesh with it's animations. When looking at the nodes of the FBX's in C4D, the Armature (which is basically the Root in UE4) has scale set on it, that screws things up. This only happens when you export Armature + Mesh.

    Anyway, I'll report my findings on Blenders bug tracker too and hope this is useful for everyone.

  • #2
    Added here https://developer.blender.org/rBAf42...7fe9347e#71933.

    Also I forgot to say, these settings give you a working PHAT asset without any messing around. Very useful plus all the improved meshes, skeletons are oriented with X Forward.

    Click image for larger version

Name:	Screenshot 2015-03-08 22.11.27.png
Views:	1
Size:	864.2 KB
ID:	1070398
    Last edited by Anadin; 03-15-2015, 07:57 PM.

    Comment


    • #3
      Hey Anadin, have you had any luck doing the above while keeping compatibility (without need for re-targeting) with the Standard UE4 Mannequin? The reason I ask is because if I want to add a rigged clothing mesh (to add in as an extra body part in UE4 mesh settings) we would need blender to import and then export the Standard UE4 Mannequin without messing up any of the information. So far, while I have no problem creating custom, non-compatible assets for import into Unreal, I cannot for the life of me, get assets that are compatible with the UE4 Standard Mannequin (which is the defacto standard for workshop assets).

      I know some of the work-arounds, and that can get me compatible animation, which I can re-target onto the UE4 Standard Mannequin, at which point compatibility is achieved, but this method will not work when you need a compatible character skinned mesh or a compatible clothing/armor skinned mesh that needs to attach to and follow along with the Standard Man's animations (and still be a fully compatible asset for the UE4 Workshop Store).

      Thank you. And so far as I can see, if this one last little bit is fixed, Blender's import/export for .FBX will be able to do everything.

      EDIT: your Attachment 30054 link isn't working for me ATM.
      Last edited by Cancer; 03-15-2015, 08:19 AM.

      Comment


      • #4
        I was just doing similar test myself because I to notice the difference in 2.74, Great post really useful stuff!

        I feel like blender is right now coming really close to an almost perfect io with fbx. If the scale gets fixed I will be a really happy be

        Comment


        • #5
          @Cancer (fixed the attachment, thanks)

          So my method to get my character here imported and reexported was to know some things about it. For example I knew it was originally -Z Forward and Y Up, I knew (by trial and error) that I had to scale it by 300x so this is now my default preset for importing C4D meshes/rigs.

          Click image for larger version

Name:	BlenderImportFromC4D.png
Views:	1
Size:	27.7 KB
ID:	1070408

          The very first thing I do is make sure my import is facing the right way (-Y Forward) and is scaled roughly correct (make a quick Cube), then delete the cube, select everything in the scene and Apply Rotation and Scale. Now verify the size of the mesh and that the animations still work.

          At this point you have a 1:1 scale correctly rotated mesh/armature etc.


          For the Epic guy I had to have +Y Forward, Z Up, Scale 100 plus a couple of other tick boxes

          Click image for larger version

Name:	BlenderImportUE4Guy.png
Views:	1
Size:	27.3 KB
ID:	1070409

          Once again select all and Apply Rotation Scale, then start modifying.
          Last edited by Anadin; 03-15-2015, 09:37 PM. Reason: fixing attachments

          Comment


          • #6
            PS, you may not need the Ignore Leaf Bones, it does make the feet point in a strange way

            Comment


            • #7
              Anadin, bear with me here, lets say we want to make a simple rigged Jacket model that can be added or removed easily.

              Once you got your default UE4 Man into blender (with your settings), and made your modifications (lets say you keep the rig, add a simple jacket model and rig it with automatic weights, then delete the Man geo so only the Jacket and Rig are left.

              Now you do all your settings you get it back into UE4 but when you import, you have to have all your settings + in the first category "Mesh", you have to pull down the "Skeleton" entry and select the existing UE4 skeleton (because we are adding a jacket to him). Next, after your jacket is imported, you would go to the UE4 Standard Man inside of UE4, open his Mesh window, and on the Mesh Details panel, you would pull down the option for "Additional Body Part > Add Mesh" and then select your newly imported Jacket. Now switch over to the Animation tab and play through a few of the default animations and see if the jacket follows along nicely or is completely messed up???

              If you can get that working properly let me know, that is specifically what I am after, I have no problems with anything else. My first try using your settings and methods still doesn't work for this, I'll try again some more later. Let me know, thank you so much.
              Last edited by Cancer; 03-16-2015, 12:36 AM.

              Comment


              • #8
                I don't understand why you've changed the scale like that. The way it is by default works perfectly.

                1 unit in blender is 1 unit in UE. Any reason for changing the import scale to .01?

                Comment


                • #9
                  Originally posted by Anadin View Post
                  Also I forgot to say, these settings give you a working PHAT asset without any messing around.
                  Thanks for posting these settings! I haven't tried them yet (first i must do my animations), but could you explain this sentence a little? Do you mean that with these settings, imported mesh will already have 'ready-to-go' physics asset (so it can be used for ragdoll) ? I always found it frustrating and time consuming to create working physics asset (scale volumes & set up limits, etc. for every bone, for every character) and it would be great if this process could be automated somehow.

                  Comment


                  • #10
                    Originally posted by Slavq View Post
                    Thanks for posting these settings! I haven't tried them yet (first i must do my animations), but could you explain this sentence a little? Do you mean that with these settings, imported mesh will already have 'ready-to-go' physics asset (so it can be used for ragdoll) ? I always found it frustrating and time consuming to create working physics asset (scale volumes & set up limits, etc. for every bone, for every character) and it would be great if this process could be automated somehow.
                    Yup this is the way to get you 1:1 so PHAT is all correctly scaled.

                    @thorax its not actually 1:1 when you start separating the different types of assets. You have to have Blender in CMs / Blender Unit and I find if you do the scale on export things go horribly wrong.

                    This is meant as a method that works now but also as a start of me hopefully contributing more to BF about issues to get them to work 1:1 with all asset types.

                    Comment


                    • #11
                      Originally posted by Anadin View Post
                      Yup this is the way to get you 1:1 so PHAT is all correctly scaled.

                      @thorax its not actually 1:1 when you start separating the different types of assets. You have to have Blender in CMs / Blender Unit and I find if you do the scale on export things go horribly wrong.

                      This is meant as a method that works now but also as a start of me hopefully contributing more to BF about issues to get them to work 1:1 with all asset types.
                      Just so you know, there is another way to do it, that is way easier. Set blender to Meters and leave scale at 1. This lets you work in a very nice version of the metric system, where grid scale at 1, is 1 meter, and you can play with the grid setting for different snappings, etc.. You also don't have to play with the camera's far clipping plane this way. Then on import, leave the import scale at 1. On export, the export scale becomes 100. Basically the same as what your doing but a slightly different and for some probably more convenient way. GL. Let me know if you have any luck on my previous question/inquiry.

                      Comment


                      • #12
                        Ok, i did that leave the meters to 1 and scale 100 the UE4 importer, that works. Only i dont understand the part with exporting only the armature and then retarget to the exported only mesh, any help here?

                        Comment


                        • #13
                          Originally posted by Akira_San View Post
                          Ok, i did that leave the meters to 1 and scale 100 the UE4 importer, that works. Only i dont understand the part with exporting only the armature and then retarget to the exported only mesh, any help here?
                          I wasn't giving general instructions for people to follow Akira, I was asking the "Anadin" (specifically) to help trouble shoot something "that I dont' think we can do yet" to see if he could get it working. Don't follow that.

                          Use this if you are stuck: https://www.youtube.com/watch?v=Ayp1lof0RJU or follow Anadin's instructions to the letter. Don't mix and match posts/methods, that won't work. GL
                          Last edited by Cancer; 03-17-2015, 11:21 AM.

                          Comment


                          • #14
                            Good point, back to topic. My question was no correct, but anyway.

                            Comment


                            • #15
                              Hi @Cancer, agreed it should work that way but I found I could not succesfully apply Scale and Rotation to imported animations when I leave the Blender scale at 1. I think perhaps that is a bug I should report to Blender.

                              The rotations are important too, anyway this a work in progress to see if we can get it all fixed, it is a pain at the moment

                              Comment

                              Working...
                              X