Announcement

Collapse
No announcement yet.

Blender 2.73a and 2.74 working export to UE4 settings for various types

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    Great insight in your workflow and I would say this can totally be adapted.

    Comment


      #17
      I am running with same settings as Anadin with the 0.01 scale.
      One thing I notice is that if you use GoB which is like Zbrush GoZ but for blender you may also notice that now you have scale on your models that Zbrush really don't like.
      I personally don't like to have to unify all the time when I have multiple Subtools in Zbrush. So I changed the GoB addon to work with the 0.01 setting, so Zbrush gets the scale it likes.
      So I thought I post it here because somebody may have had the same problem. Use at your one risk and remember only use this if you have 0.01 setting on the scale in Blender.

      http://www.mediafire.com/download/8f...he8/GoB_UE4.7z

      Comment


        #18
        Originally posted by Anadin View Post
        Hi @Cancer, agreed it should work that way but I found I could not succesfully apply Scale and Rotation to imported animations when I leave the Blender scale at 1. I think perhaps that is a bug I should report to Blender.

        The rotations are important too, anyway this a work in progress to see if we can get it all fixed, it is a pain at the moment
        Thanks for your workflow. Will try this this evening. I love Blender but the export process has been a royal pain in the @#$. I get a lot of "floating" models in the PHAT and of course the ginormous physics asset...which is cramping my development process. I've spent more time messing with imports and exports than creating. Hopefully this will give my butthurt ointment a rest.

        Comment


          #19
          Originally posted by vanillaf4i View Post
          Thanks for your workflow. Will try this this evening. I love Blender but the export process has been a royal pain in the @#$. I get a lot of "floating" models in the PHAT and of course the ginormous physics asset...which is cramping my development process. I've spent more time messing with imports and exports than creating. Hopefully this will give my butthurt ointment a rest.
          Same feelings here If you have problems with floating, check me thread HERE.

          To the topic, when i import with Yaw +/- 90 degrees, my character is turned sideways in Persona. So i leave Yaw value at 0 and it's ok, but maybe it's wrong? I don't understand why you set Yaw to +/-90, should characters face X axis (red) or Y (green) when droppen into scene?

          Comment


            #20
            It's going to depend on how your character is sitting in Blender. I'm adamant about using the default facing in Blender because looking at the front of my character when in side view just....no.

            Just make sure all your assets have the same direction, the physics asset, the animation, etc. As long as they're all matching up it should be good I would think.

            I just make sure my assets are facing the same way as the default character asset that's included in UE4.

            Oh and that's not the floating I'm talking about. My guys float like they're on a tower lol. I can handle a little floor gap.
            Last edited by VidemusOKC; 04-06-2015, 11:22 AM.

            Comment


              #21
              I do the -90˚ in the importer because Blender forward is -Y and UE forward is +X

              Comment


                #22
                For you guys working with Armature:
                If you set blender world scale to 1.0/metric and also set export scale to 1.0, the armature scale wont get messed up.
                In UE4 set the import scale to 100.

                You may get an error during import stating that physics asset can not be generated because bones are to small.
                On the import mesh -> create -> physics asset -> set min bone size to 0.05 -> works fine

                Ive been setting up blendspaces and so far i did not run in any further trouble, but i took me a whole weekend to figure out the blender exporter scaling mess on armature. I hope they will fix this soon.

                Comment


                  #23
                  Dont listen to what i had to say. Do it the way OP describes. Took me some time to realize physics asset is messed up when using my method -.-

                  Comment


                    #24
                    @Rouli, darn! I was quite excited when I saw your post. yeah so far this is the only successful method I have found.

                    Comment


                      #25
                      Originally posted by Anadin View Post
                      @Rouli, darn! I was quite excited when I saw your post. yeah so far this is the only successful method I have found.
                      I can't get it right with this settings.. I export something with X 4.805cm, Y 6.859cm and Z 1.664cm but when I import in UE4 the approx size is 480x685x166 which I guess is way to big?


                      I applied everything / did use Metric and Degrees in blender and imported everything with scale 1.
                      Last edited by AntonieB; 05-16-2015, 06:59 AM.

                      Comment


                        #26
                        Hmm yeah your size in UE4 should end up as 4.8x6.8x1.6 which is pretty small, UE units are cm.

                        Um did you use 0.01 in your import scale?

                        It seems mont29 has finally fixed the scale stuff for Blender 2.75 (not had a go with the dev build yet but certainly gonna update this once I do)

                        Comment


                          #27
                          Hello!

                          I am beginner in Unreal Engine and 3D modelling. I made a character in Blender and animated it. Following this tutorial, I am trying to import the character and it's animations in the FBX format. But I am confused about how to export the character model and animation separately. I tried to follow the images given in the post and check/ uncheck the correct options. But I am on Blender 2.70 and my Export FBX options look like this:
                          Click image for larger version

Name:	Export_Menu.jpg
Views:	1
Size:	74.5 KB
ID:	1079609

                          And I get empty FBX files after exporting. Could someone help me figure out where I might be going wrong?

                          Hoping it's not too noob a question! ( :

                          Thanks in advance.

                          Comment


                            #28
                            hmm, I didn't play much with Blender pre 2.73 and 2.74 first time I got serious with it, I'm not sure if 2.7 even exports using FBX 7.1 I'm afraid I don't know. I can confirm a lot of these scale problems seem to have been fixed with 2.75 though.

                            Comment


                              #29
                              Works with Blender verion 2.75 RC

                              Originally posted by Anadin View Post
                              hmm, I didn't play much with Blender pre 2.73 and 2.74 first time I got serious with it, I'm not sure if 2.7 even exports using FBX 7.1 I'm afraid I don't know. I can confirm a lot of these scale problems seem to have been fixed with 2.75 though.
                              Hey Anadin,

                              Thank you so much for your reply. I downloaded the release candidate version of Blender 2.75 and followed all your steps from the beginning. And it works! I don't think I need to scale it down to 0.010 anymore, because that just makes the mesh really tiny in UE4. I was a bit confused with the extra option in the FBX export menu - "Key All Bones". It was checked by default, so I kept it as it is. And things seem to be working quite okay! ( :

                              Thanks again.

                              Cheers!
                              Ashin

                              Comment


                                #30
                                hey Anadin, thanks so much for your time getting this to work

                                Though I have a problem, I have basically copied and pasted your settings straight to blender 2.75, though whenever I import to ue4 I get 2 warnings, one about smoothing groups, the other about degenerate tangents being missing, and therefore ue4 says it will result in incorrect shading, low and behold my entire mesh becomes pitch black after building the project. Anyone else has this issue?

                                Comment

                                Working...
                                X