Announcement

Collapse
No announcement yet.

Converting BSP to Statoic Mesh, strange lighting effect.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Converting BSP to Statoic Mesh, strange lighting effect.

    Hi All

    Made a room out of BSP.

    What I normally do is, Select all, Convert to Static mesh. Export then re-import.

    That generally works, but in the occasion it does not.

    The one on the right is BSP, then one on the left is the Static Mesh.

    Click image for larger version

Name:	Capture.JPG
Views:	1
Size:	32.0 KB
ID:	1144371

    Regards

    Narg
    http://www.seven-mountains.eu/


    #2
    Have you checked your UVMap ... generally I find that the UVMap is set to index 0 but the auto generated UV is normally in index 1. Open the static mesh and check where the proper UV is and make the change. I am not in front of my dev machine so I can't tell you exactly where it is.

    Also ... did you redo the lighting after you brought the static mesh back in to the map?
    Quinton Delpeche
    Founder - Gobbo Games | Designer - The Colony 2174 (Board Game) | Developer - Riders of Asgard

    Comment


      #3
      Hi

      I ticked - Recompile Normals.

      Did the job.

      Thanks for pointing me in the right direction.

      Narg
      http://www.seven-mountains.eu/

      Comment


        #4
        Awesome ... glad you came right. 8-}
        Quinton Delpeche
        Founder - Gobbo Games | Designer - The Colony 2174 (Board Game) | Developer - Riders of Asgard

        Comment


          #5
          My Bad

          I was perfect until the lighting was rebuilt.

          Sorry, thanks for the help anyhow.

          Narg
          http://www.seven-mountains.eu/

          Comment


            #6
            You might want to check the lightmap resolution. The default for converting to static mesh is 4. That's terribly low. I use 64 as an absolute minimum. I use 512 or even 1024 if needed.
            Strife - 1996 - Remake

            Comment


              #7
              Originally posted by awilliams1701 View Post
              You might want to check the lightmap resolution. The default for converting to static mesh is 4. That's terribly low. I use 64 as an absolute minimum. I use 512 or even 1024 if needed.
              Oh yeah ... I also set mine to 64 by default. Sorry forgot about that. 8-{
              Quinton Delpeche
              Founder - Gobbo Games | Designer - The Colony 2174 (Board Game) | Developer - Riders of Asgard

              Comment

              Working...
              X