Announcement

Collapse
No announcement yet.

MMO Starter Kit

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Hello Calhoun, thanks for your answer, i already seen whole docs to see how its works, i have added 'Energy' but i can't even do works 'if player attack energy increase like 10% by shot ' so else i have heal+mana and energy, in Database+php files and in the 2 blueprints functions like its writed in the docs. But my question was more like how add caracteristics complete and assign server to say : if you create a warrior ( or anything other class ) : set strenght to : 20, stamina : 50 etc. ( and after modify this if people have item that up this stats ). Then if player have more strength -> attack stronger -> spell stronger etc. I'm maybe not really strong in blueprint yet, but if you have a start of idea really thanks.

    About your problem, i solved it yesterday night, i hope its will help you. I have re read again like 15time doc and so i rebuild project. then i log, create one character BUT I NOT ENTER WORLD, i just quit. Then i go in database and changed id to 0 in character id ( not user table ). Then i switch to dedicated server, desert map, play and i will have my character ( with class ) that will spawn ( with same name you writed normally ). But each time you have to play with map, you cant log with Start map. If you want add an other character and play with, just create one again, switch his ID to 0 then you will play with it.

    I had this error like you because it seems not possible to play in editor by starting menu ( even if i think its worked before ).
    Last edited by KamiKZZ; 11-22-2016, 05:16 PM.

    Comment


      Hey Kami, thanks a bunch dude. Your answer helped me find the issue. Anybody else get weird choppy performance when playing from the start map.

      Comment


        i downloaded a clean "install game" (to test your server). I did purchased the kit but its easier to download the game and see the features. I tried checking the animated loading screen on the live server but I think it is not working. It just shows up grey and a loading sign.. I think a mini message aswell (tip?)

        regards

        Comment


          No problem calhoun, it's nice that its work again

          Else for my stats things, anyone could help? Thanks !

          Comment


            Anybody know how to disable bandit spawns. I deleted the from the map but they continue to spawn if I play through the start map.

            Comment


              i'm a quite busy at moment but i try to help you. I actualise this post part for part when i have time. It costs to much time to make a perfect answere or example for each question but i can give you hints.

              1. ( if you create a warrior ( or anything other class ) : set strenght to : 20, stamina : 50 etc. )

              Click image for larger version

Name:	BJYO6_create2.jpg
Views:	1
Size:	129.8 KB
ID:	1118882

              is where the stas are set for a new character. You can make an if statement for each class like (warning its only pseudocode you must look how it's done in the mmocreatecharacter.php and i'm not good in php) if class == 1 (warrior) $stmt = $conn->prepare("INSERT INTO characters VALUES (NULL, ?... = stats that you want) else if class == 2(rogue) $stmt = $conn->prepare("INSERT INTO characters VALUES (NULL, ?... = other stats that you want).

              2. (Then if player have more strength -> attack stronger -> spell stronger etc.)

              Click image for larger version

Name:	UbAqb_dmg2.jpg
Views:	1
Size:	213.4 KB
ID:	1118884

              A quick example how you can add dmg. in this case the damage is normally calculated between 50 and 150% of attack power and after this we add 0,5 damage for each point of strength.


              3. (The NPCs won't move or animate in certain areas on that map. )

              Is this set to RoamingAICon for the new npcs?

              Click image for larger version

Name:	myzsk_nps.jpg
Views:	1
Size:	90.9 KB
ID:	1118885

              4. (Anybody know how to disable bandit spawns. I deleted the from the map but they continue to spawn if I play through the start map. )

              I can't reproduce this error. My first question is, do you save the map after you delete them? And how can you play from the start map? I thought it's only possible after compile and package and play outside the editor.
              If it's the case(you packaged the game) and then the error occurs it is possible that a Full Rebuild can help.

              Click image for larger version

Name:	v9269_rebuild.jpg
Views:	1
Size:	69.0 KB
ID:	1118886
              Attached Files
              Last edited by Gerrod; 11-24-2016, 09:59 AM.

              Comment


                So I haven't packaged the project yet as it isn't finished. On the other hand my start map links me directly to the Desert Rally Race map. After having edited the desert rally race map and removed all the npcs, the bandits (and only the bandits) still remain.

                Comment


                  I'm working on a project with a friend. I made a second database for him to work, we then merge his blueprints into my master project.

                  However he's having trouble entering world and getting this error.

                  Wrong client version - please make sure you have the latest client.

                  Comment


                    Any update for new engine ? new features ? Something ? lol

                    Comment


                      Hello everyone, just wanted to drop a quick post here to let folks know I was unable to do any work on the videos or the kit since June due to family issue's that arose out of the blue. I do not want to bring the thread down in any way or derail it, so I'll just say it was a very heart breaking time for me with a family member passing away.

                      I am now back and plan to hopefully pick up where I left off with the videos and kit and see what all has happened since I was last here. Going to take a bit to get back in the flow so bear with me.

                      Nemodain

                      Comment


                        Hey Nemo! Sorry to hear about the tough time with your family, I've been there too, no fun.

                        As for the kit, I believe codespartan is looking into how to port the project to 4.14, and has already released a version for 4.13. I've been working with the 4.12 kit version with some minor changes posted by codespartan for porting 4.12 to 4.13, but appear to be having some server issues when making the changes sqshi posted to make the kit open with 4.14, so I'm waiting for the official 4.14 port to proceed with development.

                        Comment


                          Gerrod: The code you posted will let two different players request the same character name at the same time, if you run servers in parallel.
                          This is because you first attempt to select to check for name free, and then attempt to insert, without keeping both operations in a single transaction.

                          A better option would be to make sure that you have a unique index on the character name field, and just run the insert; if the insert fails, tell the user that the name is taken.
                          That way, the check-for-available and actually-create-character operation is a single, atomic operation.

                          Comment


                            Originally posted by Piepants View Post
                            Hey Nemo! Sorry to hear about the tough time with your family, I've been there too, no fun.

                            As for the kit, I believe codespartan is looking into how to port the project to 4.14, and has already released a version for 4.13. I've been working with the 4.12 kit version with some minor changes posted by codespartan for porting 4.12 to 4.13, but appear to be having some server issues when making the changes sqshi posted to make the kit open with 4.14, so I'm waiting for the official 4.14 port to proceed with development.
                            Thanks for the words and the update, will read through all the forum today and hopefully get caught up on the Engine version.

                            Nemo

                            Comment


                              Oh Nemo, I think it was you I was talking to about optimizing landscape auto material and how it was laggy on large landscapes? So I gave up on it and found an auto terrain cover plugin, free, by Shoiko. I really like it, and he has a release for 4.13 I've been using and also a 4.14 version which I'm waiting to use once we can port this kit to 4.14. I've been working with 4k x 4k landscapes from worldmachine with no lag at all. Link is below if you're interested!

                              https://forums.unrealengine.com/show...ver-V3-Release

                              Comment


                                Originally posted by Piepants View Post
                                Oh Nemo, I think it was you I was talking to about optimizing landscape auto material and how it was laggy on large landscapes? So I gave up on it and found an auto terrain cover plugin, free, by Shoiko. I really like it, and he has a release for 4.13 I've been using and also a 4.14 version which I'm waiting to use once we can port this kit to 4.14. I've been working with 4k x 4k landscapes from worldmachine with no lag at all. Link is below if you're interested!

                                https://forums.unrealengine.com/show...ver-V3-Release
                                I am always interested in cool new stuff, thank you for the link. Feels like I am starting over since I have been out of the loop for a few months. Hopefully 4.14 release will be out soon and I can get started on videos for that version since so much has changed. I'll be around, feel free to update me on anything I have missed.

                                Nemo
                                Last edited by Nemodain; 12-01-2016, 11:15 AM.

                                Comment

                                Working...
                                X