Announcement

Collapse
No announcement yet.

MMO Starter Kit

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Hey Guys...

    Tried to use VS Community 2015 with the kit and blew up EVERYTHING high wide and ugly. Is there a switch I need to use ??
    Clifford Brock

    Gamer / Tinkers with MMO Kit
    Game: Claws&Paws

    Comment


      Originally posted by Tarly View Post
      Hey Guys...

      Tried to use VS Community 2015 with the kit and blew up EVERYTHING high wide and ugly. Is there a switch I need to use ??
      I have been using VS 2015 for some time now, no issues, here is version numbers and info of the what I have...

      Click image for larger version

Name:	vs2015.jpg
Views:	1
Size:	89.6 KB
ID:	1103394

      I have had to rebuild Game Engine no less than 3 times this weekend as I keep blowing up the engine files, I am getting lighting errors when doing full build in editor, so I have definitely put VS2015 to the test.

      Click image for larger version

Name:	error.jpg
Views:	3
Size:	21.1 KB
ID:	1103396

      Something in the dollmap is generating overlapping UV maps, when I edit it things go bad. When I edit the EditorSkysphere it effects something in the main engine files and causes the spawn in spot to be under the terrain which breaks the engine.

      I just installed from inside editor when prompted.



      Nemdain
      Last edited by Nemodain; 03-28-2016, 10:43 AM.

      Comment


        Originally posted by Nemodain View Post
        You tested your database and made sure it's working? When you registered information was it saved correctly? Did you set the id number in your character account to 0? that has to be done to run in editor. Did you try running in selected view port with run dedicated server checked?

        [ATTACH=CONFIG]85727[/ATTACH]
        I have already written, done everything as in the video, the database is running, the account is created, the id is set to 0 , the checkbox run dedidacted set, run the scene , appears Loading and then nothing happens, and Visual Studio 2015 and you have to do the project configuration Development Server , what can be the causes of these phenomena?

        Comment


          Dark1985,

          Did you do a development build?

          You might have to contact CodeSpartan on skype, he has much more knowledge on troubleshooting over the internet.


          Nemodain
          Last edited by Nemodain; 03-28-2016, 04:28 PM.

          Comment


            So I broke many things this weekend and had to get some rebuilds made, in the process I made a small video fixing some of the errors I had when doing a Build inside the editor. I will post a link here if you wish to pop over and check them out. Here is the list of items I worked on...

            1.) Deleting folders that reappear
            2.) Missing Bones on Mixamo FBX import fix
            3.) Lake 2 error and Spot Light error
            4.) Override materials on static mesh

            I still have yet to find the overlapping UV mesh error, but will continue to look. If someone here has found a fix please let us know.

            Click image for larger version

Name:	error.jpg
Views:	3
Size:	21.1 KB
ID:	1103428

            Video Link: Few Error Fixes

            Nemodain
            Last edited by Nemodain; 03-28-2016, 05:08 PM.

            Comment


              Hey guys,

              I as posted couple days ago... I seem to have busted my kit.... LOL... again. This time as I got things put back together. I got the error listed below. So, I FFR'd the machine, thinking I hd REALLY busted something. And, I got the same error after the FFR as before I torn the whole thing down.

              I d/l'd the engine from GitHub, in the .ZIP form. Can anyone please advise me why 4.10 still wants VS 12 or 13. The error listed below is when I double click the "GenerateProjectFiles" bat file in the UE 4 4.10 dir.

              I'd really appre any advise or help anyone can offer.

              Click image for larger version

Name:	Projectfile.png
Views:	1
Size:	39.1 KB
ID:	1103497

              I have VS 2015 community installed.
              Last edited by Tarly; 03-29-2016, 07:39 PM. Reason: Forgot to add the darn pic. lol
              Clifford Brock

              Gamer / Tinkers with MMO Kit
              Game: Claws&Paws

              Comment


                Unreal Engine requires 1 of the following devenv (Visual Studio): 2012, 2013, 2015.

                And they can't abbandon the old ones, Visual Studio isn't cheap for large companies, and 2015 community is only allowed for teams smaller and equals than 5 people.

                Comment


                  Zydronium,

                  Nemodain shows on page 21 of this thread (Near the bottom) that he uses VS 2015 Community... Has screenies of it even. I am hoping he or someone can advise me on how to set it up.. or how I am being a chowderhead and ******** it up.
                  Clifford Brock

                  Gamer / Tinkers with MMO Kit
                  Game: Claws&Paws

                  Comment


                    I didn't said 2015 isn't supported, your screenshot shows it is
                    From what I see in your screenshot is that some registry keys are incorrect. Maybe try to repair Visual Studio?

                    Comment


                      Originally posted by Tarly View Post
                      Zydronium,

                      Nemodain shows on page 21 of this thread (Near the bottom) that he uses VS 2015 Community... Has screenies of it even. I am hoping he or someone can advise me on how to set it up.. or how I am being a chowderhead and ******** it up.
                      You have a good download of Visual Studio Community 2015 with Update 1? Can launch it on it's own?

                      Don't feel bad, blew up my Source Engine this weekend had to re-download it, happens when learning, at least for me it does.
                      Last edited by Nemodain; 03-29-2016, 09:25 PM.

                      Comment


                        Yup Nemodain it does...

                        In windows 10 I go to all apps and find Visual Studio 2015 and click on it and the Start page pops right up.

                        When I click on help and about VS 2015 it is version 14.0.24720.00 update 1.

                        When I go to UE -release and get into samples, mobile starter content the project file is dated 3/29/16 I right click it and click generate VS files and it says I don't have the source code. and I am in the full engine dir... I am confused
                        Clifford Brock

                        Gamer / Tinkers with MMO Kit
                        Game: Claws&Paws

                        Comment


                          Originally posted by Tarly View Post
                          Yup Nemodain it does...

                          In windows 10 I go to all apps and find Visual Studio 2015 and click on it and the Start page pops right up.

                          When I click on help and about VS 2015 it is version 14.0.24720.00 update 1.

                          When I go to UE -release and get into samples, mobile starter content the project file is dated 3/29/16 I right click it and click generate VS files and it says I don't have the source code. and I am in the full engine dir... I am confused
                          So good copy of VS 2015 and it runs... check!

                          Right click you project and switch engine versions on your project file and see if you can generate new VS files, then try to open it. Like a Engine version 4.8 or any plain ones not sourced. Just something different than one you have now.

                          Comment


                            I did right click switch engine in the MMO kit.. Then right click and generate vs files I get the error listed above.

                            If I go to samples in the engine and do the same thing, right click switch, right click and generate VS files, I get an error about not having the source.

                            I used the link https://github.com/EpicGames/UnrealEngine from MMOkit directions, to get the engine.
                            Clifford Brock

                            Gamer / Tinkers with MMO Kit
                            Game: Claws&Paws

                            Comment


                              Originally posted by Tarly View Post
                              I did right click switch engine in the MMO kit.. Then right click and generate vs files I get the error listed above.

                              If I go to samples in the engine and do the same thing, right click switch, right click and generate VS files, I get an error about not having the source.

                              I used the link https://github.com/EpicGames/UnrealEngine from MMOkit directions, to get the engine.
                              Are you using Preview 8 of Version 11, the kit is only supported on version 10...

                              Do you have version 10.4? https://github.com/EpicGames/UnrealEngine/releases

                              I see up few threads back you said version 10, is that just plain 10? I know I had an old source of 10 that used VS 2013, maybe you need 10.4 for VS 2015? <shrug>
                              Last edited by Nemodain; 03-29-2016, 10:02 PM.

                              Comment


                                OH my... How did you find that link... the link I posted had a zip there.. and I was at the same place when I clicked the drop down to the left and d/l'd that version of 4.10... I love the link you have as it gives me 4.10.4 TY vm... I'll try that one ...
                                Clifford Brock

                                Gamer / Tinkers with MMO Kit
                                Game: Claws&Paws

                                Comment

                                Working...
                                X