Announcement

Collapse
No announcement yet.

MMO Starter Kit

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    hey guys, I am developing a dynamic server system for MMOKIT. you can find more at:
    DSS

    Leave a comment:


  • replied
    Hi, tell me how many changes need to be done to make a non-target system?

    Leave a comment:


  • replied
    CodeSpartan Now my BP_Modular_Doll is playing dead! Whoops! Something is definitely not right here.

    Leave a comment:


  • replied
    @CodeSpartan

    After some failures and restarting from ground zero, I have Greystone as the Player Character! For some reason I can't figure out, is the HUD is no longer working now. I didn't alter or change anything related to HUD at all. I know in the Greystone Character there is some input which is supposed to be replaced and haven't done that yet as I am lost there now. I haven't altered the Inventory Doll which might be linked to the HUD? (I don't know, just guessing as I did that step once before and something else happened. I know too when I package the project my Player Character is a Mannequin. Will poke around some more and will report back.
    Last edited by IFamStudios; 02-26-2020, 09:37 PM.

    Leave a comment:


  • replied
    CodeSpartan Thank You! Prior to seeing your response, I was able to get this made:



    Click image for larger version

Name:	Greystone1.jpg
Views:	761
Size:	449.5 KB
ID:	1724477






    I did the first part of this which was part 4 where I moved the walk, run and idle states I didn't do the non-combat yet as I mentioned as I tried to skip a few steps. in terms of crawling, I didn't crawl as I should have when I was learning I learned to walk first! Then again, we all learn at different speeds! I don't always get things immediately and digesting material sometimes takes me a little bit. Thanks for your guidance.

    Leave a comment:


  • replied
    CodeSpartan I believe that I have figured out what I am supposed to do here now. As I have gotten beyond step #4 in the Guide. I still need to do the same steps for the non-combat as I did for the combat. The one thing though is my screen looks a bit different than the example in the updated guide. Thanks for the update to the Doc.

    I have a screenshot I can include later if you have any questions.

    Leave a comment:


  • replied
    IFamStudios the state machines are nested below the animgraph. if you you use the arrow and open the section you will see them.

    Also while we all want to run, sometimes we have to crawl first. i would highly recommend some videos on the subject. they helped me greatly.
    https://www.youtube.com/watch?v=NYFeFUxU6DI

    Click image for larger version

Name:	machinestates.png
Views:	762
Size:	335.0 KB
ID:	1724453

    Leave a comment:


  • replied
    CodeSpartan I am confused! I have opened the Anim according to the step four and see this:


    This is where I am getting lost! I am looking for the State Machine and I am not sure where the State Machine is...

    Is that Visible (the State Machine or did I miss something?)

    Click image for larger version  Name:	Greystone_AnimBP.jpg Views:	0 Size:	443.4 KB ID:	1724419

    Leave a comment:


  • replied
    CodeSpartan I restored the connection to the chat server as per your post. After some very intense packet inspection at our firewall i found the issue with the chat server threads. We utilize iptables as our firewall and while the normal rules were all correct it seems that the game server sends packets bound for the external adapter to be routed back to the chat server. once i created a rule accepting packets on the internal interface bound for the external address all was well. we now have a stable chat and party bars. thank you for your feedback.

    Leave a comment:


  • replied
    Originally posted by IFamStudios View Post
    @CodeSpartan

    Okay, I am completely lost! I am lost on step 4 of the Changing the Player Character and the transfer of the animations. I am wanting to replace the Player Character with the Paragon: Greystone. I see to not find the TPT or whatever the documentation states. I did step 1-3 and am lost on step 4 continuing.

    So I am completely lost. I am not sure what to do.
    I've rewritten that part in the documentation for you. Some names have changed during the last refactoring, and the UE4 interface also changed significantly.

    Leave a comment:


  • replied
    @CodeSpartan

    Okay, I am completely lost! I am lost on step 4 of the Changing the Player Character and the transfer of the animations. I am wanting to replace the Player Character with the Paragon: Greystone. I see to not find the TPT or whatever the documentation states. I did step 1-3 and am lost on step 4 continuing.

    So I am completely lost. I am not sure what to do.

    Leave a comment:


  • replied
    CodeSpartan I was able to get through everything I had mentioned previously with the help of mastermikie when he and I discussed some settings that I didn't originally have correct until our discussion back and forth then I was able to fix everything and my client and server now talk remotely. That was the last week. Moving forward for me, I am stuck with customizing the Player Character and NPCs now! Thank you.
    Last edited by IFamStudios; 02-19-2020, 10:48 AM.

    Leave a comment:


  • replied
    CodeSpartan That isn't my issue now. I have a remote server and local client connecting properly as they should! Everything Client/Server is now working even the database too. The only trouble is when I create new levels which I understand because I didn't add them to the properties. The other problem now is getting lost and confused at the character skinning I mentioned above.

    Until I can digest step 4 through the rest with assigning the animations to the Player Character Anim_BP in my case, the Paragon Greystone as he is to become my Player Character I am stuck here.

    Leave a comment:


  • replied
    Originally posted by IFamStudios View Post
    the first quirk is the Character Name that is in the database isn't being displayed when playing.
    That means the server can't retrieve the character from DB. If you didn't change anything in the scripts, it means your server can't connect to DB. Does it work in editor?

    Leave a comment:


  • replied
    Originally posted by mastermikie View Post
    IFamStudios the -local option is for testing on one system without a server setup. you would run the server.exe on your local computer and then start the client with a shortcut adding -local to the end of the startup command. this allows you to test before you push it up to the external server.

    If your running a dedicated server on an external ip and are behind a firewall you may simply have the port forward incorrect. the bible states 7779 is the default for unreal. however we found ours was actually on 7790. i am not sure how we arrived at that but some further reading and searching yielded up the 7790 which in fact worked. so you may need to do some noodling about to get it sorted.
    I think you can also launch server with -local if you want it to simply connect to chat server on the same machine.

    Leave a comment:

Working...
X