Announcement

Collapse
No announcement yet.

MMO Starter Kit

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    When teaming up
    PIE: Warning: This control does not support focusing. If this is a UserWidget,Should be bIsFocusable set true
    why

    Leave a comment:


  • replied

    Originally posted by yskwork View Post
    After 2 hours, the chat is not displayed and Leave team command is invalid

    the chat server up and running, no crashed

    Re-enter the level, Local player chat shows that other players can't accept chat, leave the team command is invalid

    "starting it through Visual Studio in debug mode and run it like that. If it crashes, you'll know where the bug is"

    How to debug
    Chat is not displayed for people already on the server or for people who are connecting just now?

    Did you modify chat server in any way? And what version are you running? Bbecause I patched it a couple of times in the last year.
    I'm running a demo server and I don't have this problem, so I don't know how to reproduce it.

    Originally posted by yskwork View Post
    Local player chat shows that other players can't accept chat
    What do you mean by that?

    Originally posted by yskwork View Post
    How to debug
    How comfortable are you with C#? What I'd do is launch the chat server through visual studio, wait for the bug to occur, then put a breakpoints in the code to see where it goes wrong.

    Originally posted by KhxiSaki View Post
    hi so after i've downloaded the game from the launcher the zip file wont extract into thre game folder..why is this happening?
    The launcher isn't supposed to download a giant .7z file. The .7z only goes from deployer to server, where the php must unpack it. You're doing something wrong.

    Leave a comment:


  • replied
    hi so after i've downloaded the game from the launcher the zip file wont extract into thre game folder..why is this happening?
    Attached Files

    Leave a comment:


  • replied
    Hello Guys,
    I want to share with you some of my progress
    Click image for larger version  Name:	Untitled.png Views:	1 Size:	375.8 KB ID:	1596683Click image for larger version  Name:	Screenshot-98.png Views:	1 Size:	129.8 KB ID:	1596677Click image for larger version  Name:	hp.png Views:	1 Size:	42.3 KB ID:	1596678Click image for larger version  Name:	attack.png Views:	1 Size:	575.8 KB ID:	1596682Click image for larger version  Name:	hotbar2.png Views:	1 Size:	165.2 KB ID:	1596681Click image for larger version  Name:	hotbar1.png Views:	1 Size:	195.8 KB ID:	1596680Click image for larger version  Name:	mission.png Views:	1 Size:	94.8 KB ID:	1596679
    -completing a quest will give you XP/JP/COINS.
    -You can set prerequisite quests for each quest.
    -you can make time challenge quest.
    -you can hide/show quests at any time.
    -you can remove any quest and retake it again.
    -Each player has jp/
    xp and level. when killing any monster it will level up.
    -Resizable Hotbar.
    -players can kill each other if they are in PK mode.
    -
    Player can write public chat above itself.
    -redesigned chat windows
    Attached Files

    Leave a comment:


  • replied
    After 2 hours, the chat is not displayed and Leave team command is invalid

    the chat server up and running, no crashed

    Re-enter the level, Local player chat shows that other players can't accept chat, leave the team command is invalid

    "starting it through Visual Studio in debug mode and run it like that. If it crashes, you'll know where the bug is"

    How to debug debug
    Last edited by yskwork; 03-18-2019, 04:14 AM.

    Leave a comment:


  • replied
    Originally posted by yskwork View Post
    ok, Thank you very much! know where the bug is , the way

    Two hours later, Chat does not show,Leave the team, invalid

    the chat server up and running, no crashed,again transmission level,Chat show,but Leave the team or join the team, invalid

    new incoming level player, Chat show, level old player no see new Chat

    Debug log, How to see , .pdb file ,how to use
    Sorry, I don't understand. Do you have concrete steps to reproduce the bug? Could you try using google translate when describing it?

    Leave a comment:


  • replied
    Originally posted by KOMPLE21 View Post

    Yes. In the MMOGame i changed the default pawn class from ModularPlayerCharacter to a BP of my own, called CharacterBP and i set inside a spawn actor function at begin play depending on the class number. (0 = spawn WarriorBP ,2 = spawn MageBP and so on). This way it works on the editor (gets the default class 0, the warrior, to spawn) but i cant get this logic to work when i log in on the server. I cant seem to find the part where the server gets the command to spawn my BP instead of your default pawn. (I also tried making a child of the ModularPlayerCharacter and put that logic in there. Same results)
    1- If you plug in your own blueprints instead of existing ones, expect everything to get broken. There's a lot of links between various BPs, and they immediately get broken when you replace them. Think of placing the electronics of a Boeing into a Airbus. Why would they work, if it's completely different planes? Obviously, you can adapt them, but it requires a lot of work.
    And you could make child BPs inherit from the same class, but in-game classes do not warrant such drastic measures.

    2- The way to make different in-game classes (rogue, warrior, etc) is not by making different blueprints for each class. You should make a replicated enum (for your in-game class) on the Player State BP, and depending on its value, the model may change or other changes may take effect, depending on what different classes entail in your game.

    You should set this value in OnGetCharacter, and you should add the retrieval of this value in the associated php script.
    Last edited by CodeSpartan; 03-17-2019, 09:12 PM.

    Leave a comment:


  • replied
    Originally posted by CodeSpartan View Post

    Could you give an example of what you want to do?
    Yes. In the MMOGame i changed the default pawn class from ModularPlayerCharacter to a BP of my own, called CharacterBP and i set inside a spawn actor function at begin play depending on the class number. (0 = spawn WarriorBP ,2 = spawn MageBP and so on). This way it works on the editor (gets the default class 0, the warrior, to spawn) but i cant get this logic to work when i log in on the server. I cant seem to find the part where the server gets the command to spawn my BP instead of your default pawn. (I also tried making a child of the ModularPlayerCharacter and put that logic in there. Same results)

    Leave a comment:


  • replied
    ok, Thank you very much! know where the bug is , the way

    Two hours later, Chat does not show,Leave the team, invalid

    the chat server up and running, no crashed,again transmission level,Chat show,but Leave the team or join the team, invalid

    new incoming level player, Chat show, level old player no see new Chat

    Debug log, How to see , .pdb file ,how to use
    Attached Files
    Last edited by yskwork; 03-17-2019, 07:20 PM.

    Leave a comment:


  • replied
    Originally posted by KOMPLE21 View Post
    I got everything to work! they only question is where can i set my own classes and blueprints in the character creation? (not use the default bps)
    Could you give an example of what you want to do?

    Leave a comment:


  • replied
    Originally posted by yskwork View Post
    Two hours later, Chat does not show,why

    Leave the team, invalid
    Is the chat server up and running or not? If it crashed, try starting it through Visual Studio in debug mode and run it like that. If it crashes, you'll know where the bug is.

    Leave a comment:


  • replied
    Congratz Komple21

    Leave a comment:


  • replied
    I got everything to work! they only question is where can i set my own classes and blueprints in the character creation? (not use the default bps)

    Leave a comment:


  • replied
    Ok, so i followed the instructions for dedicated server and packaging in version 4.21 and i get this error when i m trying to create the CleanThirdPersonServer.exe and CleanThirdPersonClient.exe files. Any thoughts?
    Attached Files

    Leave a comment:


  • replied
    Two hours later, Chat does not show,why

    Leave the team, invalid
    Last edited by yskwork; 03-09-2019, 12:54 AM.

    Leave a comment:

Working...
X