Announcement

Collapse
No announcement yet.

MMO Starter Kit

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    i just wanted to say thanks for keeping this updated!
    this project started my journey in UE4 in 2015, and i still use it for inspiration.
    best wishes!

    Comment


      for any one that is interested you can take a look at what we are doing with the kit. here. https://www.facebook.com/Legacyofares/




      Comment


        That is really pretty
        Clifford Brock

        Gamer / Tinkers with MMO Kit
        Game: Claws&Paws

        Comment


          Good Day. i have a question for codespartan that concerns the chat. we are still using the 4.22 engine. we have not chosen to make the switch to 4.23 as of yet. i was perusing the source for the chat and noticed the version of the newtonsoftjson.dll included with the chat engine is dated 3/14/16 and the version included in the unreal source is dated 11/22/19. could this be the source of the problems with the chat engine? i am guessing the parts of the mmokit when compiled would be using the newer version, but the already compiled component of the chat is using the older version. just curious. additionally the version that appears in the visual studio in the source code seems to point to a version dated 1/28/16.
          Last edited by mastermikie; 12-07-2019, 04:09 PM.

          Comment


            update on my previous post. i copied the chat server source to another folder. i opened the sln and did the nuget update on the json package. i rerolled the chat with the new version and while it does run fine. it still stalls. =/ it did give me the new json with the .exe like it should and they launch and run great. but no bonus on the stall.

            Comment


              4.24 version is out:
              - no changes

              If you're updating your project yourself:
              - make sure to use the plugins shipped with the 4.24 version of the kit, because VaRest is undergoing some changes right now and the version you may get from the marketplace may not work correctly with the kit
              - replace these files, get them from the new version of the kit: https://i.gyazo.com/7af45ddc16e3bab0...8e22ad910b.png
              - you will have these errors when you open the project: https://i.gyazo.com/e72f735ae15bd7d4...3ba5404c26.png
              So open up BP_MMOPlayerState and BP_MMOInstance and fix the errors. They're simple - some VaRest nodes changed from pure to impure, so you have to make the execution white line pass through them.
              Example of how to fix: https://i.gyazo.com/2ef2b4b85d198f9a...ce94b695fa.png

              There's a known bug, where the game server timeouts from the chatserver after a couple of days of being online. I'm investigating it. Otherwise the new chat server ran perfectly for a couple of months without needing to be rebooted.
              MMO Starter Kit
              Dialogue Plugin
              Voxel Plugin
              Character Customization: Female
              Character Custmization: Male

              Comment


                hello guys
                anyone worked on server instancing or have any tutorial related to that?

                Comment


                  UE4.24

                  LogSockets: Warning: Tried to bind address with protocol None to a socket with protocol IPv4
                  LogUDPCommand: Error: Failed to bind listen socket to addr () for Matchmaking UDP

                  // InitSocket()
                  //
                  // Task: Init everything
                  //
                  bool UMatchmakingUDPComponent::InitSocket(int32 port)
                  {
                  // Prepare Temp Variables
                  bool bSuccess = false;
                  ISocketSubsystem* SocketSubsystem = ISocketSubsystem::Get(PLATFORM_SOCKETSUBSYSTEM);
                  ListenAddr->SetPort(port);

                  // Create the needed Socket
                  ListenSocket = SocketSubsystem->CreateSocket(NAME_DGram, TEXT("UDP Matchmaking"), true);
                  if (ListenSocket == NULL)
                  {
                  UE_LOG(LogUDPCommand, Error, TEXT("Failed to create listen socket for Matchmaking UDP"));
                  return false;
                  }

                  // Set config
                  ListenSocket->SetReuseAddr();
                  ListenSocket->SetNonBlocking();
                  ListenSocket->SetRecvErr();

                  // Try to bind
                  if (ListenSocket->Bind(*ListenAddr))
                  return true;

                  // Binding failed -> Log Error
                  else {
                  UE_LOG(LogUDPCommand, Error, TEXT("Failed to bind listen socket to addr (%s) for Matchmaking UDP"), *ListenAddr->ToString(true));
                  return false;
                  }
                  }
                  // InitSocket()
                  Attached Files
                  Last edited by yskwork; 01-01-2020, 07:36 AM.

                  Comment


                    Hello, can I use visual studio 2019 for MMO Starter Kit 4.24, Or do I have to use 2017?
                    Last edited by Realm Games; 01-01-2020, 07:36 PM.

                    Comment


                      Originally posted by Realm Games View Post
                      Hello, can I use visual studio 2019 for MMO Starter Kit 4.24, Or do I have to use 2017?
                      you can use both but recommend use the one in doc

                      Comment


                        I purchased the 4.23 version of the MMO Starter Kit, do I need to pay for each MMO Starter Kit Upgrade or how do I get the 4.24 update?

                        Comment


                          Originally posted by IFamStudios View Post
                          I purchased the 4.23 version of the MMO Starter Kit, do I need to pay for each MMO Starter Kit Upgrade or how do I get the 4.24 update?
                          You'll always have access to the latest version on Sellfy as long as you haven't lost your sellfy account.
                          MMO Starter Kit
                          Dialogue Plugin
                          Voxel Plugin
                          Character Customization: Female
                          Character Custmization: Male

                          Comment


                            Good evening CodeSpartan


                            Issue #1
                            I've tried about 3 times to upload the game to the ftp.
                            It does "work" partially, as I can download the game from the launcher, however not the big .pak file.

                            I also receive this error when uploading (GameUploader) the game, but yet, I can see the file uploaded in the ftp folder.

                            Click image for larger version  Name:	Untitled2.png Views:	0 Size:	55.3 KB ID:	1711553

                            how can this be fixed? I've uploaded two times the build, with the same error.
                            when I use thelauncher, it will download everything except the pak file, which is 6gb (even though it shows on the ftp folder and is "downloading" the pak from the launcher, as it says the whole game is 6.2gb)

                            To be honest, I can even download the file from the FTP and it has the same size, as my build before uploading, so it could be uploading successfully (regarding giving that error). Nevertheless, when downloading from launcher there seems to be an issue where that pak file downloads, but does not end up in the game folder (unzip issues? too big? there is no error on this part)

                            Note: this initially happened in the VPS I set up, then I tried doing it on a webhost (bluehost.com) and happened the same.

                            PS: i uploaded another project for test, with lots of file no bigger than 10mb and after 20m uploading, same error occured, so its not because of the file size.

                            Issue #2

                            No, I have not modified any source, except for the launcher images.
                            When I do a new "patch" and deploy it, I enter the website.

                            I noticed this "slash" to be probably wrong?

                            I ask because it says "deploy successfully" however when I try to download the patch file, it gets stucked. Guess what? Remaining Files: 4
                            which I believe are these four from the deploy log in the website ftp.

                            The first upload/deployment is successfully. Then I just open the game, add a new texture, or change a texture in the map (ThirdPerson default), rebuild, open gameuploader, uploads the files, and when I hit the deploy, it always (or the third time) shows these error.

                            Running deployment
                            Archives extracted successfully.
                            Copying: game/Engine\Content\EditorMaterials\PreviewShadowIndicator.m.ubulk.7z
                            -> game/prueba\Content\StarterContent\Textures\T_Wood_Walnut_D.m.ubulk.7z
                            Copying: game/Engine\Content\EditorMaterials\PreviewShadowIndicator.m.ubulk.7z
                            -> game/prueba\Content\StarterContent\Textures\T_Wood_Walnut_D.uptnl.7z
                            Copying: game/Engine\Content\EditorMaterials\PreviewShadowIndicator.m.ubulk.7z
                            -> game/prueba\Content\StarterContent\Textures\T_Wood_Walnut_N.m.ubulk.7z
                            Copying: game/Engine\Content\EditorMaterials\PreviewShadowIndicator.m.ubulk.7z
                            -> game/prueba\Content\StarterContent\Textures\T_Wood_Walnut_N.uptnl.7z
                            ZipSize.xml created successfully.Update deployed successfully.
                            Back to admin panel

                            The FTP folder created this new archive, error_log:

                            [22-Jan-2020 22:22:28 UTC] PHP Warning: copy(game/Engine\Content\EditorMaterials\PreviewShadowIndicator.m.ubulk.7z): failed to open stream: No such file or directory in /home1/ferretg7/public_html/elcom.com/ftp/index.php on line 267
                            [22-Jan-2020 22:22:28 UTC] PHP Warning: copy(game/Engine\Content\EditorMaterials\PreviewShadowIndicator.m.ubulk.7z): failed to open stream: No such file or directory in /home1/ferretg7/public_html/elcom.com/ftp/index.php on line 267
                            [22-Jan-2020 22:22:28 UTC] PHP Warning: copy(game/Engine\Content\EditorMaterials\PreviewShadowIndicator.m.ubulk.7z): failed to open stream: No such file or directory in /home1/ferretg7/public_html/elcom.com/ftp/index.php on line 267
                            [22-Jan-2020 22:22:28 UTC] PHP Warning: copy(game/Engine\Content\EditorMaterials\PreviewShadowIndicator.m.ubulk.7z): failed to open stream: No such file or directory in /home1/ferretg7/public_html/elcom.com/ftp/index.php on line 267


                            After this error, the launcher just stops working: it would stop at 17% of a download, getting stucked/not downloading anymore. No matter what.

                            regards
                            Last edited by Namesis; 01-23-2020, 09:02 PM.

                            Comment


                              hello Namesis. i might be able to give you some insight here.

                              Issue #1
                              I've tried about 3 times to upload the game to the ftp.
                              It does "work" partially, as I can download the game from the launcher, however not the big .pak file.

                              -----------------------------------------------
                              we ran into this very same issue with out uploader at first. the issue i believe was the path listed for upload.

                              this is from the documents here: https://docs.google.com/document/d/1...q6-Ix3Eyzs/pub

                              1. Go to uploader/ folder, open Settings.ini and fill in the values, for example:

                              GameDirectory=D:\MyGame\WindowsNoEditor your packaged game folder (no trailing slash)

                              TempFolder=I:\temp a folder to store temp files (no trailing slash)

                              FtpAddress=ftp://123.123.123.123

                              FtpLogin=john

                              FtpPassword=12345

                              FtpPath=/public_html/launcher/ <--- MAKE SURE THIS LINE ENDS IN / OTHERWISE IT WILL NOT BE UPLOADED IN THAT FOLDER AND YOU WILL GET A SECURITY FAIL ENDING THE TRANSFER. AKA. THE UNDERLYING CONNECTION WAS CLOSED. AN UNEXPECTED ERROR OCCURRED ON RECEIVE.

                              Issue #2

                              this issue may be resolved if it cannot find the files listed from the above transfer. ensure you have 7zip installed on the patcher system and 7zip files associated with it or it won't unpack the files correctly. also ensure you have the directory structure manually added. the system will not create the folders on upload or deploy they must be preexisting.
                              Last edited by mastermikie; 01-23-2020, 11:01 PM.

                              Comment

                              Working...
                              X