Announcement

Collapse
No announcement yet.

MMO Starter Kit

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    HI Allure...

    It has been some time since I renamed my kit..

    My notes say:

    "Used this You_tube to rename Cleanthird to ClawsandPaws: https://www.youtube.com/watch?v=cmK-A8Dh_Ms

    Fixed three days of shyte and heart ache trying to follow the unreal article.

    After renameā€¦ compiled game and C&P was born."

    If memory serves correct, I still had to use search and like they show in the youtube video, and rename a couple things the video didn't show. then recompile..

    Hope this helps get you on the right track.

    Oh, and Congratz on buying the kit, and welcome to the club. I look forward to seeing screenies if you care to share your progress.
    Last edited by Tarly; 05-05-2019, 11:38 AM. Reason: slight typo adjust
    Clifford Brock

    Gamer / Tinkers with MMO Kit
    Game: Claws&Paws

    Comment


      Brilliant, Thank You so much !!!
      But it was all in vain lol I don't know what happened but this time it worked, somehow...

      Thank You for such a warm welcome, it's supercalifragilisticexpialidociously encouraging ! I'm pursuing game making as a simple hobby for now and it's not always easy getting the help I need, so thanks a bunch, it means a lot !

      EDIT : Thanks for sharing, that tutorial end up being a lot more thorough than the one I followed on the forum. Thank You Very Much.
      Last edited by Allure et Charme; 05-05-2019, 06:22 PM.

      Comment


        Can I hook the database/registration up to a Debian9 VPS? I want this package only for the registration/login system and want to set it up on a remote linux server if possible. I have a LAMP stack already installed with phpmyadmin working and db's setup/ready to go.

        Comment


          Originally posted by MikeRPG View Post
          Can I hook the database/registration up to a Debian9 VPS? I want this package only for the registration/login system and want to set it up on a remote linux server if possible. I have a LAMP stack already installed with phpmyadmin working and db's setup/ready to go.
          I don't know why not, but then I'm not deeply familiar with configuring webservers.
          MMO Starter Kit
          Dialogue Plugin
          Voxel Plugin
          Character Customization: Female
          Character Custmization: Male

          Comment


            Hi, since i have installed the Steam layer in my game. When a lcient try to connect to the dedicated server i receive this error PreLogin failure: incompatible_unique_net_id and the client cannot connect?

            Comment


              Released a free plugin today on the marketplace: https://unrealengine.com/marketplace/tcp-socket-plugin
              I'll be integrating it with the MMOKit soon. It should make communication with the chat server easier, since it won't require any C++ anymore.
              I also want to get rid of C++ data assets, since now UE4 allows to make them in blueprints.
              I intend to make the entire project a pure blueprints project.
              Also a couple of fixes in the chat server are to be expected.
              And a few bugfixes in the kit, which were recently reported. E.g., you can kill friendly NPCs if you switch from a hostile target to a friendly target mid-fight
              Last edited by CodeSpartan; 05-14-2019, 02:00 AM.
              MMO Starter Kit
              Dialogue Plugin
              Voxel Plugin
              Character Customization: Female
              Character Custmization: Male

              Comment



                Excuse me, I can't reset the password of my Selly website and prompt error Captcha malformed. What should I do?

                Comment


                  Im stuck on something wondering if anyone else can help me. When I use "Open Level" it crashes the editor BUT when I use "Open Level" with a "trigger box" it works flawlessly. I want to be able to save and load into levels and ive pretty much incorporated it completely besides being able to actually load into the level I want. The things I tried are making a loading level with a "delay" upon "event begin" and it crashes, making it load the level before going into the world and again crashes...

                  I have a feeling it has to do with "open level". Is there another way to do it?

                  Ps I already have the SQL database saving current map I just cant load into those maps because of the crashing.

                  after rereading the documentation I got this working. Made a mistake in the log window
                  Last edited by Blah11; 06-12-2019, 09:22 AM.

                  Comment


                    i started using the mmokit 1.6 with ue4.21, i run the server components on a win 2016 server behind a ubuntu 16 firewall. i have had issue from day one just using the basic kit with no mods stalling the chat. i recently switched to the newest 1.7 on ue4.22. same results. i tried moving the server onto a public ip with no firewall what so ever to ensure it wasnt the firewall. still stalls. i tried running the chat server on a win10 copy to ensure it wasnt the os. still same story. it connects and works great for about 5 mins. the server log shows the client connecting in the chat log. but when the client stops responding the server log shows nothing. if a client logs out while the chat is working the log shows it. but after the client stops the log does not show the client log out. as if the client stopped talking to the server. if you log out and log back in the server sees the login. and it works for fine till you stop chatting for about 4-5 minutes.

                    Comment


                      Hi, I was wondering why this is not being sold in the Epic's store?

                      Comment


                        So first, I have to say I love the kit. It's been great to tinker with and fun to experiment with friends.

                        The problem I am currently having is with deploying a new version with the launcher. I've been able to successfully test deploying a small project over and over. However, when I go to test an actual project that is many gbs, I am receiving this message:

                        Fatal error: Maximum execution time of 30 seconds exceeded in public_html/launcher/index.php on line 21

                        Is this because of my server, or does this have to do with the launcher? If anyone has any steps or solutions I would greatly appreciate it.

                        Thanks!

                        Last edited by Kryptex3390; 07-11-2019, 12:17 PM. Reason: Actually, this has nothing to do with the launcher itself, but is a limitation of my host server.

                        Comment


                          Actually I'm having another issue as well.

                          When I go to create a test patch where all I do is tweak a material in an existing map, it doesn't actually update the file with the patcher. The launcher acts like there are files that it is updating, but when the exe launches it is the same old version. Thoughts/advice anyone? Thanks!

                          Edit: To give more information, if I package the project with a .pak the launcher sees the file differences but fails to update them in the pack. (It just re-downloads the entire pak) If I package without the pak the launcher works flawlessly, but then the entire project is available to anyone we deploy to. Obviously we don't want that.

                          Is there a setting that I am missing, or is there an additional thing that I can do to make the launcher replace files within the pak without having to re-download the entire pak?
                          Last edited by Kryptex3390; 07-11-2019, 12:20 PM.

                          Comment


                            good day. i was wondering if anyone was having issue compiling the mmokit 1.17 CleantThirdPerson.sln? i setup vs, ureal 4.22 source and built the ue4.sln and the CleanThirdPerson.sln perfectly, but my partner cannot get the CleanThirdPerson.sln to compile. we went thru every step along the way from the vs to the mmokit and compared all of his to mine. still he gets errors from every item attemping to build in the CleanThirdPerson.sln. a very large amount of varest errors. very strange we have removed vs and the github app and cleaned build and folders and followed all the details 3 times over. still no joy.
                            Last edited by mastermikie; 07-02-2019, 08:13 PM.

                            Comment


                              Originally posted by mastermikie View Post
                              good day. i was wondering if anyone was having issue compiling the mmokit 1.17 CleantThirdPerson.sln? i setup vs, ureal 4.22 source and built the ue4.sln and the CleanThirdPerson.sln perfectly, but my partner cannot get the CleanThirdPerson.sln to compile. we went thru every step along the way from the vs to the mmokit and compared all of his to mine. still he gets errors from every item attemping to build in the CleanThirdPerson.sln. a very large amount of varest errors. very strange we have removed vs and the github app and cleaned build and folders and followed all the details 3 times over. still no joy.
                              prob a varest issues?try get the latest version of varest and rebuild

                              Comment


                                KhxiSaki thanks for your suggestion. Eventually we were able to get my partners system rebuilt and working. there was no single magic bullet. I remoted into his system and uninstalled all the required components. ie. vs, sdk's, unreal source, etc. cleaned all the folders and even ran the registry clean for vs. after that i reinstalled it all and Viola! thanks for your time.

                                Comment

                                Working...
                                X