Announcement

Collapse
No announcement yet.

Lightmap UV are overlapping

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Lightmap UV are overlapping

    Hey.

    I'm new in Unreal Engine world and every step i do i find a problem and the probleme this time is overlapping error
    I use unreal engine version 4.5 et les tutorial that I found is for the old version
    and like you can see there is 1212 errors that I need to fix
    plz tell me if there is a simple thing to fix all this errors
    Click image for larger version

Name:	Capture d’écran (21).png
Views:	1
Size:	285.1 KB
ID:	1140176

    #2
    Your models have bad Lightmap UV's or even don't have those at all. You need to create the second UV channel for lightmap UV's and flatten Uv's under 45 degree (in max) in other applications find a way to do that, after assign Lightmap coordinate index to lightmap channel.

    Comment


      #3
      Originally posted by Wozner View Post
      Your models have bad Lightmap UV's or even don't have those at all. You need to create the second UV channel for lightmap UV's and flatten Uv's under 45 degree (in max) in other applications find a way to do that, after assign Lightmap coordinate index to lightmap channel.
      is that I'm forced to do this for all objects in the scenes or only the main object

      Comment


        #4
        Hi FICTIONSELL,

        Yes for all object but if you are using Unreal Engine 4.5 & more, it can automatically generate Lightmap UVs for you in Static Mesh Editor, Build Setting, check Generate Lightmap UV and click apply changes button

        Click image for larger version

Name:	9dcf7b062a36fddda974425ea8f79a1b_1.png
Views:	1
Size:	44.5 KB
ID:	1060346

        Comment


          #5
          actually it enabled automatically

          Click image for larger version

Name:	Capture d’écran (24).png
Views:	1
Size:	849.3 KB
ID:	1060356

          Comment


            #6
            Hi Fictionsell,

            Depending on how you've unwrapped the texture UV will determine how the generated lightmap will work. The generated LM will repack the texture UV layout. It will not break seams to do so either.

            For example. If you have a cylinder or a sphere that has not been split on a seam the LM will not do this still leaving and Overlapping UV error. You may not need to do this for all objects, but you will need to check or fix some in your 3D modeling software to get the issue resolved.

            Alternatively, using a fully dynamic scene can help, but at the cost of performance and losing the quality gains that a baked shadow will bring. That is an option if you do not want to deal with the headache of fixing that many lightmaps.

            Feel free to ask any questions and I'll help where I can.

            Tim
            Tim Hobson | Learning Resources | Epic Games
            UE4 Documentation

            Comment


              #7
              Hello Tim ,

              Thank you for the tip but :

              Alternatively, using a fully dynamic scene can help
              I don't understand ? Only with movable objects and lights ?
              Last edited by ChrisTm; 10-29-2014, 12:20 PM.

              Comment


                #8
                @ChrisTm -

                I was pointing out that if someone decided they didn't want to re-do or setup that many lightmaps there is the choice to use dynamic/movable lights for shadows rather than baking that information into a lightmap. It's a performance trade-off of course.
                Tim Hobson | Learning Resources | Epic Games
                UE4 Documentation

                Comment


                  #9
                  Originally posted by Tim Hobson View Post
                  Hi Fictionsell,

                  Depending on how you've unwrapped the texture UV will determine how the generated lightmap will work. The generated LM will repack the texture UV layout. It will not break seams to do so either.

                  For example. If you have a cylinder or a sphere that has not been split on a seam the LM will not do this still leaving and Overlapping UV error. You may not need to do this for all objects, but you will need to check or fix some in your 3D modeling software to get the issue resolved.

                  Alternatively, using a fully dynamic scene can help, but at the cost of performance and losing the quality gains that a baked shadow will bring. That is an option if you do not want to deal with the headache of fixing that many lightmaps.

                  Feel free to ask any questions and I'll help where I can.

                  Tim
                  Thank you Tim for the reply but what i can't understand is why the planar surface like floor for exemple show this error

                  thanks

                  Comment


                    #10
                    Originally posted by Tim Hobson View Post
                    @ChrisTm -

                    I was pointing out that if someone decided they didn't want to re-do or setup that many lightmaps there is the choice to use dynamic/movable lights for shadows rather than baking that information into a lightmap. It's a performance trade-off of course.
                    All right , nothing more , merci

                    Comment


                      #11
                      How would you deal with this problem in 4.4.3. For example, I have an object that has this same error. When I open the object, in the drop down menu for UV channels it only has a 0.

                      Comment


                        #12
                        In 4.4.3 there are still some UV generating tools to help out. There are two in 4.4.3 and prior though.

                        Open the mesh in the mesh viewer/editor > Menu Bar > Windows > Generate UVs > a tab will open in the bottom right under the details panel >

                        You will have two options here:

                        Create New UV and you can select the channel - This will pelt map and break apart chunks of your mesh to get a UV. I wouldn't recommend this method as it's rarely produced good results with more complex or even simple objects at times.

                        The second option is to base the UV creation off the UV0 for the texture. This is the current (more refined) method that is in 4.5 and later. This will look at the UVs that are split in UV0 and repack them into UV1 for the lightmap.


                        Option two is the more preferred method. However, if you want the most control over your UVs it is recommended to use an external program and make a custom LM.

                        Thanks!

                        Tim
                        Tim Hobson | Learning Resources | Epic Games
                        UE4 Documentation

                        Comment

                        Working...
                        X