Announcement

Collapse
No announcement yet.

How to get correct scale from Blender

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    How to get correct scale from Blender

    How can I export from Blender so the scale is more correct than what I get now?

    I don't know if this is the general thing, but a "normal" sized mesh in Blender gets tiny when importing to UE4. What units are Blender using and how can I change it to be 1:1 to UE4?

    #2
    1 Unreal Unit is 1 cm by default. You have to model your objects in Blender accordingly. For instance the starter cube you get when you create a new file is just 2x2x2 units, which you can tell by looking at the dimensions:
    Click image for larger version

Name:	iwApqmT.png
Views:	1
Size:	12.7 KB
ID:	1049927
    So this cube will just be a 2cm cube in Unreal. You can either just make your objects bigger, or you can apply a scale when you export to .fbx:
    Click image for larger version

Name:	PXYbDAc.png
Views:	1
Size:	18.1 KB
ID:	1049928
    Join us on IRC! We are on #unrealengine @ freenode.org

    Comment


      #3
      1 Blender unit == 1 Unreal Unit. If you measure out what sizes you need in the editor you can easily model to spec in Blender.

      Comment


        #4
        Here:
        https://wiki.unrealengine.com/Static_Mesh_from_Blender

        Comment


          #5
          Set the scene to scaling of 100 in Blender, Select the object and also set the export FBX option scale to 100 as well. batch mod should be scene. Check selected objects.
          I adjusted both scale settings and they imported the files with the standard error message of FBX being out of date.

          Comment


            #6
            Originally posted by Ruudscorner View Post
            What units are Blender using and how can I change it to be 1:1 to UE4?
            As others have mentioned, the unit scale ratio is already 1:1 between Blender and UE4.
            1 Blender Unit = 1 centimeter = 1 Unreal Unit

            Originally posted by Ruudscorner View Post
            a "normal" sized mesh in Blender gets tiny when importing to UE4.
            The problem is with what we call "normal" in Blender. To be more specific, the default scale of the scene in Blender is not comparable to the scale of the scene in UE4. This is where the ratio is not equal.

            Considering that the default cube in Blender is really only 2cm^3, that means the viewport is zoomed in by 100 if we compare it with UE4 standards.

            One method to remedy this is to adjust the scale of the scene, as described on the Static Mesh from Blender wiki page. A few caveats regarding this method is that certain objects added in will not be to-scale with the new scale of the scene (such as cameras, empties, armatures, etc.). This method also causes possibly insignificant graphical inconsistencies in the way objects are displayed in the viewport.

            To make a point, this isn't one of the strongest features of Blender, and it's clear that there wasn't a large amount of foresight involved when planning it (not to discredit the developers). There are several methods out there for getting proper scale from Blender to UE4, and they all seem to have their own downsides, which honestly is not ideal for a production workflow in the least bit. If you want to find the "best" method, then I recommend trying out each one in different scenarios to find one that works best for that given scenario.
            Last edited by Riyuzakisan; 04-02-2014, 10:37 PM.

            Comment


              #7
              i haven't done a lot of work in blender but i've produced a few videos on this subject, add i'll be doing more in the future

              but basically i just scaled the scene and work in that, but as mentioned it can cause other problems which i also cover to some extent
              UT40K:The Chosen - Warhammer 40,000 for UE4
              ut40kgeodav - UE4 Tutorials

              Comment


                #8
                Originally posted by Enos Shenk View Post
                1 Blender unit == 1 Unreal Unit. If you measure out what sizes you need in the editor you can easily model to spec in Blender.
                Originally posted by Riyuzakisan View Post
                As others have mentioned, the unit scale ratio is already 1:1 between Blender and UE4.
                1 Blender Unit = 1 centimeter = 1 Unreal Unit
                these guys said it, it basically gives you 2 options to get the right scale.

                option 1: leave blenders units at there default (set to none) and just model to the scale you want it in UE, so if you want something to be say 100CM/1M tall in UE just make it 100 units tall in blender and export with scale set to 1.

                option 2: change blenders units to metric, set the unit scale to 0.01 and then if your model is 1M in blender it will be 100CM/1M in UE if you exported from blender with scale set to 1.

                Originally posted by koluskomtu View Post
                set the export FBX option scale to 100 as well.
                I cant recommend this workflow to get the right scale because while it does work for static meshes every time I have tried to change the scale of a skeletal mesh during export it doesn't actually scale the model (I have tried changing scale during export with a few of blenders fbx exporters and its never worked for me) so you would be working with two different scales in blender for static and skeletal meshes.

                I also recommend watching Geodavs tutorials

                Comment


                  #9
                  My first thought was I can model to scale but the grid in Blender seem to be lost because everything else is now tiny. If there's a fix for this then maybe this is the best option.

                  I will definitely try out the different suggestions and also watch the tutorials first to see where it gets me.

                  Thanx!

                  Comment


                    #10
                    Originally posted by Ruudscorner View Post
                    If there's a fix for this then maybe this is the best option.
                    you can make the grid bigger by opening the properties panel "N Key" and going to the "display" section, then just change the size, if you want to make it permanent after you make the grid bigger go to "File>save startup file" and then that file will be blenders default scene at starup, it also works for the camera and light if you want to keep them.

                    hope that helps

                    Comment


                      #11
                      Originally posted by smokey13 View Post
                      you can make the grid bigger by opening the properties panel "N Key" and going to the "display" section, then just change the size, if you want to make it permanent after you make the grid bigger go to "File>save startup file" and then that file will be blenders default scene at starup, it also works for the camera and light if you want to keep them.

                      hope that helps
                      Very nice suggestion :-)

                      I changed the units to metric. Then had to change the grid size, and of course the clipping as only 1/2 of the grid was showing. Did some other tweaking to the windows and saved it as a startup. Not it's all ready for UE4 modelling.

                      Comment


                        #12
                        I've got a problem with scale my moving text, I have an intro moving but when I want to rescale it as when I preview what I have done it re-sets it self back or original size. Is there a way to save the size I want it to be.


                        First image: This is shown when I edit it
                        https://gyazo.com/6b73b1e087d073a3afcd24b13e6b81c8

                        Second Image: This the size goes back to its original size after I preview it playing to see what will happen
                        https://gyazo.com/1482715e1712e3ccbc594cbe3cf63d40

                        Comment


                          #13
                          there is no scale conversion section from i see

                          Comment

                          Working...
                          X