Announcement

Collapse
No announcement yet.

3rd person character going through terrain in some places

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    3rd person character going through terrain in some places

    The default 3rd person character is going through terrain in some places. When I press Play and go into game, player is already knee deep in terrain , but not falling through. I used terrain > export from unity3d and saved raw file in PS then imported..no errors.

    Sometimes character is almost invisible in terrain except for top of head .

    I have collision enabled, block all.

    I have the same problem even with UE4 created terrain.

    Here is a screenshot:

    https://onedrive.live.com/redir?resi...nt=photo%2cjpg

    What could be causing this ?

    thx
    nl
    Last edited by neighborlee; 10-05-2014, 07:35 PM.
    Solo but Seismic - feel free to apply
    https://neighborlee1.wixsite.com/theheartseed

    #2
    In your character blueprint, go to the capsule component and under rendering uncheck hidden in game. Then play the game and see where your collision capsule is.

    Click image for larger version

Name:	Capture.JPG
Views:	1
Size:	135.2 KB
ID:	1057502


    You need an IK system to properly position your character mesh relative to the collision capsule.

    Click image for larger version

Name:	footIK2.jpg
Views:	2
Size:	53.9 KB
ID:	1057503

    Comment


      #3
      Originally posted by nabiul View Post
      In your character blueprint, go to the capsule component and under rendering uncheck hidden in game. Then play the game and see where your collision capsule is.
      I don't recall having this problem when I first started using UE4, did something change in the default way terrains are created and what 3rd person char. comes with ? I just removed my creations and restared with new 3rd person blueprint with starter stuff and Im still having this problem. I wasn't having any of this when I first ran UE4 , Im pretty sure.

      I doubled clicked every animation component, walk run etc, and there is no hidden anything that I can find, where is this found ?

      EDIT: I found it by looking around, and the hidden field is in : 'edit defaults', which is the only place I was able to find it.

      As I say, this always worked before as I could load my terrain and mesh, and walk anywhere and I wasn't having this issue. Is this 'IK' system a new requirement that needs setup now in latest ue4 version ?

      There are tutorials on youtube showing terrain being added, and a character shows up on pLAY, and nothing is said about a IK system being needed, so are you sure about this ?

      My goal is not to doubt you, but according to this tutorial: https://www.youtube.com/watch?v=K9WTKK9f1b8 < no IK system was setup, and yet player goes across terrain without dropping into it,,although he doesn't go over terribly sloped areas so who knows...?

      Thx
      nl
      Last edited by neighborlee; 10-06-2014, 01:03 AM.
      Solo but Seismic - feel free to apply
      https://neighborlee1.wixsite.com/theheartseed

      Comment


        #4
        This is a diagnostic to figure out what is going on, we have no way of knowing what the difference is in your game that is causing this.

        This is NOT part of the ANIM blueprint, this is in the CHARACTER blueprint, the one that has all the controller inputs and skeletal mesh.

        Like my picture shows, you have to physically select the capsule in the components section of your character blueprint and in it's options you will see the hidden option. When you uncheck this box and play, you will see the collision capsule like in my picture below.

        Is terrain the only thing in your level? Is there anything under the terrain? If your collision capsule goes through the terrain, then your character should fall right through the level unless it is hitting something under the terrain.

        Click image for larger version

Name:	Capture.JPG
Views:	1
Size:	328.0 KB
ID:	1057506

        What it should look like, the capsule around the player model should be in the same position as the player model. The capsule is what is really used for collision detection.

        Click image for larger version

Name:	Untitled.jpg
Views:	1
Size:	116.2 KB
ID:	1057507


        IK is something else; when the character is on the stairs it's feet will be 'floating in the air' because the capsule does not sit on individual steps. An IK system moves the player model relative to the collision capsule so that the character looks like it is standing on the steps or sloped surface.
        Last edited by nabiul; 10-06-2014, 03:44 AM.

        Comment


          #5
          Originally posted by nabiul View Post
          This is a diagnostic to figure out what is going on, we have no way of knowing what the difference is in your game that is causing this.

          This is NOT part of the ANIM blueprint, this is in the CHARACTER blueprint, the one that has all the controller inputs and skeletal mesh.

          Like my picture shows, you have to Isselect the capsule in the components section of your character blueprint and in it's options you will see the hidden option. When you uncheck this box and play, you will see the collision capsule like in my picture below.

          Is terrain the only thing in your level? Is there anything under the terrain? If your collision capsule goes through the terrain, then your character should fall right through the level unless it is hitting something under the terrain.


          IK is something else; when the character is on the stairs it's feet will be 'floating in the air' because the capsule does not sit on individual steps. An IK system moves the player model relative to the collision capsule so that the character looks like it is standing on the steps or sloped surface.
          You may have missed but I edited my post,maybe a bad habit from another forum I peruse sometimes, but anyway yes, as my EDIT shows ( EDIT in prior post to get attention to avoid it being missed) I did find the right section by right clicking and choosing edit defaults, and that is where I found the hidden area and disabled it temporarily.

          It did show that the coll.capsule is further underground than my character is. I have yes also noticed that in many places the characters feet are hovering above ground, and I now understand your IK reference. I am not , however a artist first, and while I understand alot of programming, I'd have zero idea where t o even start in setting up a IK system for my gaming project's level(s).

          Is this video https://www.youtube.com/watch?v=Bde5dJMRBCE , going to be enough to shwo me ( given my current lacking knowledge in UE4 programming though I'm getting there as fast as I can ) how to add IK to my projects so this slope issue goes away ?

          One last thing, there is nothing under the terrain, it is the only thing in the level atm, because before proceeding, I wanted to get this right.

          TY for your assistance.

          cheers
          nl
          Last edited by neighborlee; 10-07-2014, 12:50 AM.
          Solo but Seismic - feel free to apply
          https://neighborlee1.wixsite.com/theheartseed

          Comment


            #6
            Originally posted by neighborlee View Post
            You may have missed but I edited my post,maybe a bad habit from another forum I peruse sometimes, but anyway yes, as my EDIT shows ( EDIT in prior post to get attention to avoid it being missed) I did find the right section by right clicking and choosing edit defaults, and that is where I found the hidden area and disabled it temporarily.

            It did show that the coll.capsule is further underground than my character is. I have yes also noticed that in many places the characters feet are hovering above ground, and I now understand your IK reference. I am not , however a artist first, and while I understand alot of programming, I'd have zero idea where t o even start in setting up a IK system for my gaming project's level(s).

            Is this video https://www.youtube.com/watch?v=Bde5dJMRBCE , going to be enough to shwo me ( given my current lacking knowledge in UE4 programming though I'm getting there as fast as I can ) how to add IK to my projects so this slope issue goes away ?

            One last thing, there is nothing under the terrain, it is the only thing in the level atm, because before proceeding, I wanted to get this right.

            TY for your assistance.

            cheers
            nl
            That video is for a plugin you have to purchase. Forget about IK for now, is your collision capsule all the way underneath the terrain? If the capsule misses the terrain entirely then it might mean the collision settings for the capsule are on the wrong presets.

            Otherwise if you are starting from a new TPP project and it is doing this then maybe your installation of the engine has errors or something and you could try re-downloading the engine.

            I can't tell from your picture, but maybe the mesh settings for the landscape are too coarse and the polygons of the landscape are too large?

            I noticed you said that the collision capsule is below the player model, if it is not sync'd up with your player model then there is something seriously wrong. Does it do this in the default level as well? The capsule and player model should always look like what it is in the character blueprint.

            It's very difficult to tell what is going on with so little detail.
            Last edited by nabiul; 10-07-2014, 01:35 AM.

            Comment


              #7
              Originally posted by nabiul View Post
              That video is for a plugin you have to purchase. Forget about IK for now, is your collision capsule all the way underneath the terrain? If the capsule misses the terrain entirely then it might mean the collision settings for the capsule are on the wrong presets.

              Otherwise if you are starting from a new TPP project and it is doing this then maybe your installation of the engine has errors or something and you could try re-downloading the engine.

              I can't tell from your picture, but maybe the mesh settings for the landscape are too coarse and the polygons of the landscape are too large?

              I noticed you said that the collision capsule is below the player model, if it is not sync'd up with your player model then there is something seriously wrong. Does it do this in the default level as well? The capsule and player model should always look like what it is in the character blueprint.

              It's very difficult to tell what is going on with so little detail.
              Coll preset for capsule is Pawn, and often times its fine as I walk around terrain, but other times its varying degrees of in/out of terrain. Sometimes its exactly half in half out. I can rotate terrain and see the underside of terrain ( all white) and see capsule is directly in line with feet of character.

              Its a new project yes, made a new level after that and imported my terrain. If it matters, this was a PNG from unity, into PS and made it greyscale and 16 bit, and saved out a PS raw file and imported into Ue4, no errors anywhere.

              Mesh settings too coarse, where do I fix this ?

              The default level with the simple platform and stairs, doesn't do this no, but then its all flat, not terrain but ya anyway it doesn't do what terrain is doing with character.

              I hope that's enough info to debug this mess as I"d like to fix this so I can move on, and then later learn about IK as that is precisely what i'd need.

              Cheers
              nl
              Solo but Seismic - feel free to apply
              https://neighborlee1.wixsite.com/theheartseed

              Comment


                #8
                Wait what do you mean imported terrain? I thought you were making a new landscape each time.

                I looked more into this and apparently you aren't the only one having this problem, there is a issue ticket open for this on the current engine version.

                https://answers.unrealengine.com/que...on-issues.html

                Comment


                  #9
                  Originally posted by nabiul View Post
                  Wait what do you mean imported terrain? I thought you were making a new landscape each time.

                  I looked more into this and apparently you aren't the only one having this problem, there is a issue ticket open for this on the current engine version.

                  https://answers.unrealengine.com/que...on-issues.html

                  UGH I should have looked I guess. TY so much for tracking that down, appreciate it very much.

                  Cheers
                  nl
                  Solo but Seismic - feel free to apply
                  https://neighborlee1.wixsite.com/theheartseed

                  Comment


                    #10
                    Originally posted by neighborlee View Post
                    UGH I should have looked I guess. TY so much for tracking that down, appreciate it very much.

                    Cheers
                    nl
                    Ok well, I created a new terrain , which I don't recall making any difference before, and collision was perfect ( Unreal 4 made terrain). This time I simplified all, and just exported a raw 16bit terrain file from unity where this originated in the first place, and imported into UE4, and same problem with bad collision.

                    I can't imagine having to start over, but I could as what I created could be redone fairly quickly although its going to be a major pain.

                    I'd be happy to offer my raw terrain file I exported from unity,if it helps in diagnosing this.

                    Thx
                    nl
                    Last edited by neighborlee; 10-08-2014, 06:39 PM.
                    Solo but Seismic - feel free to apply
                    https://neighborlee1.wixsite.com/theheartseed

                    Comment


                      #11
                      Originally posted by neighborlee View Post
                      Ok well, I created a new terrain , which I don't recall making any difference before, and collision was perfect ( unity made terrain). This time I simplified all, and just exported a raw 16bit terrain file from unity where this originated in the first place, and imported into UE4, and same problem with bad collision.

                      I can't imagine having to start over, but I could as what I created could be redone fairly quickly although its going to be a major pain.

                      I'd be happy to offer my raw terrain file I exported from unity,if it helps in diagnosing this.

                      Thx
                      nl
                      Have a look at the thread below which is discussing the same issue, the cause ended up being the engine scalability settings being set to anything less than High. To check if this is your issue, click on the "Quick Settings" button on the toolbar and find "Engine Scalability Settings", click High or Epic if it is not already selected, and then try playing the level again.
                      https://forums.unrealengine.com/show...nder+landscape

                      I believe the settings lower than High are causing the LOD to swap at the camera location, but the collision is still using the higher LOD, so where the character is walking on LOD0 but what you are seeing is LOD1. I have not heard an official explanation, but for the scalability settings to be causing this, that is the only thing I can come up with to explain it. Hope that helps, and hope Epic addresses this soon!
                      Free Community Ocean & Sky Project || Join us on Discord! || Trello Roadmap

                      Comment


                        #12
                        Originally posted by nabiul View Post
                        In your character blueprint, go to the capsule component and under rendering uncheck hidden in game. Then play the game and see where your collision capsule is.

                        [ATTACH=CONFIG]13455[/ATTACH]


                        You need an IK system to properly position your character mesh relative to the collision capsule.

                        [ATTACH=CONFIG]13456[/ATTACH]
                        What IK system are you using for foot placement? It looks great! I know Ikinema does that, but maybe you wrote your own solver with some tutorials found on the net. If so, please share those links!

                        Comment


                          #13
                          Originally posted by DotCam View Post
                          Have a look at the thread below which is discussing the same issue, the cause ended up being the engine scalability settings being set to anything less than High. To check if this is your issue, click on the "Quick Settings" button on the toolbar and find "Engine Scalability Settings", click High or Epic if it is not already selected, and then try playing the level again.
                          https://forums.unrealengine.com/show...nder+landscape

                          I believe the settings lower than High are causing the LOD to swap at the camera location, but the collision is still using the higher LOD, so where the character is walking on LOD0 but what you are seeing is LOD1. I have not heard an official explanation, but for the scalability settings to be causing this, that is the only thing I can come up with to explain it. Hope that helps, and hope Epic addresses this soon!
                          Wonderful ) FIXED..OMG what a relief that is, now I can proceed with other things.

                          TY so much for letting us know, and ya I hope they fix that soon, I lost far too many minutes trying everything I could to figure it out.

                          Cheers!
                          nl
                          Solo but Seismic - feel free to apply
                          https://neighborlee1.wixsite.com/theheartseed

                          Comment


                            #14
                            Originally posted by AdamZ View Post
                            What IK system are you using for foot placement? It looks great! I know Ikinema does that, but maybe you wrote your own solver with some tutorials found on the net. If so, please share those links!
                            https://forums.unrealengine.com/show...sule-collision

                            I made it based off of the content examples, it's a bit complicated and isn't very smooth.

                            Comment

                            Working...
                            X