Announcement

Collapse
No announcement yet.

Attaching Player to Landscape - Collision/Navigation Issues

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    Originally posted by MostHost LA View Post

    assuming you have no height fall damage, you can just place them very high up and simulate. They'll find the floor themselves.
    The actors are bouncing after they are landed on Landscape, and sometimes getting scattered. I need them to stay as -is (even if there is a slope / step on the landscape). In the picture given below, the Green Pyramid bounced and fell to ground. How to fix this (I played with the collisions settings but not able to figure-out)?

    Attached Files

    Comment


      #17
      Suggestions... 1. Add a HIT event to the dropped objects to disable physics once they land..... Or 2. Move the objects down without physics using only interp'd movement, such as Set Actor Location or Add Actor World Offset etc. Do this in a Loop on a Delay or use a looped Timer etc.

      For example, deduct z -100 (z = z-100) every second or so after starting with the object at the highest possible point on the landscape (working downwards). Ensure Sweep is enabled on the movement node so it stops the object from colliding with the landscape. Remember to disable the loop or timer once Z is at the lowest possible point. Using shaped Traces is another solution as well, but the other suggestions are definitely easier...
      Last edited by ClavosTech; 01-19-2020, 04:49 PM.

      Comment


        #18
        Selecting the object and hitting the home key to snap it down seems like the only approach you should be using.
        just do it once, get the Z values, and use them within the script that generates it at runtime.

        Or you could, as suggested, create a simple routine to stop simulating physics on impact.

        Comment


          #19
          Originally posted by MostHost LA View Post

          Instead of placing the player up high, play with switching cameras. You can have several cameras at the same time and you should be able to get the views to switch over nicely.
          For the character- change the camera to a child actor of type camera, so you can use the blend nodes.
          For the top-down view camera that is added - I'm not seeing any actors placed in the landscape. Understand the StaticMesh added for the Actor might be small to be visible at an elevation - so I've placed Z of the actor closer to this new Camera's Z and disabled Gravity/Physics on the actor (the Z of the Camera is 1million and rotation Pitch -90 to look-down on the landscape, and I've tried Z of Actor to be various values from 100k to 998k and still not visible).

          Is there something wrong here?

          Comment


            #20
            Where/How did you place the camera?
            Are you actually using that camera?

            Use the different debug views - drop down from the "lit" section here
            https://gyazo.com/02feb36798f0d8d00948749f63815a9e
            to see what's going on. If you have simple collision, visibility collision view may help.

            If your camera is distant enough, something may not render - but with default settings, usually anything placed in level will always render

            Comment

            Working...
            X