Announcement

Collapse
No announcement yet.

Can't assign Lightmap Coordinate Index

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Can't assign Lightmap Coordinate Index

    Now that's is weird. I moved from 4.23 to 4.24, and now I cannot change the Lightmap UV index. The objects that I added when using 4.23 are working fine, and if a create a new project on 4.24, it works fine, and I can change the index, but in the converted project, If a re-import an FBX, I got stuck at index 1, even though I do have a second UV, or even with auto UVs on.

    #2
    I'm having the same issue, had a project on 23, migrated to 24 and can't change Lightmap uv index on meshes I had imported before migration.

    Comment


      #3
      I'm on 4.24 and can change "Light Map Coordinate Index" with meshes from earlier version and meshes imported 4.24. Think I did struggle some with a mesh we store custom data in UVs but this was me not having the correct settings in the "Build Settings", changed the "Destination Lightmap Index" then reimported and it too worked as expected.

      Comment


        #4
        Originally posted by andreas.ranman View Post
        I'm on 4.24 and can change "Light Map Coordinate Index" with meshes from earlier version and meshes imported 4.24. Think I did struggle some with a mesh we store custom data in UVs but this was me not having the correct settings in the "Build Settings", changed the "Destination Lightmap Index" then reimported and it too worked as expected.
        Nope, still does not work. While yes, it auto-generate the lightmap UV, the engine still does not let me assign the UV on index 1 as the lightmap UV. Everytime I try to assign it, it goes back to 0, even though I have 2 UVs

        Comment


          #5
          RockNBurn have you found any solution? I have this problem too, after migrating from 4.23 to 4.24 i can't change lightmap coordinate index. When i trying to change it's going back to 0 or engine just crashing.
          Last edited by Deelus; 01-21-2020, 07:56 AM.

          Comment


            #6
            So, i found temporary solution for me and maybe it's will be helpful for others. What you need to do it's just export your meshes with "Level Of Detail" option enabled, change location of source file in asset properties, set "import mesh LODs" option and hit Reimport base mesh + LODs. Only then you will be able to set LM index.

            Comment


              #7
              It's an engine bug, sources of 4.24 have been fixed, you can download and compile, but you have to wait for 4.24.2 or 4.25 if you want to use binaries.

              Comment


                #8
                Originally posted by Deelus View Post
                So, i found temporary solution for me and maybe it's will be helpful for others. What you need to do it's just export your meshes with "Level Of Detail" option enabled, change location of source file in asset properties, set "import mesh LODs" option and hit Reimport base mesh + LODs. Only then you will be able to set LM index.
                Thanks, I'll try that with one asset first.

                Comment


                  #9
                  Originally posted by Deelus View Post
                  So, i found temporary solution for me and maybe it's will be helpful for others. What you need to do it's just export your meshes with "Level Of Detail" option enabled, change location of source file in asset properties, set "import mesh LODs" option and hit Reimport base mesh + LODs. Only then you will be able to set LM index.
                  No dice. Still does not work.

                  Comment


                    #10
                    Originally posted by RockNBurn View Post

                    No dice. Still does not work.
                    Actually, the workaround can be a bit simpler: Just set LOD Group to 'none', Number of LODs to 1, apply changes. Then you'll be able to assign your Light Map. But of course you won't have LODs.

                    Comment


                      #11
                      This is such a critical bug which needs immediate hot fix released in form of 4.24.2 .. we cant wait for 4.25...

                      Comment


                        #12
                        Originally posted by Castorpuck View Post
                        This is such a critical bug which needs immediate hot fix released in form of 4.24.2 .. we cant wait for 4.25...
                        Just got a mail on my bug report from the developer team: due to the bug requiring API changes, it will only be fixed in 4.25 (API changes are not allowed in hot-fixes). However, as mentioned above, if it's highly critical in your case, you could consider compiling a version of the engine from source, to integrate the fix. (Fix CL is listed on bug tracker).

                        Comment


                          #13
                          Originally posted by Warner V View Post

                          Actually, the workaround can be a bit simpler: Just set LOD Group to 'none', Number of LODs to 1, apply changes. Then you'll be able to assign your Light Map. But of course you won't have LODs.
                          Hey, that actually works, Thanks, I'll try to bake it again.
                          considering I'm not working on a game, but a portfolio piece, I don't mind losing LODs

                          BTW, you don't actually need to set the LOD group to None, just set the number back to 1.
                          Last edited by RockNBurn; 01-24-2020, 01:02 PM. Reason: adding information

                          Comment


                            #14
                            A quick fix is to set the Number os LODs to 1. You cannot use LODs, but you can bake lightmaps again.

                            Comment


                              #15
                              Originally posted by Warner V View Post

                              Just got a mail on my bug report from the developer team: due to the bug requiring API changes, it will only be fixed in 4.25 (API changes are not allowed in hot-fixes). However, as mentioned above, if it's highly critical in your case, you could consider compiling a version of the engine from source, to integrate the fix. (Fix CL is listed on bug tracker).
                              I don't understand because this has been fixed in UE4.24 sources, you can read this:
                              https://forums.unrealengine.com/unre...hange-off-of-0
                              I have tested myself so I think, that if there will be a 4.24.2, the fix will be integrated.

                              Comment

                              Working...
                              X