Announcement

Collapse
No announcement yet.

Missing precompiled manifes

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Missing precompiled manifes

    Hello. Tell me who faced a similar problem.
    I try to build Unreal Engine 4.22 empty project with IKINEMARunTime4.22 plugin. The available version of RunTime Indie will not support being rebuilt as it is a binary distribution. The current solution is to install the plugin to the engine directory.
    But where exactly, in the Plugins or Plugins\Runtime directory?

    Visual Studio compiles correctly, but when I try to package a project in the UE, the following errors appear.

    UATHelper: Packaging (Windows (64-bit)): ERROR: Missing precompiled manifest for 'IKinemaCore'. This module was most likely not flagged for being included in a precompiled build - set 'PrecompileForTargets = PrecompileTargetsType.Any;' in IKinemaCore.build.cs to override.
    PackagingResults: Error: Missing precompiled manifest for 'IKinemaCore'. This module was most likely not flagged for being included in a precompiled build - set 'PrecompileForTargets = PrecompileTargetsType.Any;' in IKinemaCore.build.cs to override.

    How to add a binary library to a project?

    I tried adding IKinemaCore to PublicDependencyModuleNames and PrivateDependencyModuleNames, but another error appears.

    fatal error LNK1181: cannot open input file 'D:\Epic Games\UE_4.22\Engine\Plugins\Runtime\IKinema\Intermediate\Build\Win64\UE4Editor\Development\IKinemaCore\UE4Editor-IKinemaCore.lib'

    What am I doing wrong or what is missing?

    #2
    Same problem. Exactly the same. Garbage.

    Comment

    Working...
    X