Announcement

Collapse
No announcement yet.

Imported .obj with alpha texture won't render transaprency

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Imported .obj with alpha texture won't render transaprency

    Greetings,

    I'm reviving an old project (started 10 years ago...). By then I stored my assests in .dae format. A sample is available here, it's hair (see first screenshot with purple background):
    https://new.dercetech.com/wp-content...encer-hair.zip

    It imports pretty well in Blender, so it helps converting the model to an .obj file. The resulting .obj (with .mtl) is available here:
    https://new.dercetech.com/wp-content...9/hair-red.zip

    It imports almost perfectly in Unreal. The 2 materials are generated nicely upon import (material 0 has the alpha texture while material 1 has the solid texture). Glossiness needs adjustment to not make it look like plastic but that's a minor issue.

    My issue here is that the alpha channel doesn't seem to be applied. The strands that finish "nicely" don't render "nicely", see second screenshot. We should see the green box through the strands that were circled.

    I assigned the "rgba" from my texture sample to the material base color, but that doesn't help (see screenshot 3).

    I'm grateful in advance to anyone stopping by and reading this :-)

    #2
    You'll need to plug in the alpha channel to either the opacity or opacity mask depending on the type of translucency or masking you end up using. You'll also need to change the material settings for blend mode.

    Take a look at this guide and the Digital Humans example project https://docs.unrealengine.com/en-US/...ter/index.html

    You don't have to use everything their hair shading is using, but you could easily open up the project and take apart their hair material.

    Comment


      #3
      Thanks ZacD , will try that at once :-)

      Comment

      Working...
      X