Announcement

Collapse
No announcement yet.

Unreal material turns inside out when switching blend mode to Transulcent

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    if this is a sorting issue and if you really need a translucent mesh you can check the 'allow custom depth writes' and compare the pixel depth against the custom depth.
    https://www.tomlooman.com/the-many-u...h-in-unreal-4/


    if your just trying to make the visor translucent but the rest of the mesh can be opaque then use multiple materials.
    Last edited by IndieGameCove; 09-16-2019, 08:08 PM.

    Leave a comment:


  • replied
    Separate the visor into its own translucent material and set the body material to opaque.

    This is not a normal problem. The hint is in your description: It looks fine when the material is set to opaque.

    When rendering translucent materials the mesh has to be sorted to render translucency correctly. The problem is meshes often will not sort correctly and you will end up with pieces being rendered in the wrong order. The easiest and most performant way to resolve this is to use translucency sparingly and never try to combine your opaque elements with the translucent pieces in the same material (which is what you did). Another option (which is great for performance but has visual artifacts) is to use an opaque material with dithered translucency.
    Last edited by Arkiras; 09-15-2019, 07:36 PM.

    Leave a comment:


  • replied
    import normals...

    Leave a comment:


  • Unreal material turns inside out when switching blend mode to Transulcent

    So I'm not sure if I'm doing materials right. I've tried google, but everything points to my normals being flipped... but checking the normals in Blender and in UE4, they look like they're going the correct direction. When I have the blend mode as Opaque, it looks fine, but switching it to Transparent (I'm trying to make her visor transparent, the textured image is an RGBA PNG), it turns my model normals flipped. Does anyone have any ideas how to fix this?

    I've also manually gone into Blender and flipped all the normals and it still displays the same problem. I've tried triangulating the faces, and reimporting with the normals set as opposed to recalcuated. Help!

    I've put an album of screenshots to show what's going on here:
    https://imgur.com/a/qYH5Ql8

Working...
X