Announcement

Collapse
No announcement yet.

LOD Creation

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    LOD Creation

    Hey,

    I made some static meshes and now i am working on the LODs.
    But, I am not sure about certain things when creating LODs.
    Maybe, someone could tell me what i am doing wrong.

    To be more specific about my problem i inserted two pictures.
    I deleted some polygons for making LOD1.
    In places where i was thinking they wont have much influence of how the model will look in game.
    The first picture is LOD0, the second picture is LOD1.
    When the engines switches between LOD0 and LOD1, the shadows on the model are changing.
    And, if i look directly on the model, this is really easy to see.

    I dont know if i made too much of a change or if this is normal.
    Should i just leave it like that? Or change my way of making LODs?

    Thanks!


    Click image for larger version

Name:	LOD0.png
Views:	1
Size:	363.1 KB
ID:	1653335Click image for larger version

Name:	LOD1.png
Views:	1
Size:	254.5 KB
ID:	1653334


    #2
    what do you mean exactly?
    if you are speaking of the shadows on the side facing towards us : this is because you have the same smoothing group on the top and the sides.
    Split the normals on the vertices

    Comment


      #3
      Thanks, that was the problem. Its difficult to adjust all smoothing groups in a way that this isnt happening.




      Maybe, someone knows the answer for this shadow problem.
      I made a BP with different components, in one area, where the components join together but are not intersected.
      I get this kind of shadows, is that normal? Or is there a way to get rid of this?

      Thanks


      Do Click image for larger version

Name:	Test.png
Views:	1
Size:	355.4 KB
ID:	1654013

      Comment

      Working...
      X