Announcement

Collapse
No announcement yet.

After importing heightmap scale and scene are messed up

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    After importing heightmap scale and scene are messed up

    hello there,

    after importing and scaling a heightfield (2017x2017, Scale 100-100-800) things are getting strange. the heightfield gets placed waaaaaaaaaaaaaay down below in the scene and the gizmo offsets
    and floats waaay above the terrain. even when I set the terrian´s coords to all zero and I place another object into the scene (let´s say a rock, also @ 0-0-0 coords) the rock is nowhere near the terrain. Also navigation gets clunky and slow. When increasing camera speed, it is getting better - but still navigation is a PITA

    Now. how can I fix this? Is there a way to somehow center the gizmo/pivot of the terrain to it´s actual mid-point and zero out the coords?
    It looks like, because of the displacment from the heightmap, center and surface get´s somhow offset (I think?)

    Hope you can understand, what I mean ^^

    And maybe another question: is there a setting to make new objects "stick" to ther terain, when placing them? If I pull in some new objects, the getting placed somewhere, but not on the
    terrian, like the camera-view would suggest.

    I am a bit lost there, please help me out.

    Cheers!

    #2
    I am not sure about your first question but if you press the End key on your keyboard when placing something in the scene it will snap it to the floor. Hope this helps.

    Comment


      #3
      ..so floor means Landscape? or do I need to place a "floor" object into the scene?

      Comment


        #4
        for the first question:

        if you click an object, like a rock, you get a gizmo to move (or rotate or scale), that is centered on this object, right? If I click on my landscape, the gizmo is waaaaaaaaaaaaaay above and looks like it is x y offset, as well. So when I move the view to my landscape and click it, I can not use the gizmo, cause it´s not in my field of view/frame. I guess, it´s because I scaled the heightmap/landscape?!
        Last edited by Official_Kayess; 05-28-2019, 05:04 AM.

        Comment


          #5
          So... is this landscape/gizmo behavior normal?

          Comment


            #6
            The gizmo is always going to be at the pivot of your object, so if your pivot is off, then the gizmo will be off as well.

            When exporting meshes from 3D software like Maya, make sure the point where you want the pivot to be is at your scene origin (0,0,0), before importing to Unreal.

            Comment

            Working...
            X