Announcement

Collapse
No announcement yet.

Blender to UE4 meshes see through

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Blender to UE4 meshes see through

    I've conquered this problem before but somehow it got solved (i don't know how i didn't do anything at the time). But now its back. This happens to both .obj and .fbx files although .obj files are not see through but they have some parts of the models removed. Is there any way to fix this? (I've seen multiple threads about this but none of the answers fixed it that i've tried so far.) Thank you! ~Kevin
    URL To picture : https://imgur.com/a/HyFcE9W


    Errors :
    Import Mesh Error: Bi Normals Are Nearly Zero and Tolerance of 1E-4
    Last edited by KeWin_.; 02-12-2019, 02:23 PM.

    #2
    recalculate normals
    in edit mode select all the vertices and click ctrl + n
    YT Channel: https://www.youtube.com/channel/UCoc...KYPSK6g7vZ5CNg

    Comment


      #3
      Originally posted by IndieGameCove View Post
      recalculate normals
      in edit mode select all the vertices and click ctrl + n
      Does not work. Tried with both .OBJ and .FBX obj still has some missing polygons and fbx is still see through.
      I also get these two error messages i should've probably mentioned in the post (ill edit it)
      Errors :
      Import Mesh Error: Bi Normals Are Nearly Zero and Tolerance of 1E-4

      Comment


        #4
        idk what the error means, but a couple things to check.
        there's an option that lets you visualize the direction the normals are facing. it's somewhere on the right side panel that appears when you press the 'n' key. I would make sure that the computer correctly recalculated the normals.

        check if there are any modifiers being applied on export that could mess up the verts.

        check the uv map make sure the whole mesh is on there with no overlaps.

        if the material is translucent sometimes there are weird depth issues, so see how a opaque material looks.

        does the problem appear in the blender render mode as well?
        YT Channel: https://www.youtube.com/channel/UCoc...KYPSK6g7vZ5CNg

        Comment


          #5
          there is an import option that imports all subobjects into a single asset.
          "Combine Meshes" or something like that.
          For the see through, you need to change your Material from "Translucent" to "Opaque".
          If you need the glass to be translucent, you need to split your mesh into separate sections in Blender. One that contains the glass and one that contains the rest. You then apply a Translucent Glass Material to the Glass and a Opaque Material to the Lamppost

          Comment


            #6
            Fbx fix: In Blender, select effected faces, open Q menu, select flip.
            obj fix:, I'm just guessing, but if you are using a modifier to achieve that bend, you have to collapse it (apply it) before exporting. Specifically must do for spline related modifiers. This is also true in other softwares like 3ds max.
            Last edited by NotSoAccurateNo1; 02-14-2019, 02:39 PM.

            Comment

            Working...
            X