Announcement

Collapse
No announcement yet.

Images are rendered too large in UMG

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Images are rendered too large in UMG

    Hi,

    I am creating a building overview and I have a single 1x1 white pixel to draw row dividers in a table. Sometimes, however, the row is drawn twice as large as intended:

    Click image for larger version

Name:	Overview.png
Views:	25
Size:	6.0 KB
ID:	1557348

    The effect is quite annoying. I have configured the image as follows:

    Click image for larger version

Name:	Settings.png
Views:	37
Size:	35.8 KB
ID:	1557349

    What could be the reason and how do I prevent the row from growing? I want it fixed at 1 pixel in height.

    Thanks!
    Ethereum Reach: Tower Defense set in outer space!

    #2
    Hi Laurens,

    Where are you seeing this? Is it in the editor, or a maximized window?

    If you're in the editor, can you confirm if it disappears when you change screen size or if you zoom around? Sounds like aliasing to me.

    Comment


      #3
      If you're not running the game viewport at exactly 1080p (or whatever your project has configured as 1.0), it's probably caused by the automatic DPI scaling.

      Comment


        #4
        Thanks for the quick replies! Stefan Lundmark I am seeing this while playing in the editor, but it also happens in stand-alone editor windows and cooked builds. I think Zeblote has it right, since it seems I can also make the table rows disappear while making the stand-alone editor window smaller and bigger. Still it seems strange to me that it would scale some rows, but not others. Are these floating point inaccuracies perhaps? Is there any way I can disable the automatic scaling on certain elements?

        Thanks again!
        Ethereum Reach: Tower Defense set in outer space!

        Comment

        Working...
        X