Announcement

Collapse
No announcement yet.

Dropping Beneath Landscape

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Dropping Beneath Landscape

    I am not sure if this has been brought, very likely has i just cannot find it, when I am running around in my landscape in play in the editor, why do i often end up in places beneath the landscape??

    #2
    What you you exatly mean with end up beneath the landscape? -> you fall through the landscape or you are still abel to walk? + which engine version do you use?

    Comment


      #3
      Quite literally passing through my landscape and stopping just behind it, like its glitching, here is a pic. I am using the UE4.4.
      Click image for larger version

Name:	BeneathLandscape.png
Views:	1
Size:	354.2 KB
ID:	1056153

      Comment


        #4
        Check if you have set the collision of your landscape to "block all" + change the value at "collision thickness". Is this happening just at special parts of the landscape or just randomly?

        Comment


          #5
          Well two things are happening here...First my definition of the landscape is disappearing and seems to only come back when i sculpt something on it; and 2nd it seems to happen more often where elevation changes occur.

          Should collision thickness be higher or lower than 16?

          Comment


            #6
            It seems like that your landscape is a little bit buggy ^^ -> delete your old one - create a new landscape - check if it is still happening

            Try both, so higher and lower value, at the thickness

            Comment


              #7
              Actually I have gone through 5 iterations of this ..... lol....UE4 was working fine with landscape before...but now it seems odd...Reinstall??

              Additionally, what exactly does collision thickness do? Having an understanding of that would be great!

              Comment


                #8
                I dont know exactly what collision thickness is doing, but I think that it will increase the distance from the collision form the landscape -> so that the collision is not exactly the landscape, but a little bit "thicker"

                Then try it in a new map or project. When it doesnt work it re-install the engine. Btw, you use the default third person template without any changes?

                Comment


                  #9
                  Unfortunately, I am a newbie...with a capital N...So I am not sure what you mean by "default third person template without any changes"

                  Comment


                    #10
                    e.g When you have created a project with the 3rd person bp template + havent done any changes (e.g the jump height, collision capsule,....) Because probably your character is causing the problem

                    Comment


                      #11
                      Not sure if this has anything to do with it, just thought I would add this just in case.

                      Do you by any chance have more than one landscape in your level by accident? Have a look at the "Scene Outliner" panel with all of the objects that are in your level, there should only be one "Landscape" and one "Landscape...Gizmo", if there are more than one (named Landscape0, Landscape1 etc) make sure to delete it and try again. the fact that you can walk around below the landscape is strange...

                      If that doesn't help, are you able to move the camera around freely when you are under the landscape? If it isn't colliding with the landscape it is something to do with the collision settings on your character, and/or, the landscape. Try placing a box on the landscape and see if you can walk right through it or not, that might help narrow it down a bit.
                      Free Community Ocean & Sky Project || Join us on Discord! || Trello Roadmap

                      Comment


                        #12
                        Dotcam,

                        Unfortunately I have only one landscape and gizmo in the level....and I do not actually walk behind the landscape rather I move into or sink into a bit. This is happening I figure because my imported landscape is not holding its detail or the detail is muted. Only by sculpting a bit of the landscape in a quad does the definition come back and I am able to move about normally.

                        I have uninstalled and reinstalled UE4 and still have the same issues.

                        Please see my Before and After Landscape pics:

                        Before:

                        Click image for larger version

Name:	LandscapeShotBefore.png
Views:	1
Size:	775.8 KB
ID:	1056200


                        After Landscape Sculpt:

                        Click image for larger version

Name:	LandscapeShotAfter.png
Views:	1
Size:	830.1 KB
ID:	1056201

                        Any help would be great on this muting issue

                        Nadragul

                        Comment


                          #13
                          Originally posted by Nadragul View Post
                          Dotcam,

                          Unfortunately I have only one landscape and gizmo in the level....and I do not actually walk behind the landscape rather I move into or sink into a bit. This is happening I figure because my imported landscape is not holding its detail or the detail is muted. Only by sculpting a bit of the landscape in a quad does the definition come back and I am able to move about normally.

                          I have uninstalled and reinstalled UE4 and still have the same issues.

                          Please see my Before and After Landscape pics:

                          Before:

                          [ATTACH=CONFIG]10450[/ATTACH]


                          After Landscape Sculpt:

                          [ATTACH=CONFIG]10451[/ATTACH]

                          Any help would be great on this muting issue

                          Nadragul
                          Often doing non-uniform scaling on the landscape messes up the collision.
                          Also, that muting I believe is intentional, and done to save resources when you aren't working on that section of the landscape.
                          DO contact me with questions about Blueprint or other Unreal features! I don't bite! Or charge money! Just press that blue Skype button and fire away.

                          Project Culverin - Open Ended First Person Shooter

                          Comment


                            #14
                            Originally posted by Nadragul View Post
                            Dotcam,
                            Unfortunately I have only one landscape and gizmo in the level....and I do not actually walk behind the landscape rather I move into or sink into a bit. This is happening I figure because my imported landscape is not holding its detail or the detail is muted. Only by sculpting a bit of the landscape in a quad does the definition come back and I am able to move about normally.

                            I have uninstalled and reinstalled UE4 and still have the same issues. Any help would be great on this muting issue
                            Ok a couple more questions here:

                            - What is the size (in pixels, like 2048x2048) of the heightmap you are importing? Also which file format (raw, png etc)?
                            - Was the heightmap created in a separate program such as World Machine, Terragen, Scape?

                            The fact that you need to use the landscape tool to get the detail to show up, and also that you sink into it, sounds like an issue with the LOD on the landscape. If you zoom out from a mountain on the landscape, you will see it morph into a lower level of detail after a certain distance, and sometimes it can radically change the shape of the mountain.

                            It almost sounds like that is happening, but way to close to the camera/player. Can you select your landscape from the list of items in Scene Outliner, and then look into the details panel, under the LOD section there are 4 settings. Check the settings, in my level they are set like this:

                            Max LODLevel = -1
                            Export LOD = 0
                            LODDistance Factor = 1.0
                            LODFalloff = Linear

                            Let me know if any of that helps at all, it's a really strange issue you are having...
                            Free Community Ocean & Sky Project || Join us on Discord! || Trello Roadmap

                            Comment


                              #15
                              Size: 2017x2017 (per UE4 Documentatiom)
                              Creating the map in World Machine

                              My LOD Settings are like yours.

                              Is it possible that my Graphics Card is the issue?

                              Here are my laptop Stats:
                              Intel® Core™ i5-4200M Processor
                              (3M Cache, up to 3.10 GHz)

                              Processor Number i5-4200M
                              # of Cores 2
                              # of Threads 4
                              Clock Speed 2.5 GHz
                              Max Turbo Frequency 3.1 GHz
                              Intel® Smart Cache 3 MB

                              HD Graphics 4600 (1.35 GHz)

                              Comment

                              Working...
                              X