Announcement

Collapse
No announcement yet.

problem with a Static mesh render when built light

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    problem with a Static mesh render when built light

    Hello UE community,

    first message for me, I hope I am on the right place.

    I am starter in unreal with a VFX background.

    I have right now a problem with a mesh,

    done in 3dsMAX
    UV in UV layout
    texture in substance painter
    imported in fbx 2013

    all looks goods in these software,
    When I import to unreal, I had these alerts :
    I checked no seam, exported in triangles.

    Click image for larger version

Name:	log_import_error.JPG
Views:	5
Size:	14.2 KB
ID:	1516676
    BTW, when I clic on doc on the right it goes to broken web links (no docs anymore).


    in unreal no material, it looks like this :
    Click image for larger version

Name:	Pilone_Capture_UNREAL.JPG
Views:	5
Size:	237.5 KB
ID:	1516678
    Click image for larger version

Name:	Pilone_Capture_3dsmax.JPG
Views:	5
Size:	135.4 KB
ID:	1516679







    this mesh is in ONE piece !

    with texture like in substance all is fine :

    Click image for larger version

Name:	Pilone_Capture_material_UNREAL.JPG
Views:	5
Size:	226.4 KB
ID:	1516680
    and the light unbuilt look quite ok !
    but when I buit the light : the most ugly result !!, even in production level.
    Click image for larger version

Name:	Pilone_Capture_material_UNREAL_LIGHT_build.JPG
Views:	6
Size:	314.9 KB
ID:	1516681

    at the origin, the mesh was build with objects not connected together, I thought the importance of small meshes created the lightmap
    textures result.
    So I did a whole retopology unifying everything to be sure to not have adjacent face/elements conflicts.

    so apparently, the concern is at the lightmap ( built in auto) /build light step.

    I read the page about the light map (that pushed me to redo the mesh retopo.

    but without result success.

    can the community can push me a step foward please.

    PS : this is a VR scene, everything works fine on VIVE until now

    Thank you !







    Attached Files

    #2
    The lightmap resolution is too small

    Comment


      #3
      thank you Darthviper,

      I really appreciate your feedback and not being alone on this !

      You re right, I advanced during the day on the issue and the first thing I pushed is an override on the lightmap resolution (1024) tu get a better finish.

      I even went in 3dsmax to manually inject a second UV, and used the max editor to get more space between mesh.

      here is the result , when light built and the UV2 seen in the editor.

      even with a lot of space I still have massive streaks. the shape is very convexe ...
      Does I have to make more space in the UV ? or is it useless ?

      or another option ? thank you !

      Click image for larger version

Name:	pilonev2_issueB1.JPG
Views:	7
Size:	30.5 KB
ID:	1516880Click image for larger version

Name:	pilonev2_issueB2.JPG
Views:	6
Size:	165.2 KB
ID:	1516881












      Comment


        #4
        Your lightmap UV's could be much much better, you want to try to have as few UV seams as possible and only split things so that it avoids distortion. In those UV's you have a bunch of thin or small parts which won't turn out well, and there's a lot of unused space because of how many seams there are. To get the best results, you need to do the lightmap UV's manually, there isn't an automatic method that does a good job. The option to automatically generate lightmap UV's in UE4 only takes existing UV's and runs a flattening/packing algorithm, it doesn't create UV's from scratch.

        Comment


          #5
          It's also likely the model wasn't created in a way that would bake well. Small thin pieces of geometry with lots of tight right angles often fail to bake well due to there not being enough resolution, too many seams, etc.

          I'd suggest trying to use a normal map for most of those details, and simplifying the model.

          Comment


            #6
            thank you Darth and Zad for your feedbacks

            I hear all your points. the UV readjusment definitly is something I have to refine.

            for the modeling, sure there might have more to optimise too, but a normal texturing is exactly what I would like to not go.

            is there a way to keep the preview not light built mode as an option for bake ? cause that s quite ok for me there ?

            Comment


              #7
              Ok, I come back to close this subject to give finally a solution ! :

              many people commented the mesh as I thought as the source of the problem.
              and this morning I woke upwith a tech from post in mind, let me explain :

              when you do a microscopic simulation, you don t work in microscopic scale?. My concern was to able to see the mesh with a good render when the light was not baked. so the problem is coming more from the lvl of precision of the engine to bake small objects !

              I just changed the scale of the mesh to 2, and tada !!! no problem anymore....

              Click image for larger version

Name:	scale-x2.JPG
Views:	6
Size:	45.4 KB
ID:	1517965

              conclusion : Depending the level of precision of your mesh, you might not have to work on scale 1 !

              thank you all for shaking my brain !


              Comment

              Working...
              X