Announcement

Collapse
No announcement yet.

Zbrush importing question.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Zbrush importing question.

    I have a human head, less than 400k polys. if I import at FBX my mesh inside the editor looks like this...... The first pic is the mesh in Keyshot. the 2nd in me attempting to import it to the editor but i get loke a few specs of the mesh. If I do import it as a OJB..... i get the 3rd pic. In which is almost there but is missing a few polygons. What is causing this?
    Attached Files
    Last edited by syrom; 08-08-2018, 05:58 PM.

    #2
    Zbrush is not designed to export directly to UE4, you should export to a different program first (like 3ds Max/Maya/Blender/etc.) and prepare it there before exporting to UE4.

    Comment


      #3
      Originally posted by darthviper107 View Post
      Zbrush is not designed to export directly to UE4, you should export to a different program first (like 3ds Max/Maya/Blender/etc.) and prepare it there before exporting to UE4.
      I'm fully aware that it's not supported directly from zbrush. What I'm doing is I'm exporting it from zbrush to 3D Max and then from 3D Max 2 Unreal Engine editor, but I'm getting these weird Imports

      Comment


        #4
        btw... using the latest 4.2.0.1
        Will do a test with 4.19

        Comment


          #5
          You can easily use Zbrush to export directly into UE. I've done hundreds of meshes this way... Though for characters, you'll have to go through another DCC app like Maya/Blender/3dsmax/etc for skinning/rigging/animating/etc. If you're using new versions of Zbrush, such as 2018, you can export as an FBX. You have to do it from Zplugins menu at the top, go to the FBX export/import tab and do your business.

          I don't recommend using a 400k poly/800k tri version of your face though.

          Duplicate the subtool
          Retopologize down to a simpler base mesh either manually or with tools like Zremesher(definitely suggest manually for characters)
          Divide it to match close to the poly count of your original mesh tri count
          Project all onto the face to project your original high quality base mesh onto the new retopo'd mesh
          You're done with your original mesh and won't really need it again
          On the new mesh, drop down your division levels to the tri count you want your mesh to be in engine
          Delete lower subdivisions, if there are any, so that it's your new base(or keep clone them off to a subtool copy to construct LODs for later)
          UV map the mesh
          Paint it
          Bake normals from the highest subdivision level onto the lowest (or export the low and high versions to bake in another app like Xnormal)

          You can use that normal map in UE, just make sure you either flip G within your normal map baker or flip it in UE.
          Last edited by IronicParadox; 08-09-2018, 12:40 AM.

          Comment


            #6
            ok .. further testing. Same results with 4.19. but got this new info. Seems lioke its the format fbx.if i send it as a ojb, i get this result on the first pic. only issue is... i cant get the 2nd UVW channel to stick. The send pic is FBX again and it gives me these weird shadows like the mouth area. ANy idea whats going on? Normally, whats the best format to save it in?
            Attached Files

            Comment


              #7
              Originally posted by IronicParadox View Post
              You can easily use Zbrush to export directly into UE. I've done hundreds of meshes this way... Though for characters, you'll have to go through another DCC app like Maya/Blender/3dsmax/etc for skinning/rigging/animating/etc. If you're using new versions of Zbrush, such as 2018, you can export as an FBX. You have to do it from Zplugins menu at the top, go to the FBX export/import tab and do your business.

              I don't recommend using a 400k poly/800k tri version of your face though.

              Duplicate the subtool
              Retopologize down to a simpler base mesh either manually or with tools like Zremesher(definitely suggest manually for characters)
              Divide it to match close to the poly count of your original mesh tri count
              Project all onto the face to project your original high quality base mesh onto the new retopo'd mesh
              You're done with your original mesh and won't really need it again
              On the new mesh, drop down your division levels to the tri count you want your mesh to be in engine
              Delete lower subdivisions, if there are any, so that it's your new base(or keep clone them off to a subtool copy to construct LODs for later)
              UV map the mesh
              Paint it
              Bake normals from the highest subdivision level onto the lowest (or export the low and high versions to bake in another app like Xnormal)

              You can use that normal map in UE, just make sure you either flip G within your normal map baker or flip it in UE.
              Good tips, Ill look into what you are suggesting. The mesh is highly detailed with pores and wrinkles. You dont see it since its a lower mesh i posted for testing purposes.didnt know about the fbx plugin. Will dive into that and see what happens.Btw... have you guys noticed how much FASTER ojb imports compared to fbx?
              Last edited by syrom; 08-09-2018, 12:56 AM.

              Comment


                #8
                LOLOLOLOLOLOL! I tried the fbx plugin. It gave me very similar results to importing it as FBX through max. Oh lordy..... :/

                Comment


                  #9
                  It might be a normal issue. You might have to import it into another DCC and fix your normal smoothing groups.

                  Comment


                    #10
                    You need to learn about how to make meshes for games.
                    Typically you bake your small details(wrinkles, pores) to a normal map, so your head should be a much much lower polygon count but with a normal map you'll still have the detail.

                    Comment


                      #11
                      Ok.... turned out CULING on project settings helped. Changed it from .03 to .01. Now the fbx import look like this. Huge improvement but I am getting a anomaly in the corner of the mouth. But I will drop the Poly count in which should help. Here is a pic......
                      Attached Files

                      Comment


                        #12
                        Hmmm.. had the issue return. It's not the culing. Might be hardware limitations. I have to re import sometimes to getva clean mesh. Ohh welll

                        Comment

                        Working...
                        X