Announcement

Collapse
No announcement yet.

Network/Steam connectivity issues using John Galt's SteamBase project

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Network/Steam connectivity issues using John Galt's SteamBase project

    Hello,
    I'm currently working on a multiplayer project and as a base I'm using John Galt's 'SteamBase' project, see here:
    https://forums.unrealengine.com/comm...on-to-projects

    I can locally use LAN mode just fine, while steam works partially (tested with a friend):

    There is a problem when using steam and launching from the editor, which seems like it could be a configuration issue.

    While I can both host and join fine using a packaged version of the project, my hosted session is invisible to my friend when I host launching a 'standalone game' from the editor, also I cannot join his hosted sessions from the editor, no matter if he hosts packaged or using the editor.
    I can however join his hosted sessions (editor and packaged) using the packaged version.

    So it works for him, but not for me, the question is why?

    I've tried adding firewall rules (windows 10 fw), completely disabling the firewall to make sure, nothing seems to make a difference.

    We are using the exact same project files (shared via scm) btw.

    Any ideas on what could be causing this?

    #2
    Hey, thanks for getting back to me. Yeah, we've already stumbled because of the download region thing, apparently Hamburg and Berlin (Germany) are not close enough... ;-)
    I guess this would be nice for en efficient workflow, since packaging the project every time to test will become time consuming fast, and as I said, for my friend at least, this does seem to work.
    Thanks again for your feedback and of course for providing the base project in the first place!

    Comment

    Working...
    X