Announcement

Collapse
No announcement yet.

Setting up collision

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Setting up collision

    I'm just starting to learn Unreal. I imported a simple house that I made in Blender. I can't walk through the space I made for the door. I think it has something to do with the collision. Does anyone know how to fix it so I can walk into my house? Thanks.

    #2
    Easy, one simple and fast way to do it. Double click on the mesh icon. Go to collision settings usually on the right, go to collision complexity and choose use complex collision as simple. done

    Another more time consuming way is to make inside blender another copy of the same mesh and name it same name but add UCX like this:

    UCX_Mesh_001
    Mesh_001

    Export in the same FBX file
    Last edited by graphicsgriffin; 04-16-2018, 05:23 AM.

    Comment


      #3
      How to make collision to ignore some characters?
      Example1: red team can pass through the shield, blue team - can't.
      Example2: enemies can walk through the map's border, player - can't.

      Comment


        #4
        Oh! I've just find the solution. I looked for it for 2 days!
        I've added a new Object channel in Edit->Project Settings->Collision.
        Then I've set up an object type of my Blocking volume to this new channel.
        Then I've set my character collision to ignore this new object channel collision.
        PS. Sorry for my English.

        Comment


          #5
          Originally posted by ShieldGenerator View Post
          Oh! I've just find the solution. I looked for it for 2 days!
          I've added a new Object channel in Edit->Project Settings->Collision.
          Then I've set up an object type of my Blocking volume to this new channel.
          Then I've set my character collision to ignore this new object channel collision.
          PS. Sorry for my English.
          Thanks for the tip

          Comment


            #6
            I just used simple collision and scaled the boxes to the shape of the walls. Couldn't get complexity to work.

            I have one other problem.
            The material can only be seen on the outside of the house. It disappears on the inside. Does anyone know why this is?

            Comment


              #7
              By default UE4 uses 1 sided rendering for materials/polygons (also called backface culling). This is a performance optimization.

              Comment

              Working...
              X