Announcement

Collapse
No announcement yet.

SpeedTrees displaying black

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    SpeedTrees displaying black

    I am working on an ArchViz scene using Unreal Studio VR template,
    I placed some of our Speedtrees plants and trees using a different method. Some are manually placed others are placed using the Foliage tools.

    The plant with the foliage tools are displaying black on the editor. if I test the scene everything renders fine, but when I compile and launch it is random, some will render others will display black.
    If I close the game and play it again then everything change, some will show black others will show OK.
    Never seems this behavior before when we used Unreal.

    Thanks
    Fco.
    Attached Files
    Last edited by fco3d; 03-28-2018, 07:49 PM.

    #2
    OK, so the deadline is upon me and I don't have time to debug this anymore, What I found was that there is a Speedtree shader node that gives color variation to the plants/Trees. This is causing some problem when used with the Foliage tools and make everything render black. Tested compiling in different machines, the problem always shows the same.I did disable that node and problem solved.
    Not sure if it is Epic bug or Spreedtree company, but there you have it if someone finds the same problem.

    Comment


      #3
      Hi Patron,

      Maybe a little late, but think I had the same problem and traced it back to the `normalise' vector node in the speedtree colour variation.
      Simple fix-replace the normalise with the SafeNormalize node. Hope it works for you.

      Comment


        #4
        Thanks for the response cosmologist, that fixed the issue on my end as well. Even the trees from the sample library seem to be affected by this bug.

        Comment


          #5
          Thank you cosmologist, your method works perfectly.

          Comment


            #6
            This may be related to this bug which is fixed in 4.19.2

            Comment


              #7
              Thanks @cosmologist I'll try that out next time.

              Comment

              Working...
              X