Announcement

Collapse
No announcement yet.

FBX imports at 1:100 scale and is automatically scaled up again

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    FBX imports at 1:100 scale and is automatically scaled up again

    I've noticed when importing FBX files into Level
    File > Import Into Level

    Any FBX files I import from Blender are imported as scaled down by 100 and then scaled up again in the scene by 100.

    This means they display correctly so things work fine.

    However, when importing objects that should be of a fair size ( 1m x1m cube) I get a warning

    "Warning: The imported mesh is very small. This is most likely an issue with the units used when exporting to FBX."

    How can I get these files to not be imported at scale 1:100?

    If I simply click in content browser and chose "Import Asset" they get imported at the correct scale, but I like the FBX scene file that gets created when I import them using the File > Import Into level method. This allows me to reimport the entire file (containing many FBX meshes) at once.

    I've tried setting units differently in Blender, in the scene and in the fbx export dialog, but still get the same results in UE4

    UE4 Version: 4.18.3-3832480+++UE4+Release-4.18

    Last edited by Andypants; 02-27-2018, 08:42 AM.

    #2
    Thats funny, I export with Maya 2018 and with the "Import Asset" I get a wrong scaling. The transformation node doesn't seem to be imported, so a Box scaled 100x100x100 gets in with 1x1x1...
    But importing with File->Import Into Level gives me a BP_Actor with everything correctly scaled...
    Drives me crazy, got some pics here:
    https://answers.unrealengine.com/que...7177/view.html

    Did you found any solution?

    Comment


      #3
      The default blender unit is 1 metre whereas the default unreal unit is 1cm. I never set the scale in blender, nor in unreal. I just work at 1:1 at all times. This is practical as long as your don't model anything bigger than a house or smaller than an iphone. Keeping it 1:1 means you are not going to get any clipping issues in blender or any weird complaints from unreal when you import. At least not for static meshes.

      Of course, through all of this I am assuming that when you see 1.00 in blender you know it means 1 metre or 100cm or 100 unreal units. And if I see 0.01 in blender I know this means 1cm or 1 unreal unit. They are just different units, I am not scaling anything during import or export.

      So most people might think that the default cube it small but it is huge, it is 2 metres by 2 metres by 2 metres. Bigger than the mannequin. If you are one of the few people who can actually leave the default cube in your scene long enough for you to export it as an FBX, you should import it into unreal, to a third person template, to see what I mean.

      Comment


        #4
        Your modeling environment should be configured to work in centimeters space...
        Some default to meters, some default to millimeters, etc.
        On FBX exporter settings you should be able to set units to centimeters as well.
        | Savior | USQLite | FSM | Object Pool | Sound Occlusion | Property Transfer | Magic Nodes | MORE |

        Comment

        Working...
        X