Announcement

Collapse
No announcement yet.

Render Distance Pulling My Hair !!!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Render Distance Pulling My Hair !!!

    So I have been working on my game and recently moved from 4.15 to 4.18 and the camera at a distance does not render texture quality correctly , my meshes look blurry till up close . How can I have small level area look at the correct quality at any distance ? Please help examples below .
    Ex1: https://youtu.be/miXf95zxCgQ
    You can see my Texture on the cabin walls are blurry, how can I fix the textures to always look crisp at any distance and any Fire I put in the world does not give reflections WHY ? Please help .
    Ex2: https://youtu.be/VPDG_DlpOuo

    #2
    Is the chainlink fence using an opacity mask driven by a texture? If so, you can set that texture's compression mode to none and set it to not generate mips, that should keep the opacity mask consistent at any distance.

    As for the blurry textures, it looks like your map is unbuilt by the lighting out of date warning in the viewport. Try clicking on the drop-down next to build and select "Build Texture Streaming" and see if things get any better for static meshes in your scene. If this doesn't help it, then you might want to profile your texture usage in the scene and make sure you're not loading too many high res textures at once.
    @Brian__May

    Comment


      #3
      You might also want to check in the scalability settings drop down for the "monitor editor performance?" and uncheck the box. If that doesn't work, then chances are, Brian is correct and it's being caused by streaming overload. If worst comes to worst, you can disable the streaming while you work on things. It's in the engine=>rendering settings tab and I also want to say you can also use the console command r.textureStreaming 0 or 1, while in game, but I could be wrong. I never pay attention to it, but I'm not sure if the commands are case sensitive or not because I always type them in the way they shown in the console.

      Comment


        #4
        Thanks for the help guys , But nothing helped and I even tried adjusting my texturepool . I don't know what else it could be at this point anymore suggestions would be greatly appreciated.

        Comment


          #5
          https://forums.unrealengine.com/comm...istance-whyyyy
          https://www.casualdistractiongames.com

          Comment


            #6
            Hello, I'm experiencing a similar issue. Did you manage to resolve it?
            PLAYNE : The Meditation Game

            Comment

            Working...
            X