Announcement

Collapse
No announcement yet.

Landscape LODs different shades when level streaming

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Landscape LODs different shades when level streaming

    hi there
    I am just learning level streaming but I am now trying to use LODs on the lanscape, which the level editor does automatically, but the levels are coming out a different shade. not sure what I should do.

    Thanks in advance for any help you can give to me.

  • #2
    let me know if I need to give more info.
    Last edited by chierfarchon; 09-13-2017, 06:20 AM.

    Comment


    • #3
      Here is another picture

      Comment


      • #4
        does this happen in all areas, or just seems like only a few parts get his effect?
        I have seen LODs do weird stuff to landscapes, and, materials.
        I have hand random areas go back to the grey and black squares for no reason at all before using LODs ...

        anyways - this happens on certain areas, or, all areas?
        Founder and CEO of Angry Penguin Studio, LLC
        Dallas, TX USA
        https://www.facebook.com/AngryPenguinStudios

        Comment


        • #5
          HI AP_Studio

          This happens on all areas. It's whenever the default terrain borders with an LOD terrain.
          Last edited by chierfarchon; 09-14-2017, 04:07 AM.

          Comment


          • #6
            Originally posted by chierfarchon View Post
            HI AP_Studio

            This happens on all areas. It's whenever the default terrain borders with an LOD terrain.
            I just noticed "Level Steaming" is in the title.
            I have never gotten level streaming to ever work as intended. Is your landscape that big that you need level streaming on?
            If you export height map, and, import as a single map, does this still happen?
            This maybe an issue with level streaming and how it culls light, materials, and the parts of the landscape itself ..

            i say test with one heightmap and dont use level streaming and see if you get the same results.

            edit: i wonder if when you see this issue, if its because not enougt of that square is loaded in to properly stream it ... im not sure how the specifics of the level streaming works, but, looking at the pics again, that maybe it. It maybe a LOD thing with the material/landscape.

            I wonder if the LOD is causing the light properties to not function (like in a tree, you can tell it to pull out all "additives" on X LOD)

            hmmmmm, dat rabbit hole tho ...
            Last edited by AP_Studios; 09-14-2017, 04:28 PM.
            Founder and CEO of Angry Penguin Studio, LLC
            Dallas, TX USA
            https://www.facebook.com/AngryPenguinStudios

            Comment


            • #7
              Can the big terrains be level streamed to load themselves in bit by bit? Like sacerd 2 did by loading sections of it? . how do you set this up?

              Comment


              • #8
                Not sure I understand half of what you guys said, but it is currently 11x11 levels, but that is not the whole of it by far. So far this is just me testing.

                I am using World Composition.

                When you say Test with 1 heightmap, do you mean 1 LOD ?

                The LODs are created using the level editor, I just said make me a LOD 1 and it did so.

                I'm very new at all this lol
                Last edited by chierfarchon; 09-15-2017, 05:37 AM.

                Comment

                Working...
                X