Announcement

Collapse
No announcement yet.

Landscape texture

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Landscape texture

    Hi

    I have a landscape and a single texture to cover it all.
    When I apply the texture to the landscape, it tiles it thousands of times... I just want it one time, over the entire landscape.

    I know this is not the proper way to do a detailed landscape, I'm just learning, and this is a step I need to take.

    Can someone point me in the right direction?
    Easy weapons in Unreal Engine 4:
    Check out Realistic Blueprint Weapons

    Currently doing a tutorial series on Vectors and what they are good for.
    Please visit Unreal Unscripted

    #2
    Use a landscape layer coord to scale it up:

    http://www.youtube.com/watch?v=FHVuVVHlUmM (1:30)

    Comment


      #3
      Originally posted by fighter5347 View Post
      Use a landscape layer coord to scale it up:

      http://www.youtube.com/watch?v=FHVuVVHlUmM (1:30)
      That worked.

      To other newbies who might search and find this thread;


      You have 3 things in the material editor for the landscape material. LandscapeLayerCoords, which outputs into the left side of a TextureSample, which goes into the Base Color on the material itself.
      Set the Mapping Scale on the coordinates to the resolution of your texture.
      Easy weapons in Unreal Engine 4:
      Check out Realistic Blueprint Weapons

      Currently doing a tutorial series on Vectors and what they are good for.
      Please visit Unreal Unscripted

      Comment


        #4
        Remember to always set the texture mapping scale to the size of your landscape , if you have 2017 landscape , then set mapping scale of your texture to 2017 even if its 4096 resolution it doesn't matter .

        Comment


          #5
          Originally posted by Arendt View Post
          Remember to always set the texture mapping scale to the size of your landscape , if you have 2017 landscape , then set mapping scale of your texture to 2017 even if its 4096 resolution it doesn't matter .
          Yes, this is important... I had 4096 set on my 4033 map... it made it a tad better when I fixed this. Thanks

          Now on to remove the shine from the landscape. Any pointers?
          Easy weapons in Unreal Engine 4:
          Check out Realistic Blueprint Weapons

          Currently doing a tutorial series on Vectors and what they are good for.
          Please visit Unreal Unscripted

          Comment


            #6
            Make sure the material is 0 metallic and 1 roughness?

            That should do it I believe, from the videos I've watched.

            Comment


              #7
              You have to set the specular to 0 (constant node)

              Comment


                #8
                Originally posted by fighter5347 View Post
                You have to set the specular to 0 (constant node)
                Thanks.

                As a side note... this is so much more logical than Unity.
                Easy weapons in Unreal Engine 4:
                Check out Realistic Blueprint Weapons

                Currently doing a tutorial series on Vectors and what they are good for.
                Please visit Unreal Unscripted

                Comment


                  #9
                  Cool. This is exactly what I need.

                  Comment


                    #10
                    Originally posted by fighter5347 View Post
                    You have to set the specular to 0 (constant node)
                    Whaaa...please dont do this

                    I mean you can, but its a hack Just make a proper roughness or increase roughness to 0.85 with a constant. Touching Spec is actually not recommended since it does something completely different in pbr than you are used to from traditional shading approaches
                    Check out UNREAL 4 Lighting Academy
                    https://forums.unrealengine.com/show...ng-like-that-)

                    Comment


                      #11
                      Whilst this is basically true there are some situations where you would need to break the rules.
                      I found myself setting the specular close to zero (roughness close to 1 at the same time) for a landscape with only basic colors / no normal maps. The ground on this one does not look like grass at all, does it? http://abload.de/img/ue4_envlandscape_002nwux9.jpg
                      3.14159265359

                      Comment


                        #12
                        Yep, same here, I also get a pretty non-realistic result when I do it with roughness and specular -> that's why I have set the spec to 0 (since the beta I'm doing it like that)

                        Comment


                          #13
                          Whaaa...please dont do this
                          Why not? A specular *exponent* of 0 in a Phong-style specular would be "bad" but a specular *multiplier* of 0 should be fine; it's just like a black gloss map.
                          I'd be more concerned with setting roughness to 0 to "turn off" specular -- that sounds to me like more of a hack, because you're still saying "generate a bunch of specular, and then spread it out over an infinitely large highlight area."
                          Is there some documentation that suggests why this understanding would be wrong?

                          Comment


                            #14
                            What is wrong with this: http://gyazo.com/0933eb6dfe9e36d30760b6096b1ea1d6 ?

                            Comment


                              #15
                              Originally posted by eggfriedbryce View Post
                              What exactly do you mean?

                              When you are not abel to paint onto your landscape, you will have to add landscape layer weights https://docs.unrealengine.com/latest...als/index.html

                              Comment

                              Working...
                              X