Announcement

Collapse
No announcement yet.

Lightmap Resolution Problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Lightmap Resolution Problem

    I'm having a problem having high quality shadows forming off of a mesh. I modeled this plant with proper unwrapping, textures, and a uv lightmap. I used blender to model my object but for some reason if the lightmap resolution for the object is less than 512 the shadows are blocky. I don't want to have the lightmap resolution for that object so high because then building lighting takes forever. How can I fix it so shadows are detailed without having such a high resolution to make building so long?

    Shadow Image: https://gyazo.com/e10becf11bfc496edcbb9eb5406ba114
    Texture Image: https://gyazo.com/9f43b15d5e735ad3fdd7150631b9e4ef
    UV Channel 1: https://gyazo.com/72cc909041fbcabc034d1f356b5bcd6b
    UV Channel 2: https://gyazo.com/2709ad14f5168d32d5a14aa3dfe8c6de
    Mesh Editor: https://gyazo.com/3b1711ca9e9d40664956ed75adc08e2e

    #2
    Looking at the first screenshot, it seems you are concerned about the "blocky" shadow that the plant casts on the window sill...
    The UVs of the plant or the lightmap resolution of the plant is completely irrelevant for this.
    What matters is the UV map and lightmap resolution of the shadow receiver, in this case the window sill...
    Thats where the shadow is "drawn onto" in the light baking process.

    Comment


      #3
      Originally posted by KVogler View Post
      Looking at the first screenshot, it seems you are concerned about the "blocky" shadow that the plant casts on the window sill...
      The UVs of the plant or the lightmap resolution of the plant is completely irrelevant for this.
      What matters is the UV map and lightmap resolution of the shadow receiver, in this case the window sill...
      Thats where the shadow is "drawn onto" in the light baking process.
      The only problem with that now is that if i put the lightmap resolution for the sill higher than no shadow gets casted onto it.

      Lightmap resolution for the sill under the plant is 64
      https://gyazo.com/84ef0084090c3638189347b85ab4f39d

      Comment


        #4
        Did you rebuild lighting? (Seriously, sometimes people forget that )
        Then there is something wrong on your sill mesh settings.
        Is is possibly set to movable? Or did you disable shadow casting on the plant / shadow receiving on the sill?

        Apart from that: Did you place a lightmap importance volume in your level ?

        Comment


          #5
          Originally posted by KVogler View Post
          Did you rebuild lighting? (Seriously, sometimes people forget that )
          Then there is something wrong on your sill mesh settings.
          Is is possibly set to movable? Or did you disable shadow casting on the plant / shadow receiving on the sill?

          Apart from that: Did you place a lightmap importance volume in your level ?
          Yeah I rebuilt the lighting after I changed the lightmap resolution for the wall, that's the picture in the link. The wall is a brush box because I have a subtractive brush box that makes up the window view. The box brush doesn't have a static, stationary, or movable. I did test it and put the plant onto a box shape that is static and the same result happens. Lightmap importance volume?

          Comment


            #6
            I did test it and put the plant onto a box shape that is static
            And the plant is also static?

            Also: What types of light are you using?

            Lightmap importance volume?
            Yepp. Under the volumes section. Put it around your level. It helps lightmap to focus on your level...

            Comment


              #7
              Originally posted by KVogler View Post
              And the plant is also static?

              Also: What types of light are you using?


              Yepp. Under the volumes section. Put it around your level. It helps lightmap to focus on your level...
              The plant is static, I'm using a spotlights around the room, what do you mean by around your level? Should I make it the size of the room or as big as the map will be?
              I made it as big as the room and there's no effect for the shadows.

              Comment


                #8
                Yeah, the volume goes over everything that you want to look nice. So usually all the playable area.
                If you leave stuff out, it gets rendered in a lower quality.. Speeds up light build. If you have it around your room, lightmap will focus on that..

                Do other actors in your scene cast shadows?

                Comment


                  #9
                  Originally posted by KVogler View Post
                  Yeah, the volume goes over everything that you want to look nice. So usually all the playable area.
                  If you leave stuff out, it gets rendered in a lower quality.. Speeds up light build. If you have it around your room, lightmap will focus on that..

                  Do other actors in your scene cast shadows?
                  Yeah every object I imported has the Cast Shadow check marked. They all produce crappy shadows on objects though and it makes me mad because I have no idea what could be causing it. My object is properly textured and unwrapped so how is it that the shadow is terrible. As I increase the lightmap resolution for the walls, there's no shadow. But when it's 1 it's back but blocky.

                  Comment


                    #10
                    1
                    Waaaaaiiit a minite...
                    What do you mean by "1".. the lightmap resolution should be something like 32, 64, 128, 256, etc...
                    A value that is indeed "1" for most meshes that use static lighting is the LightmapResolutionIndex
                    Dont confuse these two

                    One twist: While a larger lightmap resolution value on a StaticMesh means a hight lightmap resolution, you need to lower the resolution value on BSP brushes.
                    This is because for static meshes the lightmap resolution refers to the pixel resolution of the lightmap, whereas for bruishes the value describes the distance between lighting sample points. Thus lower values there means a higher resolution

                    Comment


                      #11
                      Are your scalability settings on Epic? By default the engine bakes High Quality and also Low Quality Lightmaps.

                      Comment


                        #12
                        Originally posted by KVogler View Post
                        Waaaaaiiit a minite...
                        What do you mean by "1".. the lightmap resolution should be something like 32, 64, 128, 256, etc...
                        A value that is indeed "1" for most meshes that use static lighting is the LightmapResolutionIndex
                        Dont confuse these two

                        One twist: While a larger lightmap resolution value on a StaticMesh means a hight lightmap resolution, you need to lower the resolution value on BSP brushes.
                        This is because for static meshes the lightmap resolution refers to the pixel resolution of the lightmap, whereas for bruishes the value describes the distance between lighting sample points. Thus lower values there means a higher resolution
                        I used 1 for the lightmap resolution on the walls because if it's anything higher than there's no shadow. For the plant if I have it below 256 the shadow is very blocky.


                        Originally posted by helluvamesh View Post
                        Are your scalability settings on Epic? By default the engine bakes High Quality and also Low Quality Lightmaps.
                        How can I change it so it only bakes at high resolution. I don't understand why anyone would want both.

                        Comment


                          #13
                          For the plant if I have it below 256 the shadow is very blocky.
                          The lightmap resolution of the plant only affects shadows that are cast on the plant.
                          It is in no way affecting the shadow that it casts onto the wall. Only the walls lightmap resolution and UVs and your light settings are determining how the plant shadow looks on the wall.

                          I don't understand why anyone would want both.
                          Scalability

                          Comment


                            #14
                            Originally posted by High Kyle View Post
                            How can I change it so it only bakes at high resolution. I don't understand why anyone would want both.
                            Edit---Project Settings---Rendering---Shader Permutation----Low Quality Lightmaps

                            Do you use static mesh or BSP brush for the wall?

                            Comment


                              #15
                              Originally posted by helluvamesh View Post
                              Edit---Project Settings---Rendering---Shader Permutation----Low Quality Lightmaps

                              Do you use static mesh or BSP brush for the wall?
                              BSP brush is what I have for the wall and my scalability is Epic as well as I unchecked the low quality lightmaps and nothing has ever changed.

                              How can I fix this stupid shadow problem? Why would the engine even generate crappy shadow resolution in the first place?
                              Last edited by High Kyle; 01-30-2017, 09:16 PM.

                              Comment

                              Working...
                              X