Announcement

Collapse
No announcement yet.

PSA: Your monitor’s DPI scaling can negatively affect the quality of your AA

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    PSA: Your monitor’s DPI scaling can negatively affect the quality of your AA

    If you are using a 4k monitor with DPI scaling set to more than 100, the Screen Percentage of your renders will be scaled down accordingly. So let’s say your Screen Percentage is set to 200 for nice AA. If your DPI scaling is 150, your actual Screen Percentage will be 133.33 (i.e. 200/150), so the AA won’t be as nice and crisp as expected.

    To fix it, you can either:
    • Set r.SecondaryScreenPercentage.GameViewport=100 (instead of the default 0).
    • Or under EditorPreferences>General>Performance turn on Disable DPI Based Editor Viewport Scaling (I don’t know if this actually does the same thing as r.SecondaryScreenPercentage.GameViewport, but the result is the same).
    • Or if your eyesight is really good, you could just set your DPI scaling to 100% in Windows (under Display Settings).
    Ever since 4.19 (or since I bought a 4k monitor… can't remember which was first) I had been struggling with ugly AA. I knew something had changed but I wasn't sure what. My previous workaround was to render at 4k and resize to 1080 in post, but that wasn’t ideal as renders took four times longer and the files were much bigger. Thought I’d finally try and figure out what was really going on and found this after playing around with almost all the Temporal AA and ScreenPercentage CVars.

    Thought I’d share because I wasn’t able to find anything online about this (at least not specifically relating to rendering from Sequencer). If anyone has better insight into this, feel free to correct me if I got something wrong.
Working...
X