Announcement

Collapse
No announcement yet.

Webcam live video doesn't work (black) on some of my machines

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Webcam live video doesn't work (black) on some of my machines

    This is probably something stupid....I followed the https://docs.unrealengine.com/en-US/...ams/index.html tutorial and setup a live webcam into a sample unreal project on my work machine and it worked great. Then I went to my machine at home and did the same thing (with the same webcam) and I don't get any video, just a black screen.

    The "camera" app in windows detects the camera and shows video ok. In unreal the webcam shows up in the MediaPlayer asset list of sources but when selected I just get a black screen and the activity light on the camera does not light. On my work computers (2 of them) it works fine, camera light lights up and I get video as soon as it is selected in the Unreal Media Player asset.

    Is there some Unreal Editor plugin or setting that might not be enabled on my home machine that would stop the camera from working?

    The install on my home machine is a fresh 4.22.3 unreal on windows 1803. Same setup on my work machine, but that one has been used a lot more. The camera (logitech pro hd 920) did not require any driver installation to work on my work machines.

    Any suggestions how to debug this, seems odd that it works on windows camera applications but not in unreal.

    #2
    Hi Greg,

    I wonder, did you find a solution? I am having the same problem - black live video feed although the camera should be working and is working in other applications. I'd highly appreciate to hear if you found a solution. Thanks and all the best,

    Tyler

    Comment


      #3
      I still have some issues with this. The specific fix for the webcam issue I don't remember, it might have just gone away when I updated to the latest unreal. I HAVE noticed that sometimes unreal is just picky. There are a few video capture cards that work fine with a lot of applications but not unreal. For example NDI (video over ethernet) has a thing that is supposed to make an NDI camera show up as a WMF (windows media foundation) source that Unreal should support, but I haven't got it to work. Works to stream video/audio from my iPhone to skype, google hangouts and other stuff, when I try it in unreal it seems to recognize that there is a video feed there and opens it, the tally lights on the phone light up, indicating that unreal has opened the video source up...but on the unreal end I just get black...though the time in the playback window keeps moving forward like it was getting frames.

      Comment

      Working...
      X