Announcement

Collapse
No announcement yet.

UnrealBuildTool Exception: missing source folder

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    UnrealBuildTool Exception: missing source folder

    I am on a Linux machine with UE 4.11 installed, built it and can run the editor with no problem. I have installed it in the Download folder:

    /home/me/Downloads/UnrealEngine/
    I am following this tutorial for setting up a cmake environment to do my C++ development in CLion.
    If I understand the tutorial correctly, I am supposed to have a template game first. I tried going for a blank c++ project and called it `BasicCodeNoStarter`. It is stored in:

    /home/me/Documents/Unreal Projects/BasicCodeNoStarter
    I then go on the terminal and:

    Code:
    cd Downloads/UnrealEngine/ && ./GenerateProjectFiles.sh -cmakefile -game -project "/home/me/Documents/Unreal Projects/BasicCodeNoStarter/BasicCodeNoStarter.uproject"
    When I do that, I get:

    UnrealBuildTool Exception: ERROR: Directory '/home/me/Downloads/UnrealEngine/Engine/Source/Projects/BasicCodeNoStarter' is missing 'Source' folder.
    It looks to me like it is creating a directory inside my engine installation and failing for some reason. Although I had files in the source directory of my project:

    Code:
    ls "/home/me/Documents/Unreal Projects/BasicCodeNoStarter/Source/BasicCodeNoStarter"
    BasicCodeNoStarter.Build.cs BasicCodeNoStarterGameMode.h BasicCodeNoStarter.cpp
    BasicCodeNoStarter.h BasicCodeNoStarterGameMode.cpp
    I tried adding a class MyActor there and after I did that, Unreal editor compiled the project automatically but that does not change anything. Running GenerateProjectFiles.sh still returns the same error.

    UPDATE

    I managed to get it to build by manually creating the source folder:

    Code:
         mkdir /home/me/Downloads/UnrealEngine/Engine/Source/Projects/BasicCodeNoStarter/Source
    and the CmakeLists.txt gets generated for me and I no longer get the error.

    It generates the cmake file fine. However,

    -The directory
    /Engine/Source/Projects/BasicCodeNoStarter/Source
    does not get populated.

    -The c++ class that I had added to my project through Unreal's IDE, namely MyActor, is nowhere to be found. It is not in the source directory ^ nor is there any sign of it in the CmakeLists.txt file.

    - include_directories and add_definitions both have empty argument lists in the cmake file.

    My guess is that I am missing a step before running the build tool. Any idea what that might be?
    Last edited by Shah29; 04-13-2016, 05:36 AM.

    #2
    I am having this issue as well

    Comment

    Working...
    X