Announcement

Collapse
No announcement yet.

Problems linking to third party static lib

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Problems linking to third party static lib

    I have followed the wiki tutorial here: https://wiki.unrealengine.com/Linkin...e_Build_System

    But I wonder if it is out of date, because I am not having much luck. Despite doing all that, I am still getting unresolved symbols when trying to use my third party library. ZeroMQ specifically in my case.

    #2
    Well, show some Build.cs and Module implementation code. Without it is hard for anyone to tell you what may be wrong...
    | Savior | USQLite | FSM | Object Pool | Sound Occlusion | Property Transfer | Magic Nodes | MORE |

    Comment


      #3
      Originally posted by BrUnO XaVIeR View Post
      Well, show some Build.cs and Module implementation code. Without it is hard for anyone to tell you what may be wrong...
      Can you just trust me that I followed the tutorial precisely? My main question is if that tutorial is no longer correct.

      I'd love to show my build.cs but unfortunately it isn't that simple. Due to MPAA restrictions, production machines aren't connected to the Internet so I would have to retype the whole thing out, no copy/paste. A pain but not a huge deal, but even if I did I need to go through red tape to get permission first. Was hoping to nip the low hanging fruit first and find out if maybe that tutorial is just out of date and no longer correct, and if so what has changed.

      Comment


        #4
        Well, i used the steps from that tutorial to bind a dll into the project (yes, it even works with dlls too^^) so i assume
        it isnt deprecated. The only thing i found a bit less convenient was that it wasnt quite intuitive that you need to click on the picture with the Visual Studio Setup steps.
        Live long and prosper.

        Comment

        Working...
        X