Announcement

Collapse
No announcement yet.

[4.9] Character falling in Blueprint viewport

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    [4.9] Character falling in Blueprint viewport

    Hey all,

    After upgrading from 4.8 to 4.9, I've noticed my Character appears to be falling in the Blueprint viewport (see the screenshot below.) Before the update he was using the idle animation.
    https://forums.unrealengine.com/atta...1&d=1441051597

    Has anybody else experienced this yet?

    EDIT:
    The only reason this is in the C++ section is because the Character has a C++ parent class; very little happens in this Character Blueprint. Feel free to move if it's better somewhere else.
    Attached Files
    Last edited by SolitaryTurian; 08-31-2015, 04:26 PM.

    #2
    Hello ThomasKasene,

    Thank you for reporting this. Does this only happen with this particular blueprint or does it happen with any character blueprint that you assign a skeletal mesh / animation blueprint to? Also, instead of responding here, can you please make a post on the Answerhub in the bug reports section? You can post a link to the new answerhub post here afterwards if you would like.

    Comment


      #3
      Here's the post i made. I did some more testing and it isn't related to the 4.8.3->4.9 upgrade, but it still shows that the Blueprint Viewport is displaying some strange (and possibly unwanted) behaviour.

      I can live with it for now, but I'd be interested to hear whether it's intended to work like this.

      Comment


        #4
        I read your post on the AnswerHub but just like you I'm puzzled why changing the AutoPossess option makes a difference.

        I'm also wondering, are you using a custom animation blueprint or the default one? In the end, the animation blueprint that is active on your skeletal mesh decides what animation to play in the viewport. If you do have a custom animation blueprint, might sharing some screenshots?
        Journeyman's Minimap - Available on Marketplace - Forum topic - Video

        Comment


          #5
          I'm using the SK_Mannequin with ThirdPerson_AnimBP, both from the ThirdPerson project template.

          Comment


            #6
            Originally posted by ThomasKasene View Post
            I'm using the SK_Mannequin with ThirdPerson_AnimBP, both from the ThirdPerson project template.
            I saw this behavior too. Was on a throwaway project, so I didn't think too much of it, but it was a 4.8->4.9 upgrade c++ Third Person project.

            Comment


              #7
              If anyone else finds this thread on Google because you're having the same problem. What finally solved it for me was setting Character Movement Component -> Run Physics with no Controller to False. Then close and reopen the Blueprint and the Character will stop falling in the viewport.

              Comment


                #8
                Originally posted by vib View Post
                If anyone else finds this thread on Google because you're having the same problem. What finally solved it for me was setting Character Movement Component -> Run Physics with no Controller to False. Then close and reopen the Blueprint and the Character will stop falling in the viewport.
                omg thanks for that tip! this has been driving me craaaazy but I've just kind of dealt with it without trying to find a solution. This worked great, thanks again.

                Comment

                Working...
                X