Announcement

Collapse
No announcement yet.

Development Server compilation and Debuging ...

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    well, I still am havin issues starting the server/client in debug mode, but I am able to compile/launch the dedicated
    server basically.
    It runs in headless mode and listens on the Lan IP mode allowing attempts to connect by local lan ip (not by 127.0.0.1)
    but I still really prefer to start it in debug mode. Not happy at all...

    Also the Launcher gives me the complaint when doing it just from the Launcher app or from within the editor..
    Settings are for Windows (not window server / windows client) as both those fails to build:

    Running AutomationTool... Program.Main: Running on WindowsHostPlatform Program.Main: Executed from AutomationToolLauncher (C:\Users\mythic\AppData\Local\assembly\dl3\L1AG9ME1.HNV\VH3B6K3N.K2Y\8fc6cf8d\8eee7c08_8a6bcf01\AutomationTool.exe) Program.Main: CWD=C:\Development\Unreal4\UnrealEngine-4.1\Engine\Binaries\DotNET Automation.ParseCommandLine: Parsing command line: BuildCookRun -project=C:/Development/EWProjects/EwClientFps/EwClientFps.uproject -noP4 -platform=Win64 -clientconfig=Debug -serverconfig=Debug -nocompile -build -skipcook -NoCompile Automation.Process: IsBuildMachine=False Automation.Process: ShouldKillProcesses=True Automation.Process: Setting up command environment
    .......
    LogPackageDependencyInfoisplay: Package Info not found for
    ....
    LogCookCommandletisplay: Failed to find depedency timestamp for:
    ....
    Platform.Deploy: WARNING: Win64 does not implement Deploy...
    ....
    Those 3 warnings will have to be cleared up. More to learn I guess.
    Altho the the one about deploy makes me suspicous setting it to Windows maybe the cause?

    Even more annoying is that if I redo the cooking it deletes out the Server exe I copied in
    Last edited by SteeleDriver; 05-10-2014, 03:11 PM.

    Comment


      #17
      Current state of where I am at...

      LogInit: Version: 4.1.0-0+UE4
      LogInit: Compiled (64-bit): May 10 2014 18:22:38
      LogInit: Build Configuration: Debug
      LogInit: Branch Name: UE4
      LogInit: Command line: Sector0 -server -log
      LogInit: Base directory: C:/Development/EWProjects/EwClientFps/Saved/StagedBuilds/WindowsNoEditor/EwClientFps/Binaries/Win64/
      LogInit: Rocket: 0
      [2014.05.10-19.12.03:507][ 0]LogTaskGraph: Started task graph with 3 named threads and 4 total threads.
      [2014.05.10-19.12.03:537][ 0]LogOnline:Verbose: NULL: Created thread (ID:4232).
      [2014.05.10-19.12.03:538][ 0]LogInit: WinSock: version 1.1 (2.2), MaxSocks=32767, MaxUdp=65467
      [2014.05.10-19.12.03:542][ 0]LogInit: Presizing for 0 objects not considered by GC, pre-allocating 0 bytes.
      [2014.05.10-19.12.03:568][ 0]LogInit: Object subsystem initialized
      [2014.05.10-19.12.03:577][ 0]LogInit: Selected Device Profile: [WindowsServer]
      [2014.05.10-19.12.03:577][ 0]LogInit: Applying CVar settings loaded from the selected device profile: [WindowsServer]
      [2014.05.10-19.12.03:590][ 0]LogInit: Computer: DEVELOPII
      [2014.05.10-19.12.03:590][ 0]LogInit: User: mythic
      [2014.05.10-19.12.03:590][ 0]LogInit: CPU Page size=4096, Cores=3
      [2014.05.10-19.12.03:590][ 0]LogInit: High frequency timer resolution =3.429394 MHz
      [2014.05.10-19.12.03:591][ 0]LogMemory: Memory total: Physical=7.9GB (8GB approx) Virtual=8192.0GB
      [2014.05.10-19.12.03:591][ 0]LogMemory: Platform Memory Stats for WindowsServer
      [2014.05.10-19.12.03:592][ 0]LogMemory: Process Physical Memory: 56.18 MB used, 56.18 MB peak
      [2014.05.10-19.12.03:592][ 0]LogMemory: Process Virtual Memory: 41.03 MB used, 41.16 MB peak
      [2014.05.10-19.12.03:592][ 0]LogMemory: Physical Memory: 5127.00 MB used, 8092.41 MB total
      [2014.05.10-19.12.03:592][ 0]LogMemory: Virtual Memory: 220.27 MB used, 8388608.00 MB total
      [2014.05.10-19.12.04:009][ 0]LogPhysics:Warning: PHYSX: ..\..\module\clothing\src\ModuleClothing.cpp (396) 2 : physx::apex::clothing::ModuleClothing::ModuleClo
      thing: Failed to load the GPU dll 'APEX_ClothingGPUPROFILE_x64.dll'
      [2014.05.10-19.12.06:060][ 0]LogObj: 20932 objects as part of root set at end of initial load.
      [2014.05.10-19.12.06:061][ 0]LogUObjectAllocator: 4982384 out of 0 bytes used by permanent object pool.
      [2014.05.10-19.12.06:072][ 0]LogEngine: Initializing Engine...
      [2014.05.10-19.12.06:073][ 0]OCULUS: OVR:eviceManager - initialized.
      [2014.05.10-19.12.06:121][ 0]OCULUS: OVR:eviceManagerThread - running (ThreadId=0x144C).
      [2014.05.10-19.12.06:121][ 0]LogHMD:Warning: No Oculus HMD detected!
      [2014.05.10-19.12.06:122][ 0]LogHMD:Warning: No Oculus Sensor detected!
      [2014.05.10-19.12.06:123][ 0]LogHMD: Oculus Latency Tester not found.
      [2014.05.10-19.12.06:146][ 0]OCULUS: OVR:eviceManager - shutting down.
      [2014.05.10-19.12.06:146][ 0]OCULUS: OVR:eviceManagerThread - exiting (ThreadId=0x144C).
      [2014.05.10-19.12.06:146][ 0]LogHMD: Oculus shutdown.
      [2014.05.10-19.12.06:173][ 0]LogInit: Texture streaming: Disabled
      [2014.05.10-19.12.06:181][ 0]LogConsoleResponseisplay:
      [2014.05.10-19.12.06:358][ 0]LogConsoleResponseisplay: GraphicsQuality 1
      [2014.05.10-19.12.06:425][ 0]LogPackageName: SearchForPackageOnDisk took 0.052s to resolve Sector0
      [2014.05.10-19.12.06:425][ 0]LogNet: Browse: /Game/Maps/Sector0?Name=FreshMeat
      [2014.05.10-19.12.06:426][ 0]LogLoad: LoadMap: /Game/Maps/Sector0?Name=FreshMeat
      [2014.05.10-19.12.06:505][ 0]LogMemory: Platform Memory Stats for WindowsServer
      [2014.05.10-19.12.06:505][ 0]LogMemory: Process Physical Memory: 114.88 MB used, 134.93 MB peak
      [2014.05.10-19.12.06:506][ 0]LogMemory: Process Virtual Memory: 94.71 MB used, 147.37 MB peak
      [2014.05.10-19.12.06:506][ 0]LogMemory: Physical Memory: 5202.57 MB used, 8092.41 MB total
      [2014.05.10-19.12.06:507][ 0]LogMemory: Virtual Memory: 313.96 MB used, 8388608.00 MB total
      [2014.05.10-19.12.06:508][ 0]LogMemory:
      [2014.05.10-19.12.06:509][ 0]LogMemory: Allocator Stats for binned:
      [2014.05.10-19.12.06:510][ 0]LogMemory: Current Memory 71.28 MB used, plus 8.85 MB waste
      [2014.05.10-19.12.06:510][ 0]LogMemory: Peak Memory 131.04 MB used, plus 4.32 MB waste
      [2014.05.10-19.12.06:510][ 0]LogMemory: Current OS Memory 80.13 MB, peak 135.36 MB
      [2014.05.10-19.12.06:511][ 0]LogMemory: Current Waste 1.60 MB, peak 3.20 MB
      [2014.05.10-19.12.06:511][ 0]LogMemory: Current Used 71.28 MB, peak 131.04 MB
      [2014.05.10-19.12.06:512][ 0]LogMemory: Current Slack 7.25 MB
      [2014.05.10-19.12.06:512][ 0]LogMemory: Allocs 141949 Current / 1257309 Total
      [2014.05.10-19.12.06:513][ 0]LogMemory:
      [2014.05.10-19.12.06:513][ 0]LogMemory: Block Size Num Pools Max Pools Cur Allocs Total Allocs Min Req Max Req Mem Used Mem Slack Mem Waste Efficiency
      [2014.05.10-19.12.06:514][ 0]LogMemory: ---------- --------- --------- ---------- ------------ ------- ------- -------- --------- --------- ----------
      [2014.05.10-19.12.06:514][ 0]LogMemory: 8 0 0 0 0 8 0 0K 0K 0K 100.00%
      [2014.05.10-19.12.06:515][ 0]LogMemory: 16 8 8 13754 123775 16 16 214K 298K 0K 100.00%
      [2014.05.10-19.12.06:515][ 0]LogMemory: 32 16 16 17673 124167 32 32 552K 472K 0K 100.00%
      [2014.05.10-19.12.06:516][ 0]LogMemory: 48 16 16 16726 82266 48 48 784K 240K 0K 100.00%
      [2014.05.10-19.12.06:516][ 0]LogMemory: 64 14 14 11999 91549 64 64 749K 147K 0K 100.00%
      [2014.05.10-19.12.06:517][ 0]LogMemory: 80 7 7 4195 72868 80 80 327K 121K 0K 100.00%
      [2014.05.10-19.12.06:517][ 0]LogMemory: 96 13 13 7599 77346 96 96 712K 120K 0K 100.00%
      [2014.05.10-19.12.06:518][ 0]LogMemory: 112 5 5 2700 32852 112 112 295K 25K 0K 100.00%
      [2014.05.10-19.12.06:518][ 0]LogMemory: 128 27 27 12907 48186 128 128 1613K 115K 0K 100.00%
      [2014.05.10-19.12.06:519][ 0]LogMemory: 160 16 16 4701 94012 144 160 734K 289K 33K 96.78%
      [2014.05.10-19.12.06:519][ 0]LogMemory: 192 29 29 9684 214680 176 192 1815K 40K 38K 97.95%
      [2014.05.10-19.12.06:520][ 0]LogMemory: 224 8 8 1885 102823 208 224 412K 99K 17K 96.68%
      [2014.05.10-19.12.06:520][ 0]LogMemory: 256 17 25 3875 67006 240 256 968K 120K 28K 97.43%
      [2014.05.10-19.12.06:521][ 0]LogMemory: 288 5 5 662 27129 272 288 186K 134K 6K 98.13%
      [2014.05.10-19.12.06:521][ 0]LogMemory: 320 8 8 1385 19226 304 320 432K 78K 11K 97.85%
      [2014.05.10-19.12.06:522][ 0]LogMemory: 384 68 68 11358 21517 336 384 4259K 76K 469K 89.22%
      [2014.05.10-19.12.06:522][ 0]LogMemory: 448 11 11 1503 4893 400 448 657K 46K 43K 93.89%
      [2014.05.10-19.12.06:523][ 0]LogMemory: 512 61 61 7736 12975 464 512 3868K 36K 165K 95.77%
      [2014.05.10-19.12.06:523][ 0]LogMemory: 576 6 6 217 2951 528 576 122K 260K 8K 97.92%
      [2014.05.10-19.12.06:524][ 0]LogMemory: 640 2 2 90 581 592 640 56K 72K 2K 98.44%
      [2014.05.10-19.12.06:525][ 0]LogMemory: 704 15 15 1340 1867 656 704 921K 39K 46K 95.21%
      [2014.05.10-19.12.06:525][ 0]LogMemory: 768 31 31 2567 4767 720 768 1925K 52K 48K 97.58%
      [2014.05.10-19.12.06:525][ 0]LogMemory: 896 22 22 1503 1961 784 896 1315K 91K 22K 98.44%
      [2014.05.10-19.12.06:526][ 0]LogMemory: 1024 6 36 64 2365 912 1024 64K 320K 1K 99.74%
      [2014.05.10-19.12.06:526][ 0]LogMemory: 1168 10 67 133 3960 1040 1168 151K 488K 10K 98.44%
      [2014.05.10-19.12.06:527][ 0]LogMemory: 1360 34 38 1310 4079 1184 1360 1739K 429K 150K 93.11%
      [2014.05.10-19.12.06:527][ 0]LogMemory: 1632 16 23 190 1736 1376 1632 302K 718K 14K 98.63%
      [2014.05.10-19.12.06:528][ 0]LogMemory: 2048 6 8 77 870 1648 2048 154K 230K 14K 96.35%
      [2014.05.10-19.12.06:528][ 0]LogMemory: 2336 89 89 2444 5425 2064 2336 5575K 110K 597K 89.52%
      [2014.05.10-19.12.06:529][ 0]LogMemory: 2720 4 5 24 578 2352 2720 63K 192K 3K 98.83%
      [2014.05.10-19.12.06:530][ 0]LogMemory: 3264 70 71 1231 3512 2736 3264 3923K 540K 251K 94.40%
      [2014.05.10-19.12.06:530][ 0]LogMemory: 4096 7 17 69 1411 3280 4096 276K 172K 28K 93.75%
      [2014.05.10-19.12.06:531][ 0]LogMemory: 4672 5 14 22 1660 4112 4672 100K 220K 4K 98.75%
      [2014.05.10-19.12.06:531][ 0]LogMemory: 5456 4 12 19 382 4688 5456 101K 155K 7K 97.27%
      [2014.05.10-19.12.06:532][ 0]LogMemory: 6544 5 8 29 190 5488 6528 185K 135K 15K 95.31%
      [2014.05.10-19.12.06:532][ 0]LogMemory: 8192 5 11 20 203 6560 8192 160K 160K 17K 94.69%
      [2014.05.10-19.12.06:533][ 0]LogMemory: 9360 5 11 28 181 8208 9360 255K 65K 16K 95.00%
      [2014.05.10-19.12.06:534][ 0]LogMemory: 10912 3 5 10 62 9408 10768 106K 86K 6K 96.88%
      [2014.05.10-19.12.06:534][ 0]LogMemory: 13104 4 4 16 57 11008 13056 204K 52K 14K 94.53%
      [2014.05.10-19.12.06:535][ 0]LogMemory: 16384 3 3 10 71 13120 16384 160K 32K 20K 89.58%
      [2014.05.10-19.12.06:535][ 0]LogMemory: 21840 9 18 14 233 16400 21840 298K 278K 34K 94.10%
      [2014.05.10-19.12.06:536][ 0]LogMemory: 32768 12 13 21 90 22048 32640 672K 96K 137K 82.16%
      [2014.05.10-19.12.06:537][ 0]LogMemory:
      [2014.05.10-19.12.06:537][ 0]LogMemory: 44928K allocated in pools (with 7448K slack and 2274K waste). Efficiency 94.94%
      [2014.05.10-19.12.06:538][ 0]LogMemory: Allocations 141791 Current / 1256463 Total (in 702 pools)
      [2014.05.10-19.12.06:539][ 0]LogMemory:
      [2014.05.10-19.12.09:109][ 0]LogWorld: Game class is 'EwClientFps_TeamDeathMatch'
      [2014.05.10-19.12.09:110][ 0]LogSockets:Warning: Failed to create socket SessionSocket [Unreal]
      [2014.05.10-19.12.09:112][ 0]LogInit: WinSock: Socket queue 131072 / 131072
      [2014.05.10-19.12.09:114][ 0]LogInit: WinSock: I am DevelopII (192.168.0.4:0)
      [2014.05.10-19.12.09:114][ 0]LogNet: GameNetDriver IpNetDriver_0 IpNetDriver listening on port 7777
      [2014.05.10-19.12.09:323][ 0]LogWorld:Warning: *** WARNING - PATHS MAY NOT BE VALID ***
      [2014.05.10-19.12.09:324][ 0]LogWorld: Bringing World /Game/Maps/Sector0.Sector0 up for play (max tick rate 30) at 2014.05.10-20.12.09
      [2014.05.10-19.12.09:324][ 0]LogOnline:Warning: NULL: AutoLogin missing LOGIN=<login id>.
      [2014.05.10-19.12.09:352][ 0]LogWorld: Bringing up level for play took: 0.234497
      [2014.05.10-19.12.09:353][ 0]LogInitisplay: Game Engine Initialized.
      [2014.05.10-19.12.09:354][ 0]LogLoad: Full Startup: 6.96 seconds (BP compile: 0.00 seconds)
      [2014.05.10-19.12.41:190][883]LogNet: NotifyAcceptingConnection: Server Sector0 accept
      [2014.05.10-19.12.41:190][883]LogNet: Open Sector0 05/10/14 20:12:41 192.168.0.4
      [2014.05.10-19.12.41:191][883]LogNet: Added client connection. Remote address = 192.168.0.4:59494
      [2014.05.10-19.12.41:192][883]LogNet: NotifyAcceptingChannel Control 0 server World /Game/Maps/Sector0.Sector0: Accepted
      [2014.05.10-19.12.41:192][883]LogNet: Remote platform little endian=1
      [2014.05.10-19.12.41:193][883]LogNet: This platform little endian=1
      [2014.05.10-19.12.41:223][884]LogNet: Login request: /Game/Maps/Sector0?Name=DevelopII-5C989E6D4CEFF0E2868115B2676282DF userId: DevelopII-5C989E6D4CEFF0E2868115
      B2676282DF
      [2014.05.10-19.12.41:224][884]LogNet: PreLogin failure: A maximum of '0' splitscreen players are allowed
      [2014.05.10-19.12.41:226][884]LogNet: UNetConnection::IsClientMsgTypeValid FAILED: (ClientMsgType != ExpectedClientLoginMsgType) Remote Address=192.168.0.4
      [2014.05.10-19.12.41:228][884]LogNet:Error: IsClientMsgTypeValid FAILED (4): Remote Address = 192.168.0.4
      [2014.05.10-19.12.41:229][884]LogNet:Error: Failed to read control channel message 'Netspeed'
      [2014.05.10-19.12.41:231][884]LogNet:Error: UControlChannel::ReceivedBunch: Failed to read control channel message
      [2014.05.10-19.12.41:232][884]LogNet: UNetConnection::Close: Name: IpConnection_0, Driver: GameNetDriver IpNetDriver_0, Owner: No Owner, RemoteAddr: 192.168.0.4
      :59494, Time: 2014.05.10-19.12.41
      [2014.05.10-19.12.41:232][884]LogNet: UChannel::Close: Sending CloseBunch. ChIndex == 0. Name: ControlChannel_0
      [2014.05.10-19.12.41:234][884]LogNetTraffic:Error: UChannel::ReceivedRawBunch: Bunch.IsError() after ReceivedNextBunch 1
      [2014.05.10-19.12.41:234][884]LogNetTraffic:Error: Received corrupted packet data from client 192.168.0.4. Disconnecting.
      [2014.05.10-19.12.41:256][885]LogNet: UNetConnection::Cleanup: Closing connection. Name: IpConnection_0, RemoteAddr: 192.168.0.4:59494 [GameNetDriver] [NoPC] [N
      o Owner] from CleanUp()
      [2014.05.10-19.12.41:256][885]LogNet: UNetConnection::Close: Already closed. Name: IpConnection_0
      [2014.05.10-19.12.41:257][885]LogNet: NotifyAcceptingConnection: Server Sector0 accept
      [2014.05.10-19.12.41:258][885]LogNet: Open Sector0 05/10/14 20:12:41 192.168.0.4
      [2014.05.10-19.12.41:259][885]LogNet: Added client connection. Remote address = 192.168.0.4:59494
      [2014.05.10-19.12.41:262][885]LogNetTraffic:Error: UNetConnection::ReceivedPacket: Received control channel close before open
      [2014.05.10-19.12.41:263][885]LogNet: UNetConnection::Close: Name: IpConnection_1, Driver: GameNetDriver IpNetDriver_0, Owner: No Owner, RemoteAddr: 192.168.0.4
      :59494, Time: 2014.05.10-19.12.41
      [2014.05.10-19.12.41:288][886]LogNet: UNetConnection::Cleanup: Closing connection. Name: IpConnection_1, RemoteAddr: 192.168.0.4:59494 [GameNetDriver] [NoPC] [N
      o Owner] from CleanUp()
      [2014.05.10-19.12.41:288][886]LogNet: UNetConnection::Close: Already closed. Name: IpConnection_1
      The last few lines are why I prefer Debug startup.. mind you this is very basic and just starting to get it configured properly..
      Haven't done any real work yet on the socket/udp connection/login, just getting it loading up and running from the base skeleton
      of the original shootergame sample.

      Comment


        #18
        Alright, here's what I did:
        • Package (not cook) ShooterGame for Windows to a directory i named ShooterPackaged
        • Compile ShooterGame 4.1 with Debug Server on Win64
        • Move ShooterGameServer-Win64-Debug.exe and the pdb to ShooterPackaged\WindowsNoEditor\ShooterGame\Binaries\Win64 (I cannot stress this step enough)
        • Open ShooterGame properties, go to "Debugging"
        • Set "Command" to C:\...\ShooterPackaged\WindowsNoEditor\ShooterGame\Binaries\Win64\ShooterGameServer-Win64-Debug.exe
        • Set "Command Arguments" to "-debug"
        • Set "Working Directory" to C:\...\ShooterPackaged\WindowsNoEditor\ShooterGame\Binaries\Win64
        • Start debugging
        • Get no asserts

        It's really as simple as that, there's no need to change anything.

        Comment


          #19
          Thats great and defeats the purpose of the designed system with sandboxed cooking..

          Plus you left out some information:

          Are you using the Binary Launcher 4.1(updated) version or the Source self-compiled version

          If the Source compiled, is it from the Zipped source or a clone, if a clone what verison? (Head / 4.1)

          Which points to an issue possibly with one of two things:

          Cooked/Sandbox has issues with server/client only builds
          OR
          Source compiled 4.1 is having issues that have been fixed in Head version (latest)

          Reason I say this as I am using the Source Self-Compiled Zipped 4.1 version
          Last edited by SteeleDriver; 05-11-2014, 07:36 PM.

          Comment


            #20
            which also in reference to the above, I also did attempt moving and changing those settings only to have the NMake
            settings from the build system changing my settings for Working Dir and Exe location to the intermediate dir structure
            thus making it impossible to set those to the correct dir.. so even if I did do a "Packaged" it still would fail as the
            Executeable is not found... So yeah, it looks like the current Zipped Source is having a problem.
            Thinking about it, I know they don't have Server Compile ability setup yet with binary launcher, so which version
            (Clone) are you using?
            Last edited by SteeleDriver; 05-11-2014, 07:59 PM.

            Comment


              #21
              Originally posted by SteeleDriver View Post
              Thats great and defeats the purpose of the designed system with sandboxed cooking..
              Is there a specific reason why you want to use sandboxed cooking? To be honest I don't even know what sandboxed cooking does or what it's used for. I thought you just wanted to step through the server code.

              Also I'm on 4.1.1, directly compiled from GitHub.

              Comment


                #22
                The point of using the sandbox is its designed for debuging.. Running the packaged (should be) for more finalized testing.

                Expection was Project files created give you multiple configurations for different stages of development and I expected them to work. The best I have been able to determine and after finding a few other posts I had missed, the provided enviroments do not all work...

                Pretty simple actually, they don't work even tho they have provided them. I've been working for quite a few years from Orge ending with T3D. T3D may not be as nice an engine but it has been far easier to work with and modify/debug then this has been by a big stretch. Being locked into naming conventions for projects I can live with as they have so much automated setups going, but I least expected if the generated project includes Debug Game / Debug Client / Debug Server, you would expect they would compile/load/debug... They don't

                The sandbox is to allow you to quickly make changes and just cook the current changes and run debug, current setup requires a full package after any changes to content to test those in Debug server mode. Not very efficient. The sandbox will work for Simplified games that have Non-Dedicated server setups, it is not a good setup for anything else yet. This is also an issue if you start splitting server / client code with the naming locks, at least it looks that way so far. Good example is running two debuggers to debug both client and server at the same time.

                Using T3D I currently already have a Master Server / Dedicated Game Server / Client all running at the same time with 3 instances of the debugger. Yes I do have a game in working condition, The Master Server code was my own creation from the base T3D code that connects to 2 different MySql databases and manages multiple instances of Dedicated servers transfering clients at login to the correct server. The code base I setup also is 3 completely seperate C++ code with duplicated Content. I create content in the editor, then just drop it in for the dedicated server to use. Mind you I dont do anything to the content (cooking) to protect the code yet at this time as it only needs to be protected on the client at a later date. The server doesnt need protected content.

                This code design has been giving me major headaches. I was expecting a really clean design coming over to UE4 and instead have been having to hunt for simple information like how to compile a Dedicated server and run it in Debug mode, not very impressive for such a well known engine.

                I was alos hoping this would be a simple thing to connect it to my Master Server system as it is all TCP Socket system, which means it isn't reliant on any specific code at either end, just correct tcp connections and data transfer, but the available information on the socket system is scarce to none. That is where debug mode comes in as you can test things easily and see when mistakes or issues come up. I do give a bg thumbs up to T3D and its network code, its clean and it works both UDP/Tcp... Its that simple and its well documented.

                *edit*
                One caveat, the provided project configurations may all work, just not easily without knowing things that are missing gems of valuable information for us the developers. For example: why is \localization dir not being copied over when I do a sandbox cook? I've looked and actually found one post about it, so maybe I've missed a step that others have done by accident? Mybe I just went in and did things like Unchecked or just compiled the game project instead of the whole solution. I don't expect I have to recompile the base engine as well every time I change something in the game source...
                Last edited by SteeleDriver; 05-12-2014, 04:02 PM.

                Comment


                  #23
                  Consider this my last post on this subject..

                  Full Packaging of the Game (ShooterGame) properly creates the WindowsNoEditor\engine\content\Localization dir.. so it is an issue it looks like with the SandBox Cooking system as it doesn't create it when you do the it with just the simple cooking.. So it doesn't look like it was anything I did!

                  Comment


                    #24
                    Sorry to see this without any feedback from Epic. I too have T3D background and it was a lot easier there for sure.

                    Comment


                      #25
                      Hi SteeleDriver, do you have any news on the subject. I'm having the same problem for a while now and just didn't use it because i thought it was bugged. Lets hope they fixed it for 4.3 as i would really like to launch the game in DebugGame configuration directly.

                      Comment

                      Working...
                      X