Announcement

Collapse
No announcement yet.

Post processing in Split-screen

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Post processing in Split-screen

    This is a long standing issue that has been reported many times. I've decided that instead of waiting for Epic to fix it I should look for ways to fix it myself or see if someone in the community would be willing to help fix it.

    To summarize, my main issue is that bloom does not work when you add a Split-screen player. This is bad because my game is split-screen only and has a tron type style to it. Tron without glowing lights is,.. well you get the idea.

    Could someone point me in the right direction on where to look to fix this? I'm pretty new at working with the engine code and I don't know where to start looking.


    Reports of the issue:
    https://answers.unrealengine.com/que...itscreen.html#
    https://answers.unrealengine.com/que...litscreen.html
    https://answers.unrealengine.com/que...t-working.html
    https://forums.unrealengine.com/show...in-Splitscreen

    #2
    Hi Voren
    Try it!

    UnrealEngine 4.8.1
    GameViewpoertClient.cpp
    line 851
    before:
    EngineShowFlagOverride(ESFIM_Game, (EViewModeIndex)ViewModeIndex, ViewFamily.EngineShowFlags, NAME_None, SplitScreenConfig != ESplitScreenType::None);
    after:
    EngineShowFlagOverride(ESFIM_Game, (EViewModeIndex)ViewModeIndex, ViewFamily.EngineShowFlags, NAME_None, false);

    However, this treatment is not formal. I want you to understand.

    Comment


      #3
      Originally posted by hiro12hiro View Post
      Hi Voren
      Try it!

      UnrealEngine 4.8.1
      GameViewpoertClient.cpp
      line 851
      before:
      EngineShowFlagOverride(ESFIM_Game, (EViewModeIndex)ViewModeIndex, ViewFamily.EngineShowFlags, NAME_None, SplitScreenConfig != ESplitScreenType::None);
      after:
      EngineShowFlagOverride(ESFIM_Game, (EViewModeIndex)ViewModeIndex, ViewFamily.EngineShowFlags, NAME_None, false);

      However, this treatment is not formal. I want you to understand.
      I do remember something, somewhere in the code mentioning that Motion Blur, Lens Flares and Bloom are disabled in Split Screen because they don't work correctly. I would try enabling them to see what happens. If it doesn't work you may have try make your own Bloom implementation using Post Process Blendable materials.

      Comment


        #4
        I changed the line provided above and it seems to work in splitscreen, I couldn't seen any strange things.
        Is there any information what exactly is not working correctly, because I also found in the source code that these effects are disabled because they are not working correctly but not what exactly happens.

        Comment


          #5
          The post-processing effect probably bleeds between viewports, but that's just a guess on my part. Splitscreens are probably rendered in one pass or something as an optimization.
          Last edited by Antidamage; 11-02-2015, 02:23 PM.

          Comment


            #6
            hey guys, i edited the gameviewportclient.cpp but nothing has happened. I pressed Save, but should I have compiled the file or rebuilt something in VS?

            i know its been more than 2 years but im facing this issue now on a 1-4 player local game

            Comment


              #7
              Yes, you need to select "development editor" from the build menu then hit run. That will load a new build of the UE editor and load your project. You'll need to continue using that build from now on, including packaging your game with it.

              Comment


                #8
                Antidamage

                Good to know, thanks for sharing...


                To Epic:

                This seems like overkill just to fix a hardcoded kill-switch that could be an Experimental / INI setting instead etc...
                To anyone else who agrees, and would like an easier solution than building UE4 from source, try upvoting here...

                Comment


                  #9
                  Originally posted by Antidamage View Post
                  Yes, you need to select "development editor" from the build menu then hit run. That will load a new build of the UE editor and load your project. You'll need to continue using that build from now on, including packaging your game with it.
                  Where do I find this development editor option? Is this in VS 2017 because I don't see it, or is it in UE4 itself.. im sorry, ive been working for about 2 years with ue4 but i don't know about this, are you refering also to a custom build of ue4 from github source or can this apply to my "default" downloaded from launcher ue4.16.2?

                  Comment


                    #10
                    You must have a source build in order to edit engine source files like in your description above, otherwise there's nothing to edit. The launcher build only comes with header files.

                    The option you want is here (it might be named a bit differently as this is from my game's VS code project), but make sure you're building the engine and not your game project:



                    The difference between a source build of the engine and a code project for a game is a bit confusing, but you figure it out eventually.

                    To be clear: if you modify the engine source and compile it, it will create a new Unreal Engine Editor binary that isn't the same version as 4.18.3 or 4.19. It's a custom build. You'll have to import your game project to that version of the editor and you won't be able to load your project using the launcher anymore, so stick the new editor on your taskbar.
                    Last edited by Antidamage; 02-10-2018, 02:43 AM.

                    Comment


                      #11
                      Originally posted by Antidamage View Post
                      You must have a source build in order to edit engine source files like in your description above, otherwise there's nothing to edit. The launcher build only comes with header files.

                      The option you want is here (it might be named a bit differently as this is from my game's VS code project), but make sure you're building the engine and not your game project:



                      The difference between a source build of the engine and a code project for a game is a bit confusing, but you figure it out eventually.

                      To be clear: if you modify the engine source and compile it, it will create a new Unreal Engine Editor binary that isn't the same version as 4.18.3 or 4.19. It's a custom build. You'll have to import your game project to that version of the editor and you won't be able to load your project using the launcher anymore, so stick the new editor on your taskbar.
                      understood. Thank you, so much!

                      Comment

                      Working...
                      X