Announcement

Collapse
No announcement yet.

Compile/Convert Project with Updated Engine - Never Works

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Compile/Convert Project with Updated Engine - Never Works

    If I ever install an upgraded version of UE4 the conversion never works. I have to make a new project, re-import everything, etc. Takes ages.

    Why is the feature there if it doesn't ever work? Even basic/new projects fail.

    Code:
    1>------ Build started: Project: SurviveP, Configuration: Development_Editor x64 ------
    1>  Performing 1 actions (4 in parallel)
    1>  [1/1] Link UE4Editor-UE4Game.dll
    1>LINK : fatal error LNK1104: cannot open file 'D:\Development\UE46\Engine\Binaries\Win64\UE4Editor-UE4Game.dll'
    1>  -------- End Detailed Actions Stats -----------------------------------------------------------
    1>ERROR : UBT error : Failed to produce item: D:\Development\UE46\Engine\Binaries\Win64\UE4Editor-UE4Game.pdb
    1>  Cumulative action seconds (8 processors): 0.00 building projects, 0.00 compiling, 0.00 creating app bundles, 0.00 generating debug info, 0.10 linking, 0.00 other
    1>  UBT execution time: 9.64 seconds
    1>C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V120\Microsoft.MakeFile.Targets(38,5): error MSB3073: The command "D:\Development\UE46\Engine\Build\BatchFiles\Build.bat SurvivePEditor Win64 Development "D:\Projects\UE4\Survive\Code\SurviveP\SurviveP.uproject"" exited with code -1.
    ========== Build: 0 succeeded, 1 failed, 1 up-to-date, 0 skipped ==========

    #2
    You might want to try removing the "Read Only" flag from your binaries.

    -Camille

    Comment


      #3
      They aren't read only.

      Edit:

      I changed read-only to off already but didn't check after - it keeps turning back on. :/
      Last edited by Vaei; 12-13-2014, 12:38 AM.

      Comment


        #4
        Right, so, anyone know how to fix this?

        Comment


          #5
          I have the same problem, I thought it was just me being a source code noob. Maybe it's both of us being a source code noob. Who knows!

          Definitely put this in the feedback forum and answerhub when you get the chance. If you tag it "bug report" they'll put it in their pocket to look into.
          iTween For UE4
          Procedural pathed animation for actors, components & UMG - $0
          Runtime DataTable
          DataTables dynamically loaded from text or Google Sheets while your game is running!
          easyCSV
          Fast, cheap, and accurate CSV parsing at runtime!

          Comment


            #6
            Originally posted by Vaei View Post
            I changed read-only to off already but didn't check after - it keeps turning back on. :/
            Well that's weird. Perforce requires files to be read-only by default, so it might be a bug in UE4's perforce management... Though it shouldn't really matter if you don't have perforce to begin with.

            Comment


              #7
              Originally posted by Jared Therriault View Post
              I have the same problem, I thought it was just me being a source code noob. Maybe it's both of us being a source code noob. Who knows!

              Definitely put this in the feedback forum and answerhub when you get the chance. If you tag it "bug report" they'll put it in their pocket to look into.
              I'll do it, but I'm not entirely sure what to put exactly. Can't convert because of error in OP and unable to set read only flags off? Or is the last part not important?

              PS: Very likely that we're both source code noobs.

              Comment


                #8
                Originally posted by cmartel View Post
                Well that's weird. Perforce requires files to be read-only by default, so it might be a bug in UE4's perforce management... Though it shouldn't really matter if you don't have perforce to begin with.
                Yeah, I can't disable them. I thought it was the desktop.ini file staying read-only due to being a system file but using the command 'attrib -r -s C:/UE4/Path /S /D' did no better. Edit: NM doesn't have one there.

                Edit2:

                None of the files are read only. But the folders say items within are read only even at the lowest level??
                Last edited by Vaei; 12-13-2014, 06:24 PM.

                Comment


                  #9
                  I'm having this problem too, when upgrading from 4.5 to 4.6. My Project builds fine in VS2013, but doing the upgrade from the ue4 launcher fails.

                  Comment

                  Working...
                  X