Announcement

Collapse
No announcement yet.

Visual Studio 2013 Intellisense is REALLY slow

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    @roxez
    I don't think Epic puts any restrictions on which IDE you can use with UE4. Why would they?
    I personally try to build UE4 from source with intel'c compiler and use QT as an IDE. Why? Because they are heavens better in every aspect than Visual Studio.
    Regards

    Comment


      #17
      Originally posted by roxez View Post
      I'm sorry as I haven't bought UE4 yet, therefore I'm not sure if there is any restrictions that would not allow to work on other IDEs.

      but why should one not expecting it? there are few good IDE that can be used as an alternative.


      regardless, I never really liked VAX for its slow parsing. but I still use it for UDK projects, and since adapted to it.
      I mean you can use other IDEs for sure since you have source code,but what I try to say is Epic will most likely not support them like they do VS.

      Comment


        #18
        @arkenthera
        "Epic will most likely not support them like they do VS."

        For now. Times are changing. Horizons broaden.
        The thing is that VS has been for use for a while and for big companies it is difficult to switch, but there are better IDE's (and compilers) than VS and there may come a time where Epic decides to go with better software than VS. Just like they decided that it is worth to target Linux (and other OS) not just windows.
        You never know.

        @roxez
        I'm working on compiling UE4 with intel's compiler (which is far superior to VS) and QT as an IDE (which is far superior to VS), so when I'm done, I'm going to post tutorial on how to do it so people can see why you should always try different things and decide for yourself what's best. Just because Epic uses VS and Maya it doesn't necessarily means that those tools are best.
        Last edited by smallB; 04-10-2014, 02:26 AM.

        Comment


          #19
          It should be very easy to use different ide's . As far as I have seen they don't even use VS for project management. They are just calling different .bat files.

          Comment


            #20
            Originally posted by smallB View Post
            @arkenthera
            "Epic will most likely not support them like they do VS."

            For now. Times are changing. Horizons broaden.
            The thing is that VS has been for use for a while and for big companies it is difficult to switch, but there are better IDE's (and compilers) than VS and there may come a time where Epic decides to go with better software than VS. Just like they decided that it is worth to target Linux (and other OS) not just windows.
            You never know.

            @roxez
            I'm working on compiling UE4 with intel's compiler (which is far superior to VS) and QT as an IDE (which is far superior to VS), so when I'm done, I'm going to post tutorial on how to do it so people can see why you should always try different things and decide for yourself what's best. Just because Epic uses VS and Maya it doesn't necessarily means that those tools are best.
            I'm really looking forward to read your experiences about that.
            I've tried the Visual Assist 30 Day trial and yes it's faster ven VSs intellisense, but feature wise, it's just stuff that is free and built in other IDEs like Qt or even Eclipse with the C++ plugin. Paying an extra of 99$ for a personal or 249$ for a commercial license, is just way out of my budget and I guess of many others' too.

            Comment


              #21
              I'm highly doubtful Epic Games will switch IDEs. They are stuck for the same reason pretty much everyone else sticks to VS. It's because the Console vendors write extensions for Visual Studio.

              This doesn't mean you can't come up with your own solutions but have fun when its time to port to consoles

              You can always at least edit in another IDE though. Shouldn't be too bad. Only use VS for debugging

              [edit] People posted good suggestions in the other thread similar to this one
              Last edited by sandboxgod; 04-10-2014, 05:23 PM.
              Godz for UT '99 / UT 2003

              Comment


                #22
                I'm in the same position, none of the solutions suggested so far has worked for intellisense (the build times fix did work awesomely though).
                I'm running an i5-3570K, 16GB of RAM and an SSD, so I'm pretty sure it's not a hardware problem.

                Also, sometimes it seems the whole setup gets confused, i.e. strange compile errors, and a simple restart of Visual Studio (without changing any code) fixes it.
                I must say this is making it quite hard, especially being new to C++. In addition to considering my own questionable C++ skills, I must take Visual Studio's feedback with a pinch of salt.

                Intellisense usually kicks in after I've finished typing all the code that I want before compiling, and then squiggles start showing me errors which go away when compiling.

                Comment


                  #23
                  same here, the intelisense works when it wants and it is very slow.
                  http://www.enzoravo.com

                  Comment


                    #24
                    Try going to Tools->Options->Text Editor->C/C++->Advanced

                    Under the Intellisense tab set "Disable Auto Updating" to True.

                    This should help a bit (it stops the update of the intellisense whenever you change something which is why the thing is slow in the first place), however note that your intellisense might get out of date if you change bunch of stuff (usually it isn't a problem)

                    Comment


                      #25
                      Originally posted by Zinus View Post
                      Try going to Tools->Options->Text Editor->C/C++->Advanced

                      Under the Intellisense tab set "Disable Auto Updating" to True.

                      This should help a bit (it stops the update of the intellisense whenever you change something which is why the thing is slow in the first place), however note that your intellisense might get out of date if you change bunch of stuff (usually it isn't a problem)
                      How do you manually update, if you turn that off?
                      It is by will alone I set my code in motion.
                      It is by coding that thoughts acquire speed, the hands acquire shaking, the shaking becomes a warning.
                      It is by will alone I set my code in motion.

                      Comment


                        #26
                        Originally posted by dmacesic View Post
                        How do you manually update, if you turn that off?
                        From MS website

                        Disable Auto Updating

                        IntelliSense updating is delayed until an actual request for IntelliSense is made. This delay can result in a longer execution time of the first IntelliSense operation on a file, but it may be helpful to set this option on very slow or resource-constrained machines. If you choose this option, you also implicitly choose the “Disable Error Reporting” and “Disable Squiggles” options.

                        I never encountered problems by disabling this option and it boosted the speed of the intellisense significantly (the first request is still very slow, all subsequent ones are instant on my pc).
                        If it starts creating problems you can always just re-enable the option, wait for it to update and then disable it again (vanilla solutions ftw ^^ )!
                        I know that it has to update at least once when you open your project, but I'm not sure whats the criteria for subsequent updates, and I couldn't find the answer for that either.

                        All in all, you should be good to leave it disabled. It still has to update whenever you start VS2013 and start your project so it won't get out of date.

                        Comment


                          #27
                          Make sure you disable any 3rd party plugins. sometimes 3rd party plugins cause this.

                          For example i used to have the same problem becuase i had CodeMap plugin enabled.

                          That being said, visual studio 2013 isa bit slow, but you should not be having the problems you are describing

                          interesting read on visual studio C++ performance : http://yosoygames.com.ar/wp/2013/12/...visual-studio/

                          Comment


                            #28
                            For me, I tried to disable auto-update and set max translation units to 10 and the intellisense seems a lot more responsive (I'll happily let it take 1GB of RAM for the speed)

                            From Microsoft site:
                            Max Cached Translation Units
                            The maximum number of translation units that will be kept active at any one time for IntelliSense requests. You must specify a value between 2 and 15. This number directly relates to the maximum number of VCPkgSrv.exe processes that will run (for a given instance of Visual Studio). The default value is 2, but if you have available memory, you can increase this value and possibly achieve slightly better performance on IntelliSense.

                            Comment


                              #29
                              Typically when IntelliSense is acting really slow I do a quick compile with a simple error and then everything starts to work rather quickly after that. It's probably the fastest way then waiting for it.

                              int a = 15.0; // This pretty much does it since my compile times are around 2.6 seconds.
                              Third Person Camera Zoom Tutorial, Click Me!

                              Comment


                                #30
                                My major issue is that Intellisense spawns several "vcpkgsrv.exe" processes that are about 1 GB in size each. With 2 VS instances open, my 16 GB RAM gets eaten up in no time.
                                It is by will alone I set my code in motion.
                                It is by coding that thoughts acquire speed, the hands acquire shaking, the shaking becomes a warning.
                                It is by will alone I set my code in motion.

                                Comment

                                Working...
                                X