Announcement

Collapse
No announcement yet.

Components Reseting on Copy

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Components Reseting on Copy

    I've created a c++ class actor with a static mesh component and a few other components that I subclassed into blueprints and when I place the blueprint in the scene it's fine, but when I then alt drag or copy paste the actor in the scene it seems that all the components get reset. They're not even reset to the the blueprint configuration or even how it is in c++. For example, in the copied version, the static mesh assigned to the component disappears as well as all of the scaling and the visibility is turned off for some reason. Anyone know what is happening? Pictures attatched

    Class Declaration
    Click image for larger version

Name:	Declaration.png
Views:	31
Size:	106.9 KB
ID:	1829325

    Constructor:
    Click image for larger version

Name:	constructor.png
Views:	22
Size:	86.6 KB
ID:	1829326


    Blueprint Class. Static mesh has been assigned and a small transform is assigned. Notice visibility is on for the mesh
    Click image for larger version

Name:	BPEditor.png
Views:	23
Size:	458.9 KB
ID:	1829327


    The dragged in blueprint is on the left and the copy is on the right, selected with no mesh, visibility turned off, and transforms reset . As soon as I make a copy all of this happens.Click image for larger version

Name:	MainEditor.png
Views:	22
Size:	628.3 KB
ID:	1829328

    So yeah, anyone know why this is happening?
    Attached Files
Working...
X