Announcement

Collapse
No announcement yet.

Could not package a project

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Could not package a project

    Hi, i'm getting the following error while trying to build project for Windows x64:

    UATHelper: Packaging (Windows (64-bit)): ERROR: Missing precompiled manifest for 'EditorWidgets'. This module was most likely not flagged for being included in a precompiled build - set 'PrecompileForTargets = PrecompileTargetsType.Any;' in EditorWidgets.build.cs to override.
    PackagingResults: Error: Missing precompiled manifest for 'EditorWidgets'. This module was most likely not flagged for being included in a precompiled build - set 'PrecompileForTargets = PrecompileTargetsType.Any;' in EditorWidgets.build.cs to override.

    I disabled all my plugins, didnt work, i deleted all my plugins, didnt help either, after that i tried to redact EditorWidgets.build.cs as message suggests(correct me if i did that wrong), but nothing changed. Didnt find any useful info on google, help please.

    Code:
    using UnrealBuildTool;
    
    public class EditorWidgets : ModuleRules
    {
        public EditorWidgets(ReadOnlyTargetRules Target) : base(Target)
        {
            PrecompileForTargets = PrecompileTargetsType.Any;
    
            PrivateIncludePathModuleNames.Add("AssetRegistry");
    
                PrivateDependencyModuleNames.AddRange(
                    new string[]
                    {
                        "Core",
                        "CoreUObject",
                        "Engine",
                        "InputCore",
                        "Slate",
                        "SlateCore",
                        "EditorStyle",
                        "UnrealEd"
                    }
                );
    
                DynamicallyLoadedModuleNames.Add("AssetRegistry");
        }
    }
Working...
X