Announcement

Collapse
No announcement yet.

[FIXED] Vivox Integration Unhandled Exception

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    [FIXED] Vivox Integration Unhandled Exception

    Good evening

    I've managed to integrate the Vivox Plugin into my project. Everything works ok in editor but when I package the project into a windows 64/86 application I get a "Fatal Error!" windows.
    I spent the whole day trying to figure out what it is but I can't. Logs show the following error:

    Code:
    Fatal error!
    
    Unhandled Exception: 0xc06d007e
    
    0x00007ffb8082a839 KERNELBASE.dll!UnknownFunction []
    0x00007ff6b29f9406 VRLounge-Win64-DebugGame.exe!__delayLoadHelper2() [d:\agent\_work\2\s\src\vctools\delayimp\delayhlp.cpp:323]
    0x00007ff6b22f4aef VRLounge-Win64-DebugGame.exe!_tailMerge_vivoxsdk_x64_dll() []
    0x00007ff6ae59e04c VRLounge-Win64-DebugGame.exe!ClientImpl::Initialize() [c:\work\vrlounge\plugins\vivoxcoreue4plugin\source\vivoxcore\private\clientimpl.cpp:91]
    0x00007ff6aea2c1e5 VRLounge-Win64-DebugGame.exe!UVRLoungeGameInstanceCPP::Initialize() [c:\work\vrlounge\source\vrlounge\vrloungegameinstancecpp.cpp:126]
    0x00007ff6aea2bff5 VRLounge-Win64-DebugGame.exe!UVRLoungeGameInstanceCPP::Init() [c:\work\vrlounge\source\vrlounge\vrloungegameinstancecpp.cpp:76]
    0x00007ff6b12cbc02 VRLounge-Win64-DebugGame.exe!UGameEngine::Init() []
    0x00007ff6ae524845 VRLounge-Win64-DebugGame.exe!FEngineLoop::Init() []
    0x00007ff6ae53a88e VRLounge-Win64-DebugGame.exe!GuardedMain() []
    0x00007ff6ae53aaba VRLounge-Win64-DebugGame.exe!GuardedMainWrapper() []
    0x00007ff6ae54b8d0 VRLounge-Win64-DebugGame.exe!WinMain() []
    0x00007ff6b29f4e42 VRLounge-Win64-DebugGame.exe!__scrt_common_main_seh() [d:\agent\_work\2\s\src\vctools\crt\vcstartup\src\startup\exe_common.inl:288]
    0x00007ffb83707bd4 KERNEL32.DLL!UnknownFunction []
    0x00007ffb838cced1 ntdll.dll!UnknownFunction []
    I don't understand why it's trying to read anything from d:/agent/... since I don't even have that drive.

    I googled this specific problem and i found it associated with a Magic Leap issue found here https://issues.unrealengine.com/issue/UE-69422 but disabling magic leap and all other vr/ar plugins didn't help at all.

    Anyone have any ideia what might be happening?


    [EDIT]
    The post with the error about magic leap made me look into other possible plugins that might be causing the problem. So I desabled them all. Except the ones i really needed and still the porblem persisted. But then I found I had two vivox plugins. The one I added as per vivox recomendations and a build-in one. When I disabled the built in one the error stoped happening It was a tiresome day but I'm happy to have solved this. Thank you.

    Last edited by AtomR; 11-13-2019, 07:28 PM.
Working...
X