Announcement

Collapse
No announcement yet.

Can't package plugin: iOS remote compilation error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Hello,

    I've made a plugin and i want to package it for IOS too, i've already set up remote build and it's working fine, when I package my project containing my plugin it package fine and works fine, but when i try to package the plugin by itself I got the same error mentioned above :

    ERROR: Remote compiling requires a server name. Use the editor (Project Settings > IOS) to set up your remote compilation settings.

    I'm using a win10 pc and a macboock pro for the remote build.

    So is there a way to package my plugin for iOS so i can distribute it on the marketplace ?

    thanks !

    Leave a comment:


  • replied
    Originally posted by Agln View Post
    what will happen if someone tries to make an iOS game with my plugin where iOS is not whitelist ?
    Then they will need to actually setup the remote compiling . Im sure there is a how-to on the docs, i have never used it so not sure how big of pain it is to get working.

    Leave a comment:


  • replied
    Originally posted by Lambdarevolution View Post
    You need to whitelist the platforms you want your plugin to work on otherwise it will try to compile to all including ios. This has been the case for a very long time but here is how you whitelist: https://wiki.unrealengine.com/How_To...gin_White_List

    Edi: Your text is so grey i could not read it, but white listing is working. If your 100% sure it is not working you can modify the BuildPluginCommand.Automation.cs to make sure it's not trying to remotecompile.
    Thanks, indeed after trying again it now works, what will happen if someone tries to make an iOS game with my plugin where iOS is not whitelist ?

    As for the text thing I believe it's because i'm using dark theme, I also have this issue sometime but the text is all black

    Leave a comment:


  • replied
    You need to whitelist the platforms you want your plugin to work on otherwise it will try to compile to all including ios. This has been the case for a very long time but here is how you whitelist: https://wiki.unrealengine.com/How_To...gin_White_List

    Edi: Your text is so grey i could not read it, but white listing is working. If your 100% sure it is not working you can modify the BuildPluginCommand.Automation.cs to make sure it's not trying to remotecompile.
    Last edited by Lambdarevolution; 06-13-2019, 11:07 PM.

    Leave a comment:


  • replied
    Same issue. Related code:

    https://github.com/EpicGames/UnrealE...oteMac.cs#L154

    I'm investigating.

    Leave a comment:


  • started a topic Can't package plugin: iOS remote compilation error

    Can't package plugin: iOS remote compilation error

    Hi, I've created an empty plugin and when I try to package it (with no modifications) I get the following error:

    Code:
    ERROR: Remote compiling requires a server name. Use the editor (Project Settings > IOS) to set up your remote compilation settings.


    I've tried to whitelist only Win32 and Win64, or blacklist iOS and TVOS, to remove IOS, Mac, TVOS, Desktop from the packaged plateforms but nothing works. My build.cs contain "Core" as public dependency and "CoreUObject, Slate, SlateCore, Engine" as private dependencies
Working...
X