Announcement

Collapse
No announcement yet.

[SOLVED] fatal error C1853 on Plugin Packaging only

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    I can confirm the solution to only have the latest Windows 10 SDK checked in the Visual Studio Installer worked for me.

    I feel better information to the developer is needed. The information provided by the error is misleading: "precompiled header file is from a previous version of the compiler, or the precompiled header is C++ and you are using it from C (or vice versa)". In this particular case, Visual Studio is updated, and for some reason, Unreal can compile projects the same, but cannot continue to package plugins, even a simple templated plugin with no changes to the original auto-created code.
    Last edited by erol_demirci; 01-27-2020, 07:38 PM.

    Comment


      #17
      Originally posted by jman2015 View Post
      Deleting Build, Intermediate, Saved and Visual Studio .sln file then rebuilding worked for me.
      That solved for me!
      Thanks jman2015!

      Comment


        #18
        Originally posted by jman2015 View Post
        Deleting Build, Intermediate, Saved and Visual Studio .sln file then rebuilding worked for me.
        Thank you, this fixed the same error for me ! I didn't delete Saved, because in my case, that gave me an error when right-clicking .uproject, Generate Visual Studio Project Files.
        After that, in visual studio 2017, I right-clicked the game project, Set as Startup Project, Ctrl+F5, Packaged from the editor and it worked !

        Comment


          #19
          I solved it too with repair the visual studio from visual studio installer.

          Comment


            #20
            The cause of this problem is probably that you update your visual studio.

            the solution is very simple, dont have to reinstall your vs and engine, all you have to do is go to you engine install folder and find

            \UE_4.21\Engine\Intermediate\Build\Win64\UE4Editor\Development\Engine\SharedPCH.Engine.h.pch

            Delete it.

            Then delete Build, Intermediate,save folder in your project (inclue intermediate in your plugin).

            right click .uproject, rebuild Visual Studio .sln.

            then your project will be allright to package

            Comment

            Working...
            X