Announcement

Collapse
No announcement yet.

Can't create C++ project

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Can't create C++ project

    Hello,

    I know there is much about it, but all night googling brought nothing... I installed yesterday UE for the first time and wanted to start new C++ project, but creating new project end up in compile error (see image).

    The most answers was about make sure, that I have installed in Visual Studio:
    - Desktop development with .NET
    - Desktop development with C++
    - Game development with C++

    And windows 8.1 SDK, sometimes unreal engine installer inside VS. All of this I make sure that is installed with my visual studio, tried even to reinstall VS, but I'm still stuck on this compile error. Also I look in documentation, but there was too nothing new...

    Though I can read more from mentioned log file in error, but I couldn't locate it... Seems like there is error because of file SharedPCH.Engine.h.pch, which was not found.

    What are another options to make C++ project working with UE?

    #2
    So tried uninstall UE and VS. Installed VS, with all recommended components, installed VS, also installed UnrealVS extension, but still can't move through the first time compile, when I try create project c++ in UE...

    How have you visual studio configured to successfuly create C++ project in UE...? I don't know what more to do to got this work...

    I got UE 4.2.02 and VS 2017 Community.

    Comment


      #3
      Try to Re-generate VisualStudio project files, it seems that you're missing SharedPCH.Engine.h.pch file.

      Comment


        #4
        How can I re-generate files?

        Comment


          #5
          Right-click on your MyProject2 Unreal Engine Project File in your MyProject2 folder, and select Generate Visual Studio project files.

          Comment


            #6
            I can't find that option... Where is it? If it's inside unreal editor I can't do it, i just can't open project in UE, because it needs to build/rebuild it...

            Comment


              #7
              The "MyProject2" Unreal Engine Project File is in the "F:\Osobní\Documenty\Unreal Projects\MyProject2" folder.
              Last edited by Phantas; 08-24-2018, 10:58 AM.

              Comment


                #8
                Oh yea... Right click on the uproject in windows explorer... I was searching everywhere around Unreal Editor...

                Comment


                  #9
                  But this didn't help... Still stucked on the same error.

                  When try to generate sources, I see there is some error with folder, that doesnt exist... And it's some folder in VS2015, isn't error here? I have on my computer VS2017 but apparantly it is try to use 2015.
                  Attached Files
                  Last edited by JayZet; 08-24-2018, 11:55 AM.

                  Comment


                    #10
                    Can you show me the whole sentence? "Directory "~" does not ..." what else?

                    OK, in the DefaultEngine.ini (F:\Osobní\Documenty\Unreal Projects\MyProject\Config) under the '[/Script/WindowsTargetPlatform.WindowsTargetSettings]'
                    what is used as compiler? Anything else than 'Default'? VS2017 is default for UE 4.20.
                    Last edited by Phantas; 08-24-2018, 12:50 PM.

                    Comment


                      #11
                      In DefaultEngine I have only:
                      [URL]
                      [/Script/HardwareTargeting.HardwareTargetingSettings]
                      TargetedHardwareClass=Desktop
                      DefaultGraphicsPerformance=Maximum


                      The error message end with "does not exists."

                      Comment


                        #12
                        Wierd.
                        Is that a new project?

                        Anyway, you can copy/paste there this to see if that helps

                        [/Script/WindowsTargetPlatform.WindowsTargetSettings]
                        Compiler=Default
                        Last edited by Phantas; 08-24-2018, 02:43 PM.

                        Comment


                          #13
                          Yes, I opened Unreal Engine, and under New Project i selected C++ and created Basic Code template... That's all...

                          Otherwise, even this still didn't help...

                          Comment


                            #14
                            You obviously tried verify our UE instalation, VS 2017 aswell, you never had VS 2015 and still can't create a project.
                            Probably because you have those programs installed on F:\ and not on C:\ ??

                            Comment


                              #15
                              All installed correctly... With 2015 i'm not sure If i ever had this version on my computer, but found something after Unity... So I uninstalled, also cleared registry... But still no change, there is obviously error with generating files, that mentioned not existing folder VS2015... If I try to rebuild, it will correctly locate everything..

                              By default I had VS on C, but this disc is just small system SSD, so there is no much space to waste and after reinstall there was no choice, to install it on my main disc.

                              Comment

                              Working...
                              X