Announcement

Collapse
No announcement yet.

FMatrix::Inverse() Error on Build

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Oh wow, okay, that's quite strange then. Can't say I have any idea what's going on there.

    Leave a comment:


  • replied
    Originally posted by TheJamsh View Post
    Thought I replied to this yesterday but must have forgotten to hit Post...

    I started having this issue when using an FRotator the other day, though I can't remember exactly where the issue stemmed from. I ended up re-writing the code and using the Rotator differently, though it required quite a few more lines to get it working :/
    Thanks for the reply. Unfortunately this project doesn't actually have any C++ code. I probably shouldn't have posted it here, but I figured the coder forum was the best place for an ambiguous debug message like this...

    I've pored through all my blueprints and whatnot, and not found anything that is using rotators at all, so I can't see where this is coming from. The only rotation I was doing was to reset the HMD yaw to 180 degrees - deleting and recompiling that part of the level blueprint hasn't had any effect

    Leave a comment:


  • replied
    Thought I replied to this yesterday but must have forgotten to hit Post...

    I started having this issue when using an FRotator the other day, though I can't remember exactly where the issue stemmed from. I ended up re-writing the code and using the Rotator differently, though it required quite a few more lines to get it working :/

    Leave a comment:


  • replied
    Here's the kicker, it isn't a C++ project - its entirely blueprint based. So I'm not actually calling that function anywhere...

    That's the weird part

    Leave a comment:


  • replied
    Any idea where you're calling FMatrix::Inverse that it's getting a nil matrix?

    If you can't figure out why/where a nil matrix is being passed, just replace the call in that location to FMatrix::Inverse with FMatrix::InverseSafe - it should check for nils, unlike the regular Inverse (that's what the error message is saying, anyway).

    Leave a comment:


  • started a topic FMatrix::Inverse() Error on Build

    FMatrix::Inverse() Error on Build

    Not 100% sure if this is the right forum, but there we go...

    I recently migrated a project from 4.2 to 4.4.1 in light of the new OVR SDK - since we need this project working with the DK2 and the other 4.4.1 updates. However, on trying to build, I'd run into a plethora of issues. I've managed to go through and fix everything, with the exception of one error which I can't see where is coming from...

    Code:
    MainFrameActions: Cooking (Windows): UE4Editor-Cmd: [2014.08.27-12.04.59:073][  0]LogInit:Display: LogUnrealMath:Error: FMatrix::Inverse(), trying to invert a NIL matrix, this results in NaNs! Use InverseSafe() instead.
    Any ideas?


    (I've got a question on the Answerhub as well, but this is a time-sensitive problem - we have a client brief in the next 7 days - so I figured I'd hedge my bets and get it posted up here too)
    https://answers.unrealengine.com/que...-on-build.html
Working...
X