Announcement

Collapse
No announcement yet.

Understanding Workflow - UE4, Visual Studio 2017

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Understanding Workflow - UE4, Visual Studio 2017

    Since I'm attempting to write my own C++ code, I'm posting this here.

    I come from a former Unity shop, where using Monodevelop meant compile in the IDE, then attempt to run the game in the Unity editor to see your changes.

    WIth UE4, this obviously changes. I've installed Microsoft Visual Studio 2017 (2), I'm using Unreal Engine v4.19.2 for my project. I'm deploying to a variety of devices, so the targets are set for "All". Occasionally I'll push a build to my Android device for a quick test -- but that part is working fine, so I'm not asking that here.

    When you use the "Compile" button on the UE4 Editor, it does its magic and pushes files into the appropriate project folders.

    With MS Visual Studio 2017, you make your code changes and select to Build your project, ostensibly the same thing happens.

    The crux of the question is:

    Is the flow from Visual Studio ---> UE4 Editor/Engine automatic provided you've used Build--->Configuration Manager properly?

    I'm selecting "DebugGame Editor" for Active Solution, and under Project Contexts - Configuration DebugGame_Editor (For my current project) Platform: Win64, and "Build" is checked. UE4 has configuration "BuiltWithUnrealBuildTool" Platform: Win32, Build NOT checked.

    This gets me a good build in Visual Studio 2017 - the log window indicates as much, but the UE4 Editor doesn't seem to know that anything has changed.

    I've read through the material in setting up Visual Studio and working with UE4, but I still think I'm getting something mixed up or totally wrong here.

    How does the process actually work? I haven't stumbled on the relevant docs if they exist.

    I'd appreciate any pointers since this is driving me slowly insane.


    #2
    UE4 usually detects if a new module is built and does an automatic hot reload.
    If that doesnt happen by default try using the manual hot reload (Compile button at the top of the editor) instead of building in visual studio

    If for some reason hot reload doesnt work at all you will need to restart the editor in order for the changes in code to be applied.

    Also for variables and functions (UPEOPERTY / UFUNCTION) to show up in the visual/blueprint editor it needs to be restarted (doen't matter you used hot reload or not).

    Comment


      #3
      The Editor hot reload uses non-debug builds, if you want the editor to run a debug build you should start it from within VS with F5.

      Comment

      Working...
      X